ruby-rouge_1.10.1-1_all.deb


Advertisement

Description

ruby-rouge - pure-Ruby syntax highlighter compatible with pygments

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-rouge
Package version: 1.10.1
Package release: 1
Package architecture: all
Package type: deb
Installed size: 745 B
Download size: 147.54 KB
Official Mirror: archive.ubuntu.com
Rouge is a pure-Ruby syntax highlighter. It can highlight over 60 languages, and output HTML or ANSI 256-color text. Its HTML output is compatible with stylesheets designed for pygments.

Alternatives

    Download

    Source package: ruby-rouge

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-rouge deb package:
      # sudo apt-get install ruby-rouge

    Files

    • /usr/bin/rougify
    • /usr/lib/ruby/vendor_ruby/rouge.rb
    • /usr/lib/ruby/vendor_ruby/rouge/cli.rb
    • /usr/lib/ruby/vendor_ruby/rouge/formatter.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexer.rb
    • /usr/lib/ruby/vendor_ruby/rouge/regex_lexer.rb
    • /usr/lib/ruby/vendor_ruby/rouge/template_lexer.rb
    • /usr/lib/ruby/vendor_ruby/rouge/text_analyzer.rb
    • /usr/lib/ruby/vendor_ruby/rouge/theme.rb
    • /usr/lib/ruby/vendor_ruby/rouge/token.rb
    • /usr/lib/ruby/vendor_ruby/rouge/util.rb
    • /usr/lib/ruby/vendor_ruby/rouge/version.rb
    • /usr/lib/ruby/vendor_ruby/rouge/formatters/html.rb
    • /usr/lib/ruby/vendor_ruby/rouge/formatters/html_inline.rb
    • /usr/lib/ruby/vendor_ruby/rouge/formatters/html_linewise.rb
    • /usr/lib/ruby/vendor_ruby/rouge/formatters/null.rb
    • /usr/lib/ruby/vendor_ruby/rouge/formatters/terminal256.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/apache.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/apple_script.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/c.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/clojure.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/coffeescript.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/common_lisp.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/conf.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/cpp.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/csharp.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/css.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/dart.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/diff.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/elixir.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/erb.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/erlang.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/factor.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/gherkin.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/glsl.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/go.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/groovy.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/haml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/handlebars.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/haskell.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/html.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/http.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/ini.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/io.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/java.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/javascript.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/liquid.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/literate_coffeescript.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/literate_haskell.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/llvm.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/lua.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/make.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/markdown.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/matlab.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/moonscript.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/nginx.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/nim.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/objective_c.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/ocaml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/perl.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/php.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/plain_text.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/powershell.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/praat.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/prolog.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/properties.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/puppet.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/python.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/qml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/r.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/racket.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/ruby.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/rust.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/sass.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/scala.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/scheme.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/scss.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/sed.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/shell.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/slim.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/smalltalk.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/sml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/sql.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/swift.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/tcl.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/tex.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/toml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/tulip.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/vb.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/viml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/xml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/yaml.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/apache/keywords.yml
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/gherkin/keywords.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/lua/builtins.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/matlab/builtins.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/php/builtins.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/sass/common.rb
    • /usr/lib/ruby/vendor_ruby/rouge/lexers/viml/keywords.rb
    • /usr/lib/ruby/vendor_ruby/rouge/plugins/redcarpet.rb
    • /usr/lib/ruby/vendor_ruby/rouge/themes/base16.rb
    • /usr/lib/ruby/vendor_ruby/rouge/themes/colorful.rb
    • /usr/lib/ruby/vendor_ruby/rouge/themes/github.rb
    • /usr/lib/ruby/vendor_ruby/rouge/themes/molokai.rb
    • /usr/lib/ruby/vendor_ruby/rouge/themes/monokai.rb
    • /usr/lib/ruby/vendor_ruby/rouge/themes/monokai_sublime.rb
    • /usr/lib/ruby/vendor_ruby/rouge/themes/thankful_eyes.rb
    • /usr/share/doc/ruby-rouge/TODO.Debian
    • /usr/share/doc/ruby-rouge/changelog.Debian.gz
    • /usr/share/doc/ruby-rouge/copyright
    • /usr/share/lintian/overrides/ruby-rouge
    • /usr/share/man/man1/rougify.1.gz
    • /usr/share/ruby-rouge/demos/apache
    • /usr/share/ruby-rouge/demos/applescript
    • /usr/share/ruby-rouge/demos/c
    • /usr/share/ruby-rouge/demos/clojure
    • /usr/share/ruby-rouge/demos/coffeescript
    • /usr/share/ruby-rouge/demos/common_lisp
    • /usr/share/ruby-rouge/demos/conf
    • /usr/share/ruby-rouge/demos/cpp
    • /usr/share/ruby-rouge/demos/csharp
    • /usr/share/ruby-rouge/demos/css
    • /usr/share/ruby-rouge/demos/dart
    • /usr/share/ruby-rouge/demos/diff
    • /usr/share/ruby-rouge/demos/elixir
    • /usr/share/ruby-rouge/demos/erb
    • /usr/share/ruby-rouge/demos/erlang
    • /usr/share/ruby-rouge/demos/factor
    • /usr/share/ruby-rouge/demos/gherkin
    • /usr/share/ruby-rouge/demos/glsl
    • /usr/share/ruby-rouge/demos/go
    • /usr/share/ruby-rouge/demos/groovy
    • /usr/share/ruby-rouge/demos/haml
    • /usr/share/ruby-rouge/demos/handlebars
    • /usr/share/ruby-rouge/demos/haskell
    • /usr/share/ruby-rouge/demos/html
    • /usr/share/ruby-rouge/demos/http
    • /usr/share/ruby-rouge/demos/ini
    • /usr/share/ruby-rouge/demos/io
    • /usr/share/ruby-rouge/demos/java
    • /usr/share/ruby-rouge/demos/javascript
    • /usr/share/ruby-rouge/demos/json
    • /usr/share/ruby-rouge/demos/json-doc
    • /usr/share/ruby-rouge/demos/liquid
    • /usr/share/ruby-rouge/demos/literate_coffeescript
    • /usr/share/ruby-rouge/demos/literate_haskell
    • /usr/share/ruby-rouge/demos/llvm
    • /usr/share/ruby-rouge/demos/lua
    • /usr/share/ruby-rouge/demos/make
    • /usr/share/ruby-rouge/demos/markdown
    • /usr/share/ruby-rouge/demos/matlab
    • /usr/share/ruby-rouge/demos/moonscript
    • /usr/share/ruby-rouge/demos/nginx
    • /usr/share/ruby-rouge/demos/nim
    • /usr/share/ruby-rouge/demos/objective_c
    • /usr/share/ruby-rouge/demos/ocaml
    • /usr/share/ruby-rouge/demos/perl
    • /usr/share/ruby-rouge/demos/php
    • /usr/share/ruby-rouge/demos/plaintext
    • /usr/share/ruby-rouge/demos/powershell
    • /usr/share/ruby-rouge/demos/praat
    • /usr/share/ruby-rouge/demos/prolog
    • /usr/share/ruby-rouge/demos/properties
    • /usr/share/ruby-rouge/demos/puppet
    • /usr/share/ruby-rouge/demos/python
    • /usr/share/ruby-rouge/demos/qml
    • /usr/share/ruby-rouge/demos/r
    • /usr/share/ruby-rouge/demos/racket
    • /usr/share/ruby-rouge/demos/ruby
    • /usr/share/ruby-rouge/demos/rust
    • /usr/share/ruby-rouge/demos/sass
    • /usr/share/ruby-rouge/demos/scala
    • /usr/share/ruby-rouge/demos/scheme
    • /usr/share/ruby-rouge/demos/scss
    • /usr/share/ruby-rouge/demos/sed
    • /usr/share/ruby-rouge/demos/shell
    • /usr/share/ruby-rouge/demos/slim
    • /usr/share/ruby-rouge/demos/smalltalk
    • /usr/share/ruby-rouge/demos/sml
    • /usr/share/ruby-rouge/demos/sql
    • /usr/share/ruby-rouge/demos/swift
    • /usr/share/ruby-rouge/demos/tcl
    • /usr/share/ruby-rouge/demos/tex
    • /usr/share/ruby-rouge/demos/toml
    • /usr/share/ruby-rouge/demos/tulip
    • /usr/share/ruby-rouge/demos/vb
    • /usr/share/ruby-rouge/demos/viml
    • /usr/share/ruby-rouge/demos/xml
    • /usr/share/ruby-rouge/demos/yaml
    • /usr/share/rubygems-integration/all/specifications/rouge-1.10.1.gemspec

    Changelog

    2015-12-23 - Pirate Praveen <praveen@debian.org> ruby-rouge (1.10.1-1) unstable; urgency=medium * Team upload * New upstream release * Check gemspec dependencies during build

    2015-07-20 - Cédric Boutillier <boutil@debian.org> ruby-rouge (1.9.1-1) unstable; urgency=medium * Team upload * Imported Upstream version 1.9.1 * Add a debian/TODO file with the following items: - running the test suite - automation of the manpage creation * Add a patch to fix path for the rouge library in the rougify tool. * Add README.md as documentation * Move demos file to /usr/share/ruby-rouge - install the files at the proper location before dh_auto_install - add demos_in_usr_share.patch to fix the path in rouge/lexer.rb * Update packaging with dh-make-ruby -w - bump standards-version to 3.9.6 (no changes needed)

    2014-08-17 - Youhei SASAKI <uwabami@gfd-dennou.org> ruby-rouge (1.6.2-1) unstable; urgency=medium * Imported Upstream version 1.6.2

    2014-07-17 - Youhei SASAKI <uwabami@gfd-dennou.org> ruby-rouge (1.5.1-1) unstable; urgency=medium * Initial release (Closes: #755879)

    Advertisement
    Advertisement