ruby-ronn_0.7.3-4_all.deb


Advertisement

Description

ruby-ronn - Builds manuals from Markdown

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-ronn
Package version 0.7.3
Package release 4
Package architecture all
Package type deb
Installed size 92 B
Download size 26.12 KB
Official Mirror archive.ubuntu.com
Ronn builds manuals. It converts simple, human readable textfiles to roff for
terminal display, and also to HTML for the web.
The source format includes all of Markdown but has a more rigid structure and
syntax extensions for features commonly found in manpages (definition lists,
link notation, etc.). The ronn-format(7) manual page defines the format in
detail.

Alternatives

Package Version Architecture Repository
ruby-ronn_0.7.3-4_all.deb 0.7.3 all Ubuntu Universe
ruby-ronn - - -

Requires

Name Value
groff -
ruby -
ruby-hpricot >= 0.8.2
ruby-interpreter -
ruby-mustache >= 0.7.0
ruby-rdiscount >= 1.5.8

Download

Type URL
Binary Package ruby-ronn_0.7.3-4_all.deb
Source Package ruby-ronn

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-ronn deb package:
    # sudo apt-get install ruby-ronn

Files

Path
/usr/bin/ronn
/usr/lib/ruby/vendor_ruby/ronn.rb
/usr/lib/ruby/vendor_ruby/ronn/document.rb
/usr/lib/ruby/vendor_ruby/ronn/index.rb
/usr/lib/ruby/vendor_ruby/ronn/roff.rb
/usr/lib/ruby/vendor_ruby/ronn/server.rb
/usr/lib/ruby/vendor_ruby/ronn/template.rb
/usr/lib/ruby/vendor_ruby/ronn/utils.rb
/usr/lib/ruby/vendor_ruby/ronn/template/80c.css
/usr/lib/ruby/vendor_ruby/ronn/template/dark.css
/usr/lib/ruby/vendor_ruby/ronn/template/darktoc.css
/usr/lib/ruby/vendor_ruby/ronn/template/default.html
/usr/lib/ruby/vendor_ruby/ronn/template/man.css
/usr/lib/ruby/vendor_ruby/ronn/template/print.css
/usr/lib/ruby/vendor_ruby/ronn/template/screen.css
/usr/lib/ruby/vendor_ruby/ronn/template/toc.css
/usr/share/doc/ruby-ronn/README.md
/usr/share/doc/ruby-ronn/changelog.Debian.gz
/usr/share/doc/ruby-ronn/copyright
/usr/share/man/man1/ronn.1.gz
/usr/share/man/man7/ronn-format.7.gz
/usr/share/rubygems-integration/all/specifications/ronn-0.7.3.gemspec

Changelog

2016-03-05 - Cédric Boutillier <boutil@debian.org>
ruby-ronn (0.7.3-4) unstable; urgency=medium
* Team upload
[ Sebastien Badia ]
* Add ruby-test-unit to Build-Depends for ruby2.2
* Update Vcs-Browser to cgit URL and HTTPS
[ Cédric Boutillier ]
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Add dependency on groff (Closes: #771599)
* Use locale agnostic output to make build of packages using ronn
reproducible. Thanks Chris Lamb for the patch (Closes: #807201)
2014-10-09 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-ronn (0.7.3-3) unstable; urgency=low
* Team upload.
* d/control:
- added Vcs headers
- bumped up standards version to 3.9.6 (no changes needed)
- wrap sort
- added Testsuite headers
* d/copyright: removed newline
2012-06-28 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-ronn (0.7.3-2) unstable; urgency=low
* Team upload.
* Disable tests relying on ordered hashes (Closes: #674380)
* Build against gem2deb >=0.3.0~
* Bump Standards-Version to 3.9.3 (no changes needed)
* Update debian/copyright to DEP-5 copyright-format/1.0
2011-09-25 - Martin Ueding <dev@martin-ueding.de>
ruby-ronn (0.7.3-1) unstable; urgency=low
* Initial release (Closes: #643672)

See Also

Package Description
ruby-rotp_2.1.1+dfsg-1_all.deb Ruby library for generating and verifying one time passwords
ruby-rouge_1.10.1-1_all.deb pure-Ruby syntax highlighter compatible with pygments
ruby-roxml_3.3.1-4_all.deb Ruby Object to XML mapping library
ruby-rpam-ruby19_1.2.1-1build2_i386.deb PAM integration with Ruby
ruby-rpatricia_1.0.1-1build6_i386.deb efficient IPv4/IPv6 prefix storage and lookup for Ruby
ruby-rqrcode-rails3_0.1.7-1_all.deb render QR codes with Rails 3
ruby-rqrcode_0.4.2-3_all.deb Ruby library for encoding QRCode (2D barcodes)
ruby-rr_1.1.2-2_all.deb test double framework for Ruby
ruby-rspec-collection-matchers_1.1.2-1_all.deb Ruby RSpec CollectionMatchers
ruby-rspec-core_3.4.0c3e0m1s1-1ubuntu1_all.deb Behaviour Driven Development framework for Ruby - core
ruby-rspec-expectations_3.4.0c3e0m1s1-1ubuntu1_all.deb Behaviour Driven Development framework for Ruby - expectations
ruby-rspec-instafail_0.4.0-1_all.deb Show failing specs instantly
ruby-rspec-its_1.2.0-2_all.deb attribute matching extension for the RSpec BDD framework
ruby-rspec-logsplit_0.1.3-1build1_all.deb library to provide a logger for each example
ruby-rspec-mocks_3.4.0c3e0m1s1-1ubuntu1_all.deb Behaviour Driven Development framework for Ruby - mocks
Advertisement
Advertisement