ruby-riot_0.12.7-1_all.deb


Advertisement

Description

ruby-riot - fast, expressive, and context-driven unit-testing framework for Ruby

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-riot
Package version 0.12.7
Package release 1
Package architecture all
Package type deb
Installed size 156 B
Download size 29.16 KB
Official Mirror archive.ubuntu.com
Riot is a fast, expressive, and context-driven unit-testing framework for the
Ruby programming language.
In contrast to other popular Ruby testing frameworks such as Test::Unit,
Shoulda and RSpec, Riot does not run a setup and teardown sequence before and
after each test. In Riot, tests separated in "contexts" in which a "topic"
object is defined, and assertions on this object are made.

Alternatives

Package Version Architecture Repository
ruby-riot_0.12.7-1_all.deb 0.12.7 all Ubuntu Universe
ruby-riot - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-rr -

Download

Type URL
Binary Package ruby-riot_0.12.7-1_all.deb
Source Package ruby-riot

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-riot deb package:
    # sudo apt-get install ruby-riot

Files

Path
/usr/lib/ruby/vendor_ruby/riot.rb
/usr/lib/ruby/vendor_ruby/riot/assertion.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macro.rb
/usr/lib/ruby/vendor_ruby/riot/context.rb
/usr/lib/ruby/vendor_ruby/riot/context_helpers.rb
/usr/lib/ruby/vendor_ruby/riot/context_options.rb
/usr/lib/ruby/vendor_ruby/riot/message.rb
/usr/lib/ruby/vendor_ruby/riot/middleware.rb
/usr/lib/ruby/vendor_ruby/riot/reporter.rb
/usr/lib/ruby/vendor_ruby/riot/rr.rb
/usr/lib/ruby/vendor_ruby/riot/runnable.rb
/usr/lib/ruby/vendor_ruby/riot/situation.rb
/usr/lib/ruby/vendor_ruby/riot/version.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/any.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/assigns.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/empty.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/equals.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/equivalent_to.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/exists.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/includes.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/kind_of.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/matches.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/nil.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/raises.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/raises_kind_of.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/respond_to.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/same_elements.rb
/usr/lib/ruby/vendor_ruby/riot/assertion_macros/size.rb
/usr/lib/ruby/vendor_ruby/riot/reporter/dot_matrix.rb
/usr/lib/ruby/vendor_ruby/riot/reporter/io.rb
/usr/lib/ruby/vendor_ruby/riot/reporter/pretty_dot_matrix.rb
/usr/lib/ruby/vendor_ruby/riot/reporter/silent.rb
/usr/lib/ruby/vendor_ruby/riot/reporter/story.rb
/usr/share/doc/ruby-riot/README.markdown.gz
/usr/share/doc/ruby-riot/changelog.Debian.gz
/usr/share/doc/ruby-riot/copyright
/usr/share/rubygems-integration/all/specifications/riot-0.12.7.gemspec

Changelog

2014-06-20 - Cédric Boutillier <boutil@debian.org>
ruby-riot (0.12.7-1) unstable; urgency=medium
* Imported Upstream version 0.12.7
* debian/patches:
- drop 01_fix_test_suite_for_ruby18.patch, not needed any more
- add no_bundler.patch to remove usage of bundler in tests
(as well as loadpath overload)
* Bump Standards-Version to 3.9.5 (no changes needed)
2013-03-07 - Cédric Boutillier <boutil@debian.org>
ruby-riot (0.12.5-1) unstable; urgency=low
* Initial release (Closes: #702552)

See Also

Package Description
ruby-rjb_1.5.3-2build1_i386.deb Ruby-Java bridge using Java Native Interface
ruby-rmagick-doc_2.15.4-2build3_all.deb ImageMagick API for Ruby (documentation)
ruby-rmagick_2.15.4-2build3_i386.deb ImageMagick API for Ruby
ruby-roadie-rails_1.1.0-1_all.deb library for composing HTML email in Rails applications
ruby-roadie_3.1.1-1_all.deb library for composing HTML email
ruby-romkan_0.4.0-2_all.deb Romaji <-> Kana conversion library for Ruby
ruby-ronn_0.7.3-4_all.deb Builds manuals from Markdown
ruby-rotp_2.1.1+dfsg-1_all.deb Ruby library for generating and verifying one time passwords
ruby-rouge_1.10.1-1_all.deb pure-Ruby syntax highlighter compatible with pygments
ruby-roxml_3.3.1-4_all.deb Ruby Object to XML mapping library
ruby-rpam-ruby19_1.2.1-1build2_i386.deb PAM integration with Ruby
ruby-rpatricia_1.0.1-1build6_i386.deb efficient IPv4/IPv6 prefix storage and lookup for Ruby
ruby-rqrcode-rails3_0.1.7-1_all.deb render QR codes with Rails 3
ruby-rqrcode_0.4.2-3_all.deb Ruby library for encoding QRCode (2D barcodes)
ruby-rr_1.1.2-2_all.deb test double framework for Ruby
Advertisement
Advertisement