ruby-rb-inotify_0.9.7-1_all.deb


Advertisement

Description

ruby-rb-inotify - A Ruby wrapper for Linux's inotify, using FFI

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-rb-inotify
Package version: 0.9.7
Package release: 1
Package architecture: all
Package type: deb
Installed size: 47 B
Download size: 10.96 KB
Official Mirror: archive.ubuntu.com
This Ruby library is a simple wrapper over inotify, a Linux kernel subsystem that acts to extend filesystems to notice changes to the filesystem, and report those changes to applications.

Alternatives

    Download

    Source package: ruby-rb-inotify

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-rb-inotify deb package:
      # sudo apt-get install ruby-rb-inotify

    Files

    • /usr/lib/ruby/vendor_ruby/rb-inotify.rb
    • /usr/lib/ruby/vendor_ruby/rb-inotify/errors.rb
    • /usr/lib/ruby/vendor_ruby/rb-inotify/event.rb
    • /usr/lib/ruby/vendor_ruby/rb-inotify/native.rb
    • /usr/lib/ruby/vendor_ruby/rb-inotify/notifier.rb
    • /usr/lib/ruby/vendor_ruby/rb-inotify/watcher.rb
    • /usr/lib/ruby/vendor_ruby/rb-inotify/native/flags.rb
    • /usr/share/doc/ruby-rb-inotify/README.md
    • /usr/share/doc/ruby-rb-inotify/changelog.Debian.gz
    • /usr/share/doc/ruby-rb-inotify/copyright
    • /usr/share/rubygems-integration/all/specifications/rb-inotify-0.9.7.gemspec

    Changelog

    2016-03-01 - Thiago Ribeiro <thiago@pencillabs.com> ruby-rb-inotify (0.9.7-1) unstable; urgency=medium * Team upload. * Imported Upstream version 0.9.7 * Update packaging using dh-make-ruby -w

    2014-06-21 - Cédric Boutillier <boutil@debian.org> ruby-rb-inotify (0.9.5-1) unstable; urgency=medium * Imported Upstream version 0.9.5 * Bump Standards-Version to 3.9.5 (no changes needed)

    2013-09-25 - Cédric Boutillier <boutil@debian.org> ruby-rb-inotify (0.9.2-1) unstable; urgency=low * Imported Upstream version 0.9.2 * debian/control: + remove obsolete DM-Upload-Allowed flag + drop transitional packages + update my email address + bump Standards-Version to 3.9.4 (no changes needed) + use canonical URI in Vcs-* fields

    2012-06-26 - Cédric Boutillier <cedric.boutillier@gmail.com> ruby-rb-inotify (0.8.8-2) unstable; urgency=low * Bump build dependency on gem2deb to >= 0.3.0~

    2012-05-14 - Cédric Boutillier <cedric.boutillier@gmail.com> ruby-rb-inotify (0.8.8-1) unstable; urgency=low * New upstream release * Transition to the new Ruby policy + rename source and binary packages + use gem2deb packaging tool * Bump Standards-Version: to 3.9.3 (no changes needed) * Add myself to Uploaders: * Override lintian warnings about duplicate descriptions of transitional packages

    2010-03-20 - Micah Anderson <micah@debian.org> librb-inotify-ruby (0.7.0-4) unstable; urgency=medium * Changed librb-inotify-ruby1.9.1 Architecture: to all

    2010-03-20 - Micah Anderson <micah@debian.org> librb-inotify-ruby (0.7.0-3) unstable; urgency=low * Fix librb-inotify-ruby Depends to depend on librb-inotify-ruby1.8

    2010-03-16 - Micah Anderson <micah@debian.org> librb-inotify-ruby (0.7.0-2) unstable; urgency=medium * Fix Build-Depends to include ruby1.8 and ruby1.9.1 (Closes: #574089)

    2010-03-04 - Micah Anderson <micah@debian.org> librb-inotify-ruby (0.7.0-1) unstable; urgency=low * Initial release (Closes: #572694)

    Advertisement
    Advertisement