ruby-raindrops_0.16.0-1build1_i386.deb


Advertisement

Description

ruby-raindrops - Real-time stats for preforking Rack servers

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-raindrops
Package version: 0.16.0
Package release: 1build1
Package architecture: i386
Package type: deb
Installed size: 120 B
Download size: 33.02 KB
Official Mirror: archive.ubuntu.com
Raindrops is a real-time stats toolkit to show statistics for Rack HTTP servers. It is designed for preforking servers such as unicorn, but should support any Rack HTTP server on platforms supporting POSIX shared memory. It may also be used as a generic scoreboard for sharing atomic counters across multiple processes.

Alternatives

    Download

    Source package: ruby-raindrops

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-raindrops deb package:
      # sudo apt-get install ruby-raindrops

    Files

    • /usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.3.0/raindrops_ext.so
    • /usr/lib/ruby/vendor_ruby/raindrops.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/aggregate.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/last_data_recv.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/linux.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/middleware.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/struct.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/watcher.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/aggregate/last_data_recv.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/aggregate/pmq.rb
    • /usr/lib/ruby/vendor_ruby/raindrops/middleware/proxy.rb
    • /usr/share/doc/ruby-raindrops/LATEST
    • /usr/share/doc/ruby-raindrops/NEWS.gz
    • /usr/share/doc/ruby-raindrops/README
    • /usr/share/doc/ruby-raindrops/TODO
    • /usr/share/doc/ruby-raindrops/changelog.Debian.gz
    • /usr/share/doc/ruby-raindrops/copyright
    • /usr/share/doc/ruby-raindrops/examples/linux-listener-stats.rb
    • /usr/share/doc/ruby-raindrops/examples/middleware.ru
    • /usr/share/doc/ruby-raindrops/examples/watcher.ru
    • /usr/share/doc/ruby-raindrops/examples/watcher_demo.ru
    • /usr/share/doc/ruby-raindrops/examples/zbatery.conf.rb
    • /usr/share/rubygems-integration/2.3.0/specifications/raindrops-0.16.0.gemspec

    Changelog

    2016-03-14 - Matthias Klose <doko@ubuntu.com> ruby-raindrops (0.16.0-1build1) xenial; urgency=medium * No-change rebuild for ruby2.3-only support.

    2016-02-29 - Hleb Valoshka <375gnu@gmail.com> ruby-raindrops (0.16.0-1) unstable; urgency=medium * Imported Upstream version 0.16.0 * Drop 0003-test-test_linux.rb-use-plain-ASCII-in-tempfile-name.patch * Reflect license change to LGPL-2.1+

    2016-02-22 - Antonio Terceiro <terceiro@debian.org> ruby-raindrops (0.15.0-3) unstable; urgency=medium * debian/ruby-tests.rake: reimplement former blacklist of tests that won't run on the Debian buildds due to missing inet_diag and tcp_diag kernel modules.

    2016-02-22 - Antonio Terceiro <terceiro@debian.org> ruby-raindrops (0.15.0-2) unstable; urgency=medium * Team upload. * Refresh packaging with new dh-make-ruby run * 0003-test-test_linux.rb-use-plain-ASCII-in-tempfile-name.patch: fix build against ruby2.3

    2016-02-03 - Christian Hofstaedtler <zeha@debian.org> ruby-raindrops (0.15.0-1) unstable; urgency=medium * Team upload. * New upstream release.

    2015-07-01 - Hleb Valoshka <375gnu@gmail.com> ruby-raindrops (0.14.0-1) unstable; urgency=medium * New upstream release, release to unstable. * Delete upsteamed patch 0001-Test-suite-fix-for-IPv6.patch. * Bump Standards-Version to 3.9.6 (no changes).

    2015-04-10 - Christian Hofstaedtler <zeha@debian.org> ruby-raindrops (0.13.0-3~exp1) experimental; urgency=medium * Team upload. * Build-Depend on ruby-test-unit for ruby 2.2 * Target experimental for ruby 2.2.

    2014-06-09 - Hleb Valoshka <375gnu@gmail.com> ruby-raindrops (0.13.0-2) unstable; urgency=medium * Rebuild with newer gem2deb (adds gemspec for all interpreters, current and future).

    2014-04-06 - Hleb Valoshka <375gnu@gmail.com> ruby-raindrops (0.13.0-1) unstable; urgency=medium * New upstream release. * Remove upstreamed patch 0003-Remove-Scope-IDs-from-IPv6-addresses.patch. * Bump Standards-Version to 3.9.5 (no changes required).

    2013-10-07 - Jérémy Bobbio <lunar@debian.org> ruby-raindrops (0.12.0-2) unstable; urgency=low [ Hleb Valoshka ] * Disable more tests which require inet_diag or tcp_diag kernel modules as buildd servers don't autoload them (to fix FTBFS). (Closes: #725628)

    Advertisement
    Advertisement