ruby-rabl-rails_0.4.1-1_all.deb


Advertisement

Description

ruby-rabl-rails - fast Rails 3+ templating system with JSON and XML support

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-rabl-rails
Package version: 0.4.1
Package release: 1
Package architecture: all
Package type: deb
Installed size: 66 B
Download size: 10.74 KB
Official Mirror: archive.ubuntu.com
RABL (Ruby API Builder Language) is a Ruby templating system for rendering resources in different format (JSON, XML, BSON...). rabl-rails is faster and uses less memory than the standard rabl gem (provided in the ruby-rabl package) while letting you access the same features. rabl-rails only targets Rails 3+ application.

Alternatives

    Download

    Source package: ruby-rabl-rails

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-rabl-rails deb package:
      # sudo apt-get install ruby-rabl-rails

    Files

    • /usr/lib/ruby/vendor_ruby/rabl-rails.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/compiler.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/configuration.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/handler.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/helpers.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/library.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/nodes.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/railtie.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/renderer.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/responder.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/template.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/version.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/visitors.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/nodes/attribute.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/nodes/child.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/nodes/code.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/nodes/condition.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/nodes/glue.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/nodes/node.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/renderers/hash.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/renderers/json.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/renderers/plist.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/renderers/xml.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/visitors/to_hash.rb
    • /usr/lib/ruby/vendor_ruby/rabl-rails/visitors/visitor.rb
    • /usr/lib/ruby/vendor_ruby/tasks/rabl-rails.rake
    • /usr/share/doc/ruby-rabl-rails/changelog.Debian.gz
    • /usr/share/doc/ruby-rabl-rails/copyright
    • /usr/share/rubygems-integration/all/specifications/rabl-rails-0.4.1.gemspec

    Changelog

    2015-08-13 - Cédric Boutillier <boutil@debian.org> ruby-rabl-rails (0.4.1-1) unstable; urgency=medium * Imported Upstream version 0.4.1 * Do not require minitest/autorun from ruby-tests.rake (Closes: #795134)

    2014-10-13 - David Suárez <david.sephirot@gmail.com> ruby-rabl-rails (0.4.0-1) unstable; urgency=medium * Team upload. * New upstream version. (Closes: #764838) This fix some sporadic tests failures. * debian/patches: - Remove '001_fix-minitest-autoload' patch; fixed upstream. - Remove '002_remove_skipped_test' patch; skip keyword is working. * debian/control: - Remove multi-json depend; upstream changes. - Add ruby-oj and ruby-json depends; prefer ruby-oj over ruby-json. - Update standards version; no changes needed * debian/ruby-tests.rake: - Change tests files search pattern. - Remove duplicate 'lib' entry.

    2014-05-01 - Sebastien Badia <seb@sebian.fr> ruby-rabl-rails (0.3.4-1) unstable; urgency=medium * Team upload. * Imported Upstream version 0.3.4 * Wrap and sort (Build-)Depends (no changes) * Remove specific dependency to ruby 1.9.1 (Closes: #746111) * Bump Standards-Version to 3.9.5 (no changes) * Add ruby-minitest build dependency.

    2013-05-31 - Cédric Boutillier <boutil@debian.org> ruby-rabl-rails (0.3.2-1) unstable; urgency=low * Initial release (Closes: #710502)

    Advertisement
    Advertisement