ruby-qt4_4.14.3-1ubuntu2_i386.deb


Advertisement

Description

ruby-qt4 - Qt 4 bindings for the Ruby language

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-qt4
Package version 4.14.3
Package release 1ubuntu2
Package architecture i386
Package type deb
Installed size 1.43 KB
Download size 719.04 KB
Official Mirror archive.ubuntu.com
This package provides the Ruby bindings for some of the Qt 4 modules:
* QtCore
* QtDBus
* QtGui
* QtNetwork
* QtXml
This is part of the Qt Ruby module.

Alternatives

Package Version Architecture Repository
ruby-qt4_4.14.3-1ubuntu2_amd64.deb 4.14.3 amd64 Ubuntu Universe
ruby-qt4 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libqt4-dbus >= 4:4.5.3
libqt4-xml >= 4:4.5.3
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.5.3
libqtruby4shared2 = 4:4.14.3-1ubuntu2
libruby2.3 >= 2.3.0~preview2
libsmokebase3v5 >= 4:4.14.3
libsmokeqtcore4-3 >= 4:4.14.3
libsmokeqtdbus4-3 >= 4:4.14.3
libsmokeqtgui4-3 >= 4:4.14.3
libsmokeqtnetwork4-3 >= 4:4.14.3
libsmokeqtopengl4-3 >= 4:4.14.3
libsmokeqtsql4-3 >= 4:4.14.3
libsmokeqtsvg4-3 >= 4:4.14.3
libsmokeqtxml4-3 >= 4:4.14.3
libstdc++6 >= 5.2

Provides

Name Value
libqt4-ruby -
libqt4-ruby1.8 -

Replaces

Name Value
libqt4-ruby << 4:4.6.80
libqt4-ruby1.8 << 4:4.6.80

Download

Type URL
Binary Package ruby-qt4_4.14.3-1ubuntu2_i386.deb
Source Package qtruby

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-qt4 deb package:
    # sudo apt-get install ruby-qt4

Files

Path
/usr/bin/rbqt4api
/usr/bin/rbqtapi
/usr/bin/rbrcc
/usr/bin/rbuic4
/usr/lib/i386-linux-gnu/ruby/vendor_ruby/2.3.0/qtruby4.so
/usr/lib/ruby/vendor_ruby/2.3.0/Qt.rb
/usr/lib/ruby/vendor_ruby/2.3.0/Qt3.rb
/usr/lib/ruby/vendor_ruby/2.3.0/Qt4.rb
/usr/lib/ruby/vendor_ruby/2.3.0/Qt/active_item_model.rb
/usr/lib/ruby/vendor_ruby/2.3.0/Qt/active_table_model.rb
/usr/lib/ruby/vendor_ruby/2.3.0/Qt/qtruby4.rb
/usr/share/doc/ruby-qt4/changelog.Debian.gz
/usr/share/doc/ruby-qt4/copyright
/usr/share/doc/ruby-qt4/examples.tar.gz
/usr/share/man/man1/rbqt4api.1.gz
/usr/share/man/man1/rbqtapi.1.gz
/usr/share/man/man1/rbrcc.1.gz
/usr/share/man/man1/rbuic4.1.gz

Changelog

2016-03-14 - Matthias Klose <doko@ubuntu.com>
qtruby (4:4.14.3-1ubuntu2) xenial; urgency=medium
* Merge with Debian; no remaining changes.
* libqtruby4shared2: Conflicts/Replaces libqtruby4shared2v5.
2015-09-10 - Scott Kitterman <scott@kitterman.com>
qtruby (4:4.14.3-1) unstable; urgency=medium
* Team upload.
* New upstream release
* Update debian/watch
* Bump standards version to 3.9.6
* Drop ruby-qt4-webkit binary and libqtwebkit-dev build-depends in aid of
Qt4 WebKit removal goal (Closes: #784517)
- Build-Conflict libqtwebkit-dev just to be sure
* Drop obsolete libqt4-ruby1.8 transitional package
2015-01-25 - Andreas Beckmann <anbe@debian.org>
qtruby (4:4.11.3-4.1) unstable; urgency=medium
* Non-maintainer upload with maintainer approval.
* ruby-qt4.postinst: Clean up obsolete diversions of rbqtapi dating back to
libqt4-ruby1.8/lenny.  (Closes: #775894)
* Allow arch-indep-only builds by restricting the dh_installexamples
override to arch-specific builds.
2014-05-19 - Cédric Boutillier <boutil@debian.org>
qtruby (4:4.11.3-4) unstable; urgency=medium
* Build against Ruby 2.1.
* Breaks binary packages from korundum before its rebuild with Ruby 2.1.
* Drop build-conflict with ruby1.8 (not needed any more).
2014-04-03 - Maximiliano Curia <maxy@debian.org>
qtruby (4:4.11.3-3) unstable; urgency=medium
* Aesthetic changes made by wrap-and-sort.
* Build against ruby 2.0. (Closes: #739769)
2013-11-24 - Cédric Boutillier <boutil@debian.org>
qtruby (4:4.11.3-2) unstable; urgency=low
* Build-conflict with ruby1.8 and build with ruby1.9.1.
* Install files in Ruby vendor locations as per Ruby policy.
* Drop use_ruby1.8.diff, since the default Ruby version is used now.
* Add myself to uploaders.
* Bump Standards-Version to 3.9.5 (no changes needed).
* Make Vcs-Git URL more canonical.
2013-11-09 - Maximiliano Curia <maxy@debian.org>
qtruby (4:4.11.3-1) unstable; urgency=low
* New upstream release.
* Update build dependencies.
2013-10-09 - Maximiliano Curia <maxy@debian.org>
qtruby (4:4.11.2-1) experimental; urgency=low
* New upstream release.
2013-07-12 - Maximiliano Curia <maxy@debian.org>
qtruby (4:4.10.5-1) unstable; urgency=low
* New upstream release.
2013-06-14 - Maximiliano Curia <maxy@debian.org>
qtruby (4:4.10.4-1) experimental; urgency=low
* New upstream release.
* Update watch file.
* Bump Standards-Version to 3.9.4.
* Update vcs fields.
* Add myself to uploaders.

See Also

Package Description
ruby-rabl-rails_0.4.1-1_all.deb fast Rails 3+ templating system with JSON and XML support
ruby-rabl_0.11.4-2_all.deb Ruby templating library with JSON, BSON, XML and MessagePack support
ruby-rack-accept_0.4.5-3_all.deb suite of tools for interpreting HTTP Accept family for Ruby/Rack
ruby-rack-attack_4.3.1-1_all.deb Block & throttle abusive requests
ruby-rack-cache_1.2-4_all.deb HTTP Caching for Rack
ruby-rack-contrib_1.3.0-3_all.deb contributed Rack Middleware and Utilities
ruby-rack-cors_0.4.0-1_all.deb enable Cross-Origin Resource Sharing in Rack apps
ruby-rack-flash3_1.0.5-1build1_all.deb Flash hash for Ruby Rack applications
ruby-rack-google-analytics_1.2.0-1_all.deb Simple Rack middleware to inject the Google Analytics tracking code
ruby-rack-mobile-detect_0.4.0-4_all.deb rack middleware for ruby webapps to detect mobile devices
ruby-rack-mount_0.8.3-1_all.deb Stackable dynamic tree based Rack router
ruby-rack-oauth2_1.2.1-2_all.deb Rack interface for an OAuth 2.0
ruby-rack-openid_1.4.2-1_all.deb Ruby Rack library to provide access to OpenID
ruby-rack-piwik_0.3.0-2_all.deb piwik Analytics racking in your Ruby-Rack based project
ruby-rack-pjax_0.7.0-2_all.deb serve pjax responses through rack middleware
Advertisement
Advertisement