ruby-pygments.rb_0.6.3-1_all.deb


Advertisement

Description

ruby-pygments.rb - pygments wrapper for Ruby

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-pygments.rb
Package version 0.6.3
Package release 1
Package architecture all
Package type deb
Installed size 331 B
Download size 128.17 KB
Official Mirror archive.ubuntu.com
A Ruby wrapper for the Python pygments syntax highlighter.
pygments.rb works by talking over a simple pipe to a long-lived Python child
process. This library replaces albino, as well as a version of pygments.rb
that used an embedded Python interpreter.
Each Ruby process that runs has its own 'personal Python'; for example, 4
Unicorn workers will have one Python process each.  If a Python process dies,
a new one will be spawned on the next pygments.rb request.

Alternatives

Package Version Architecture Repository
ruby-pygments.rb_0.6.3-1_all.deb 0.6.3 all Ubuntu Universe
ruby-pygments.rb - - -

Requires

Name Value
python -
python-pygments -
ruby -
ruby-interpreter -
ruby-posix-spawn -
ruby-yajl -

Provides

Name Value
ruby-pygments -

Download

Type URL
Binary Package ruby-pygments.rb_0.6.3-1_all.deb
Source Package ruby-pygments.rb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-pygments.rb deb package:
    # sudo apt-get install ruby-pygments.rb

Files

Path
/usr/lib/ruby/vendor_ruby/pygments.rb
/usr/lib/ruby/vendor_ruby/pygments/lexer.rb
/usr/lib/ruby/vendor_ruby/pygments/mentos.py
/usr/lib/ruby/vendor_ruby/pygments/popen.rb
/usr/lib/ruby/vendor_ruby/pygments/version.rb
/usr/share/doc-base/ruby-pygments.rb
/usr/share/doc/ruby-pygments.rb/README.md.gz
/usr/share/doc/ruby-pygments.rb/changelog.Debian.gz
/usr/share/doc/ruby-pygments.rb/copyright
/usr/share/doc/ruby-pygments.rb/html/MentosError.html
/usr/share/doc/ruby-pygments.rb/html/Pygments.html
/usr/share/doc/ruby-pygments.rb/html/index.html
/usr/share/doc/ruby-pygments.rb/html/table_of_contents.html
/usr/share/doc/ruby-pygments.rb/html/Pygments/Lexer.html
/usr/share/doc/ruby-pygments.rb/html/Pygments/Popen.html
/usr/share/doc/ruby-pygments.rb/html/css/fonts.css
/usr/share/doc/ruby-pygments.rb/html/css/rdoc.css
/usr/share/doc/ruby-pygments.rb/html/fonts/SourceCodePro-Bold.ttf.gz
/usr/share/doc/ruby-pygments.rb/html/fonts/SourceCodePro-Regular.ttf.gz
/usr/share/doc/ruby-pygments.rb/html/images/add.png
/usr/share/doc/ruby-pygments.rb/html/images/arrow_up.png
/usr/share/doc/ruby-pygments.rb/html/images/brick.png
/usr/share/doc/ruby-pygments.rb/html/images/brick_link.png
/usr/share/doc/ruby-pygments.rb/html/images/bug.png
/usr/share/doc/ruby-pygments.rb/html/images/bullet_black.png
/usr/share/doc/ruby-pygments.rb/html/images/bullet_toggle_minus.png
/usr/share/doc/ruby-pygments.rb/html/images/bullet_toggle_plus.png
/usr/share/doc/ruby-pygments.rb/html/images/date.png
/usr/share/doc/ruby-pygments.rb/html/images/delete.png
/usr/share/doc/ruby-pygments.rb/html/images/find.png
/usr/share/doc/ruby-pygments.rb/html/images/loadingAnimation.gif
/usr/share/doc/ruby-pygments.rb/html/images/macFFBgHack.png
/usr/share/doc/ruby-pygments.rb/html/images/package.png
/usr/share/doc/ruby-pygments.rb/html/images/page_green.png
/usr/share/doc/ruby-pygments.rb/html/images/page_white_text.png
/usr/share/doc/ruby-pygments.rb/html/images/page_white_width.png
/usr/share/doc/ruby-pygments.rb/html/images/plugin.png
/usr/share/doc/ruby-pygments.rb/html/images/ruby.png
/usr/share/doc/ruby-pygments.rb/html/images/tag_blue.png
/usr/share/doc/ruby-pygments.rb/html/images/tag_green.png
/usr/share/doc/ruby-pygments.rb/html/images/transparent.png
/usr/share/doc/ruby-pygments.rb/html/images/wrench.png
/usr/share/doc/ruby-pygments.rb/html/images/wrench_orange.png
/usr/share/doc/ruby-pygments.rb/html/images/zoom.png
/usr/share/doc/ruby-pygments.rb/html/js/darkfish.js
/usr/share/doc/ruby-pygments.rb/html/js/jquery.js
/usr/share/doc/ruby-pygments.rb/html/js/navigation.js
/usr/share/doc/ruby-pygments.rb/html/js/navigation.js.gz
/usr/share/doc/ruby-pygments.rb/html/js/search.js
/usr/share/doc/ruby-pygments.rb/html/js/search_index.js
/usr/share/doc/ruby-pygments.rb/html/js/search_index.js.gz
/usr/share/doc/ruby-pygments.rb/html/js/searcher.js
/usr/share/doc/ruby-pygments.rb/html/js/searcher.js.gz
/usr/share/doc/ruby-pygments.rb/html/lib/pygments/mentos_py.html
/usr/share/ruby-pygments.rb/lexers
/usr/share/rubygems-integration/all/specifications/pygments.rb-0.6.3.gemspec

Changelog

2016-03-01 - C├ędric Boutillier <boutil@debian.org>
ruby-pygments.rb (0.6.3-1) unstable; urgency=medium
* Team upload
* Imported Upstream version 0.6.3
* Fix watch file to not use githubredir anymore
* Bump Standards-Version to 3.9.7
* Use https in Vcs-* fields
* Refresh patches
* Adapt pygments tests to new version (Closes: #812940)
2015-02-07 - Antonio Terceiro <terceiro@debian.org>
ruby-pygments.rb (0.5.4~ds1-3) unstable; urgency=medium
* Team upload.
* Reverted the previous upload completely, and acknowledged the NMU in
0.5.4~ds1-1.1 by Tomasz Buchert (Closes: #768615).
* Update debian/patches/0007-Update-test-result.patch to fix current FTBFS
(and properly Closes: #775631).
2015-02-04 - Antonio Terceiro <terceiro@debian.org>
ruby-pygments.rb (0.5.4~ds1-2) unstable; urgency=medium
* Team upload
* fix tests (Closes: #775631):
- test_highlight_works_with_larger_files: instead of testing for an exact
amount of bytes, pass with there are more than 400,000 of them.
(debian/patches/0007-Update-test-result.patch)
- test_highlight_works_with_single_character_input: removed, since the
underlying Python code does not support that use case.
(debian/patches/0008-Drop-unfeasible-test.patch)
2014-11-22 - Tomasz Buchert <tomasz.buchert@inria.fr>
ruby-pygments.rb (0.5.4~ds1-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Update the testsuite (Closes: #768615)
2014-04-04 - Per Andersson <avtobiff@gmail.com>
ruby-pygments.rb (0.5.4~ds1-1) unstable; urgency=low
* Initial release (Closes: #703188)

See Also

Package Description
ruby-qdbm_1.8.78-6build3_i386.deb QDBM Database Libraries for Ruby
ruby-qpid_0.16-9ubuntu2_i386.deb enterprise messaging system - Ruby bindings
ruby-qscintilla2_4.14.3-1ubuntu2_i386.deb QScintilla2 bindings for the Ruby language
ruby-qt4-declarative_4.14.3-1ubuntu2_i386.deb QtDeclarative bindings for the Ruby language
ruby-qt4-script_4.14.3-1ubuntu2_i386.deb QtScript bindings for the Ruby language
ruby-qt4-test_4.14.3-1ubuntu2_i386.deb QtTest bindings for the Ruby language
ruby-qt4-uitools_4.14.3-1ubuntu2_i386.deb QtUiTools bindings for the Ruby language
ruby-qt4_4.14.3-1ubuntu2_i386.deb Qt 4 bindings for the Ruby language
ruby-rabl-rails_0.4.1-1_all.deb fast Rails 3+ templating system with JSON and XML support
ruby-rabl_0.11.4-2_all.deb Ruby templating library with JSON, BSON, XML and MessagePack support
ruby-rack-accept_0.4.5-3_all.deb suite of tools for interpreting HTTP Accept family for Ruby/Rack
ruby-rack-attack_4.3.1-1_all.deb Block & throttle abusive requests
ruby-rack-cache_1.2-4_all.deb HTTP Caching for Rack
ruby-rack-contrib_1.3.0-3_all.deb contributed Rack Middleware and Utilities
ruby-rack-cors_0.4.0-1_all.deb enable Cross-Origin Resource Sharing in Rack apps
Advertisement
Advertisement