ruby-puppet-forge_2.1.3-1_all.deb


Advertisement

Description

ruby-puppet-forge - Access the Puppet Forge API from Ruby

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-puppet-forge
Package version 2.1.3
Package release 1
Package architecture all
Package type deb
Installed size 77 B
Download size 16.87 KB
Official Mirror archive.ubuntu.com
Tools that can be used to access Forge API information on Modules, Users, and
Releases. As well as download, unpack, and install Releases to a directory.
It utilized the REST API of https://forge.puppetlabs.com

Alternatives

Package Version Architecture Repository
ruby-puppet-forge_2.1.3-1_all.deb 2.1.3 all Ubuntu Universe
ruby-puppet-forge - - -

Requires

Name Value
ruby -
ruby-faraday >= 0.9.0
ruby-faraday-middleware >= 0.9.0
ruby-interpreter -
ruby-minitar -
ruby-semantic-puppet >= 0.1.0

Download

Type URL
Binary Package ruby-puppet-forge_2.1.3-1_all.deb
Source Package ruby-puppet-forge

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-puppet-forge deb package:
    # sudo apt-get install ruby-puppet-forge

Files

Path
/usr/lib/ruby/vendor_ruby/puppet_forge.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/connection.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/error.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/lazy_accessors.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/lazy_relations.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/tar.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/unpacker.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/version.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/connection/connection_failure.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/middleware/symbolify_json.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/tar/mini.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/base.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/metadata.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/module.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/release.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/user.rb
/usr/lib/ruby/vendor_ruby/puppet_forge/v3/base/paginated_collection.rb
/usr/share/doc/ruby-puppet-forge/README.md.gz
/usr/share/doc/ruby-puppet-forge/changelog.Debian.gz
/usr/share/doc/ruby-puppet-forge/copyright
/usr/share/rubygems-integration/all/specifications/puppet_forge-2.1.3.gemspec

Changelog

2016-02-07 - Markus Frosch <lazyfrosch@debian.org>
ruby-puppet-forge (2.1.3-1) unstable; urgency=medium
* [41f65eb] Imported Upstream version 2.1.3
* [cbdd0b5] Update VCS URL
* [e6258dc] Cleanup depends
2016-01-15 - Markus Frosch <lazyfrosch@debian.org>
ruby-puppet-forge (2.1.2-1) unstable; urgency=medium
* [698d738] Imported Upstream version 2.1.2
* [7513a27] Remove patch allow_newer_faraday
2015-12-17 - Markus Frosch <lazyfrosch@debian.org>
ruby-puppet-forge (2.1.1-1) unstable; urgency=medium
[ Sebastien Badia ]
* Initial release (Closes: #808098)
[ Markus Frosch ]
* [5fccd30] Soften up dependency on faraday_middleware
* [0f9b2d0] Add myself to uploaders
* [bd4197a] Depend on ruby-minitar
* [ba07181] Disable network based rspec tests
* [de01622] Change comment on disabled tests
* [4eb7cb0] Update description

See Also

Package Description
ruby-puppet-syntax_2.0.0-1_all.deb Syntax checks for Puppet manifests, templates, and Hiera YAML
ruby-puppetlabs-spec-helper_0.10.3-1_all.deb rake tasks and spec helper for spec tests on puppet modules
ruby-pygments.rb_0.6.3-1_all.deb pygments wrapper for Ruby
ruby-qdbm_1.8.78-6build3_i386.deb QDBM Database Libraries for Ruby
ruby-qpid_0.16-9ubuntu2_i386.deb enterprise messaging system - Ruby bindings
ruby-qscintilla2_4.14.3-1ubuntu2_i386.deb QScintilla2 bindings for the Ruby language
ruby-qt4-declarative_4.14.3-1ubuntu2_i386.deb QtDeclarative bindings for the Ruby language
ruby-qt4-script_4.14.3-1ubuntu2_i386.deb QtScript bindings for the Ruby language
ruby-qt4-test_4.14.3-1ubuntu2_i386.deb QtTest bindings for the Ruby language
ruby-qt4-uitools_4.14.3-1ubuntu2_i386.deb QtUiTools bindings for the Ruby language
ruby-qt4_4.14.3-1ubuntu2_i386.deb Qt 4 bindings for the Ruby language
ruby-rabl-rails_0.4.1-1_all.deb fast Rails 3+ templating system with JSON and XML support
ruby-rabl_0.11.4-2_all.deb Ruby templating library with JSON, BSON, XML and MessagePack support
ruby-rack-accept_0.4.5-3_all.deb suite of tools for interpreting HTTP Accept family for Ruby/Rack
ruby-rack-attack_4.3.1-1_all.deb Block & throttle abusive requests
Advertisement
Advertisement