ruby-progressbar_1.4.2-1_all.deb


Advertisement

Description

ruby-progressbar - Text progress bar library for Ruby

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-progressbar
Package version 1.4.2
Package release 1
Package architecture all
Package type deb
Installed size 67 B
Download size 18.01 KB
Official Mirror archive.ubuntu.com
Ruby/ProgressBar is a text progress bar library for Ruby. It can indicate
progress with percentage, a progress bar, and estimated remaining time.

Alternatives

Package Version Architecture Repository
ruby-progressbar_1.4.2-1_all.deb 1.4.2 all Ubuntu Universe
ruby-progressbar - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Binary Package ruby-progressbar_1.4.2-1_all.deb
Source Package ruby-progressbar

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-progressbar deb package:
    # sudo apt-get install ruby-progressbar

Files

Path
/usr/lib/ruby/vendor_ruby/ruby-progressbar.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/base.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/components.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/format.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/formatter.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/length_calculator.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/running_average_calculator.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/time.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/version.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/components/bar.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/components/elapsed_timer.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/components/estimated_timer.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/components/progressable.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/components/throttle.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/components/timer.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/errors/invalid_progress_error.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/format/base.rb
/usr/lib/ruby/vendor_ruby/ruby-progressbar/format/molecule.rb
/usr/share/doc/ruby-progressbar/README.md.gz
/usr/share/doc/ruby-progressbar/changelog.Debian.gz
/usr/share/doc/ruby-progressbar/copyright
/usr/share/rubygems-integration/all/specifications/ruby-progressbar-1.4.2.gemspec

Changelog

2015-06-22 - Hleb Valoshka <375gnu@gmail.com>
ruby-progressbar (1.4.2-1) unstable; urgency=medium
* Import upstream version 1.4.2
* debian/control
- Update Build-Depends
- Update Standards-Version to 3.9.6 (no changes)
- Add Testsuite: autopkgtest
- Add myself to uploaders
* Update document list
* Update watch file
* Update the way tests are run (ruby -> rake)
* Refresh debian/rules file
* Add patch 0001-Make-spec-RSpec3-compatible.patch
* Update copyright file to reflect license change
2014-01-24 - Jonas Genannt <jonas.genannt@capi2name.de>
ruby-progressbar (0.21.0-1) unstable; urgency=low
[ Cédric Boutillier ]
* Team upload.
* debian/control
- remove obsolete DM-Upload-Allowed flag
- use canonical URI in Vcs-* fields
[ Jonas Genannt ]
* Imported Upstream version 0.21.0
* d/control
- removed transitional packages
- bumped standards version to 3.9.5 (no changes needed)
2012-06-26 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-progressbar (0.11.0-2) unstable; urgency=low
* Bump build dependency on gem2deb to >= 0.3.0~
2012-06-13 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-progressbar (0.11.0-1) unstable; urgency=low
* New upstream version, from an updated source
* Update homepage and debian/watch to point to the new source
* Use upstream test suite
* Remove the use of rdtool, not needed any more (Closes: #676202)
* Add myself to Uploaders:
* Bump Standards-Version: to 3.9.3 (no changes needed)
* Use upstream test suite and build-depend on ruby-test-unit
* Set priority of transitional packages to extra
* Convert debian/copyright to DEP-5 copyright-format/1.0
2011-08-26 - Antonio Terceiro <terceiro@debian.org>
ruby-progressbar (0.9-2) unstable; urgency=low
* Update to new Ruby policy: renamed package and migrated to
gem2deb/debhelper
* Added a VERY simple test suite to run during the build
2008-04-04 - Paul van Tilburg <paulvt@debian.org>
libprogressbar-ruby (0.9-1) unstable; urgency=low
[ Vincent Fourmond ]
* Added watch file.
[ Lucas Nussbaum ]
* Fixed Vcs-* to point to dir containing debian/ instead of dir
containing trunk/
* Added Homepage field.
[ Paul van Tilburg ]
* New upstream release. 
* Updated debian/control to adhere to Debian policy 3.7.3:
- changed section "interpreters" to "libs".
- set myself als maintainer, moved the team (address) to the Uploaders
field.
- bumped standards version to 3.7.3.
- added the libprogressbar-ruby package required by Debian Ruby policy.
- added build-depend-indep on rdtool.
- removed unnecessary build-depend-indep on ruby1.8-dev.
* Use CDBS for packaging:
- changed debian/rules (use debhelper.mk only).
- appended rules to generate documentation.
- added debian/libprogressbar.docs to install the documentation.
- added debian/libprogressbar1.8.install to install the library.
* Removed superfluous debian/dirs.
2007-12-08 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
libprogressbar-ruby (0.8-3) unstable; urgency=low
* New maintainer.
* Added Vcs-*.
2006-06-05 - akira yamada <akira@debian.org>
libprogressbar-ruby (0.8-2) unstable; urgency=low
* dropped ruby1.6 support. (Closes: #367915)
2004-02-11 - akira yamada <akira@debian.org>
libprogressbar-ruby (0.8-1) unstable; urgency=low
* new upstream version.
- Fixed the bug when caused by the invalid count.  (closes: #231009)
2004-01-21 - akira yamada <akira@debian.org>
libprogressbar-ruby (0.7-1) unstable; urgency=low
* new upstream version.

See Also

Package Description
ruby-protected-attributes_1.1.3-1_all.deb Protect attributes from mass assignment in Active Record models
ruby-pundit_1.0.1-2_all.deb object oriente authorization for rails
ruby-puppet-forge_2.1.3-1_all.deb Access the Puppet Forge API from Ruby
ruby-puppet-syntax_2.0.0-1_all.deb Syntax checks for Puppet manifests, templates, and Hiera YAML
ruby-puppetlabs-spec-helper_0.10.3-1_all.deb rake tasks and spec helper for spec tests on puppet modules
ruby-pygments.rb_0.6.3-1_all.deb pygments wrapper for Ruby
ruby-qdbm_1.8.78-6build3_i386.deb QDBM Database Libraries for Ruby
ruby-qpid_0.16-9ubuntu2_i386.deb enterprise messaging system - Ruby bindings
ruby-qscintilla2_4.14.3-1ubuntu2_i386.deb QScintilla2 bindings for the Ruby language
ruby-qt4-declarative_4.14.3-1ubuntu2_i386.deb QtDeclarative bindings for the Ruby language
ruby-qt4-script_4.14.3-1ubuntu2_i386.deb QtScript bindings for the Ruby language
ruby-qt4-test_4.14.3-1ubuntu2_i386.deb QtTest bindings for the Ruby language
ruby-qt4-uitools_4.14.3-1ubuntu2_i386.deb QtUiTools bindings for the Ruby language
ruby-qt4_4.14.3-1ubuntu2_i386.deb Qt 4 bindings for the Ruby language
ruby-rabl-rails_0.4.1-1_all.deb fast Rails 3+ templating system with JSON and XML support
Advertisement
Advertisement