ruby-prawn_2.0.2+dfsg-1_all.deb


Advertisement

Description

ruby-prawn - fast, nimble PDF generation library for Ruby

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name ruby-prawn
Package version 2.0.2+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 1.27 KB
Download size 269.81 KB
Official Mirror archive.ubuntu.com
Prawn is a PDF generation library for Ruby. Its highlights include:
* Built in support for UTF-8
* Easy image embedding
* Flexible table drawing
* Simple content positioning, allowing for placing elements relative to
their sections
* Easy text flowing within and around sections

Alternatives

Package Version Architecture Repository
ruby-prawn_2.0.2+dfsg-1_all.deb 2.0.2+dfsg all Ubuntu Universe
ruby-prawn - - -

Requires

Name Value
ruby -
ruby-interpreter -
ruby-pdf-core >= 0.5.1~
ruby-ttfunk >= 1.4.0~

Download

Type URL
Binary Package ruby-prawn_2.0.2+dfsg-1_all.deb
Source Package ruby-prawn

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-prawn deb package:
    # sudo apt-get install ruby-prawn

Files

Path
/usr/lib/ruby/vendor_ruby/prawn.rb
/usr/lib/ruby/vendor_ruby/prawn/document.rb
/usr/lib/ruby/vendor_ruby/prawn/encoding.rb
/usr/lib/ruby/vendor_ruby/prawn/errors.rb
/usr/lib/ruby/vendor_ruby/prawn/font.rb
/usr/lib/ruby/vendor_ruby/prawn/font_metric_cache.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics.rb
/usr/lib/ruby/vendor_ruby/prawn/grid.rb
/usr/lib/ruby/vendor_ruby/prawn/image_handler.rb
/usr/lib/ruby/vendor_ruby/prawn/images.rb
/usr/lib/ruby/vendor_ruby/prawn/measurement_extensions.rb
/usr/lib/ruby/vendor_ruby/prawn/measurements.rb
/usr/lib/ruby/vendor_ruby/prawn/outline.rb
/usr/lib/ruby/vendor_ruby/prawn/repeater.rb
/usr/lib/ruby/vendor_ruby/prawn/security.rb
/usr/lib/ruby/vendor_ruby/prawn/soft_mask.rb
/usr/lib/ruby/vendor_ruby/prawn/stamp.rb
/usr/lib/ruby/vendor_ruby/prawn/text.rb
/usr/lib/ruby/vendor_ruby/prawn/utilities.rb
/usr/lib/ruby/vendor_ruby/prawn/version.rb
/usr/lib/ruby/vendor_ruby/prawn/view.rb
/usr/lib/ruby/vendor_ruby/prawn/document/bounding_box.rb
/usr/lib/ruby/vendor_ruby/prawn/document/column_box.rb
/usr/lib/ruby/vendor_ruby/prawn/document/internals.rb
/usr/lib/ruby/vendor_ruby/prawn/document/span.rb
/usr/lib/ruby/vendor_ruby/prawn/font/afm.rb
/usr/lib/ruby/vendor_ruby/prawn/font/dfont.rb
/usr/lib/ruby/vendor_ruby/prawn/font/ttf.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics/cap_style.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics/color.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics/dash.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics/join_style.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics/patterns.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics/transformation.rb
/usr/lib/ruby/vendor_ruby/prawn/graphics/transparency.rb
/usr/lib/ruby/vendor_ruby/prawn/images/image.rb
/usr/lib/ruby/vendor_ruby/prawn/images/jpg.rb
/usr/lib/ruby/vendor_ruby/prawn/images/png.rb
/usr/lib/ruby/vendor_ruby/prawn/security/arcfour.rb
/usr/lib/ruby/vendor_ruby/prawn/text/box.rb
/usr/lib/ruby/vendor_ruby/prawn/text/formatted.rb
/usr/lib/ruby/vendor_ruby/prawn/text/formatted/arranger.rb
/usr/lib/ruby/vendor_ruby/prawn/text/formatted/box.rb
/usr/lib/ruby/vendor_ruby/prawn/text/formatted/fragment.rb
/usr/lib/ruby/vendor_ruby/prawn/text/formatted/line_wrap.rb
/usr/lib/ruby/vendor_ruby/prawn/text/formatted/parser.rb
/usr/lib/ruby/vendor_ruby/prawn/text/formatted/wrap.rb
/usr/share/doc/ruby-prawn/README.md.gz
/usr/share/doc/ruby-prawn/README.source
/usr/share/doc/ruby-prawn/changelog.Debian.gz
/usr/share/doc/ruby-prawn/copyright
/usr/share/ruby-prawn/shift_jis_text.txt
/usr/share/ruby-prawn/fonts/Courier-Bold.afm
/usr/share/ruby-prawn/fonts/Courier-BoldOblique.afm
/usr/share/ruby-prawn/fonts/Courier-Oblique.afm
/usr/share/ruby-prawn/fonts/Courier.afm
/usr/share/ruby-prawn/fonts/Helvetica-Bold.afm
/usr/share/ruby-prawn/fonts/Helvetica-BoldOblique.afm
/usr/share/ruby-prawn/fonts/Helvetica-Oblique.afm
/usr/share/ruby-prawn/fonts/Helvetica.afm
/usr/share/ruby-prawn/fonts/MustRead.html
/usr/share/ruby-prawn/fonts/Panic+Sans.dfont
/usr/share/ruby-prawn/fonts/Symbol.afm
/usr/share/ruby-prawn/fonts/Times-Bold.afm
/usr/share/ruby-prawn/fonts/Times-BoldItalic.afm
/usr/share/ruby-prawn/fonts/Times-Italic.afm
/usr/share/ruby-prawn/fonts/Times-Roman.afm
/usr/share/ruby-prawn/fonts/ZapfDingbats.afm
/usr/share/ruby-prawn/images/fractal.jpg
/usr/share/ruby-prawn/images/indexed_color.dat
/usr/share/ruby-prawn/images/indexed_color.png
/usr/share/ruby-prawn/images/pal_bk.png
/usr/share/ruby-prawn/images/pigs.jpg
/usr/share/ruby-prawn/images/prawn.png
/usr/share/ruby-prawn/images/stef.jpg
/usr/share/rubygems-integration/all/specifications/prawn-2.0.2.gemspec

Changelog

2015-07-24 - Cédric Boutillier <boutil@debian.org>
ruby-prawn (2.0.2+dfsg-1) unstable; urgency=medium
* Imported Upstream version 2.0.2+dfsg
* Refresh patches
* Add 0900_rspec3.patch to port to RSpec3
2015-04-29 - Cédric Boutillier <boutil@debian.org>
ruby-prawn (2.0.1+dfsg-1) unstable; urgency=medium
[ Jérémy Bobbio ]
* Add 0700_use_deterministic_keys_for_gradients.patch to make
Prawn build PDF in a deterministic manner when they use gradients.
(Closes: #782890)
* Make the package build reproducibly:
- Add 0800_enable_manual_to_be_built_reproducibly.patch
to allow the manual last update to be set using an environment
variable. (Closes: #782891)
- Set the build date in debian/rules.
[ Cédric Boutillier ]
* Imported Upstream version 2.0.1+dfsg
* Refresh patches
* Update homepage to prawnpdf.org
* Bump Standards-Version to 3.9.6 (no changes needed)
* Update versions of ruby-pdf-inspector and ruby-pdf-core in dependencies
* Enable autopkg-pkg-ruby auto-package-test suite
2014-09-28 - Cédric Boutillier <boutil@debian.org>
ruby-prawn (1.3.0+dfsg-1) unstable; urgency=medium
* Imported Upstream version 1.3.0+dfsg
* Update source field in copyright
* Do not capitalize short description
* Bump version in dependency on ruby-pdf-core and ruby-ttfunk
* Refresh 0200_replace_BASEDIR_data_by_DATADIR.patch and
0400_use_system_fonts.patch
* No need to fiddle with the VERSION file in the root directory:
- drop 0650_move_VERSION.patch, merged upstream
- do not copy/clean non existing VERSION file
* Drop copyright notice for the lib/prawn/document/graphics_state.rb,
removed upstream
2014-09-11 - Cédric Boutillier <boutil@debian.org>
ruby-prawn (1.2.1+dfsg-2) unstable; urgency=medium
* Explicitly build-depend on fonts-arphic-gkai00mp, fonts-dejavu-core
and add those packages to the dependency list for autopkgtest suite.
Those packages were automatically pulled by ruby-prawn-manual-builder
during the build, but they are needed also to run the tests When
building the package, even if we don't build the manual.
2014-09-08 - Cédric Boutillier <boutil@debian.org>
ruby-prawn (1.2.1+dfsg-1) unstable; urgency=medium
* Imported Upstream version 1.2.1+dfsg
- tables support is now moved out of prawn core library
* Run wrap and sort on fields of debian/ files
* Make sure that the VERSION file gets installed:
- copy VERSION to lib/prawn/ before dh_auto_install
- add 0650_move_VERSION.patch to used the copied version file
- clean the copied version file afterwards
* Refresh patches and remove not applied obsolete patched from
debian/patches
- add 0600_replace_require_relative_manual.patch to avoid wrong relative
path for the system installed library.
* Build-depend on ruby-prawn-manual-builder to build the manual
* debian/copyright:
- fix entry for lib/prawn/graphics/gradient.rb, renamed/rewritten
to patterns.rb
- fix typo in lib/prawn/measurements.rb filename
* Add autopkgtest support
2014-04-15 - Cédric Boutillier <boutil@debian.org>
ruby-prawn (1.0.0+dfsg-1) unstable; urgency=medium
* Imported Upstream version 1.0.0+dfsg
* update the list of removed files in debian/repack.sh and
debian/README.source
* Patches:
+ refresh:
0100_remove_bundler_rubygems_stuff.patch
0200_replace_BASEDIR_data_by_DATADIR.patch
0300_fix_paths.patch
0400_use_system_fonts.patch
0405_use_system_fonts_manual.patch
0500_disable_tests_using_removed_files.patch
+ drop:
0102_simply_require_ttfunk.patch
0210_change_spec_data_to_datadir_pdfs.patch
0700_dont_call_git_from_manual.patch
* debian/copyright:
+ add copyright/license for data/fonts/Panic+Sans.dfont
+ update my email address and years
* Dependencies:
+ depend and build-depend on ruby-pdf-core

See Also

Package Description
ruby-progressbar_1.4.2-1_all.deb Text progress bar library for Ruby
ruby-protected-attributes_1.1.3-1_all.deb Protect attributes from mass assignment in Active Record models
ruby-pundit_1.0.1-2_all.deb object oriente authorization for rails
ruby-puppet-forge_2.1.3-1_all.deb Access the Puppet Forge API from Ruby
ruby-puppet-syntax_2.0.0-1_all.deb Syntax checks for Puppet manifests, templates, and Hiera YAML
ruby-puppetlabs-spec-helper_0.10.3-1_all.deb rake tasks and spec helper for spec tests on puppet modules
ruby-pygments.rb_0.6.3-1_all.deb pygments wrapper for Ruby
ruby-qdbm_1.8.78-6build3_i386.deb QDBM Database Libraries for Ruby
ruby-qpid_0.16-9ubuntu2_i386.deb enterprise messaging system - Ruby bindings
ruby-qscintilla2_4.14.3-1ubuntu2_i386.deb QScintilla2 bindings for the Ruby language
ruby-qt4-declarative_4.14.3-1ubuntu2_i386.deb QtDeclarative bindings for the Ruby language
ruby-qt4-script_4.14.3-1ubuntu2_i386.deb QtScript bindings for the Ruby language
ruby-qt4-test_4.14.3-1ubuntu2_i386.deb QtTest bindings for the Ruby language
ruby-qt4-uitools_4.14.3-1ubuntu2_i386.deb QtUiTools bindings for the Ruby language
ruby-qt4_4.14.3-1ubuntu2_i386.deb Qt 4 bindings for the Ruby language
Advertisement
Advertisement