ruby-polyglot_0.3.4-1_all.deb


Advertisement

Description

ruby-polyglot - Custom language loaders for specified file extensions

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-polyglot
Package version: 0.3.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 60 B
Download size: 5.11 KB
Official Mirror: archive.ubuntu.com
Allows one to write custom language loaders for specified file extensions to be hooked into require. This supports the creation of DSLs having a syntax that is most appropriate to their purpose, instead of abusing the Ruby syntax. Required files are attempted first using the normal Ruby loader, and if that fails, Polyglot conducts a search for a file having a supported extension.

Alternatives

    Download

    Source package: ruby-polyglot

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-polyglot deb package:
      # sudo apt-get install ruby-polyglot

    Files

    • /usr/lib/ruby/vendor_ruby/polyglot.rb
    • /usr/lib/ruby/vendor_ruby/polyglot/version.rb
    • /usr/share/doc/ruby-polyglot/README.txt
    • /usr/share/doc/ruby-polyglot/changelog.Debian.gz
    • /usr/share/doc/ruby-polyglot/copyright
    • /usr/share/rubygems-integration/all/specifications/polyglot-0.3.4.gemspec

    Changelog

    2014-05-19 - Antonio Terceiro <terceiro@debian.org> ruby-polyglot (0.3.4-1) unstable; urgency=medium * Team upload. * New upstream release

    2013-11-30 - Jonas Genannt <jonas.genannt@capi2name.de> ruby-polyglot (0.3.3-4) unstable; urgency=low [ Vasudev Kamath ] * Dropped myself from Uploaders field. [ Cédric Boutillier ] * use canonical URI in Vcs-* fields [ Jonas Genannt ] * d/control: - bumped standards version to 3.9.5 (no changes needed) - fixed Vcs-Browser url (.git missing) - added myself as Uploader (every package needs one human contact in Uploaders) - removed version dependency of ruby1.8, changed it to ruby

    2012-06-26 - Antonio Terceiro <terceiro@debian.org> ruby-polyglot (0.3.3-3) unstable; urgency=low * Bump build dependency on gem2deb to >= 0.3.0~

    2012-06-17 - Vasudev Kamath <kamathvasudev@gmail.com> ruby-polyglot (0.3.3-2) unstable; urgency=low * debian/control: + Changed minimum version of debhelper required to 9 + Bumped the Standards-Version to 3.9.3. This change did not require any changes to package source * debian/copyright: + Format URI now confirms to Debian copyright-format 1.0 * Set debian/compat to 9

    2011-11-13 - Vasudev Kamath <kamathvasudev@gmail.com> ruby-polyglot (0.3.3-1) unstable; urgency=low * Imported Upstream version 0.3.3 * debian/copyright + Dep5 format fix applied

    2011-08-15 - Vasudev Kamath <kamathvasudev@gmail.com> ruby-polyglot (0.3.2-1) unstable; urgency=low * Imported Upstream version 0.3.2 * Bumped Standards-Version to 3.9.2 * Fixed a typo in control file * Removed the ruby-test.yaml file as there is no test in upstream

    2011-04-21 - Vasudev Kamath <kamathvasudev@gmail.com> ruby-polyglot (0.3.1-1) unstable; urgency=low * Initial release (Closes: #623080)

    Advertisement
    Advertisement