ruby-pkg-config_1.1.5-1_all.deb


Advertisement

Description

ruby-pkg-config - pkg-config implementation for Ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-pkg-config
Package version: 1.1.5
Package release: 1
Package architecture: all
Package type: deb
Installed size: 69 B
Download size: 6.52 KB
Official Mirror: archive.ubuntu.com
pkg-config can be used in your extconf.rb to properly detect neeed libraries for compiling Ruby native extensions, using the pkg-config database. Note that this package does not use pkg-config, only it's database.

Alternatives

    Download

    Source package: ruby-pkg-config

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-pkg-config deb package:
      # sudo apt-get install ruby-pkg-config

    Files

    • /usr/lib/ruby/vendor_ruby/pkg-config.rb
    • /usr/lib/ruby/vendor_ruby/pkg-config/version.rb
    • /usr/share/doc/ruby-pkg-config/README.rdoc
    • /usr/share/doc/ruby-pkg-config/TODO.Debian
    • /usr/share/doc/ruby-pkg-config/changelog.Debian.gz
    • /usr/share/doc/ruby-pkg-config/copyright
    • /usr/share/rubygems-integration/all/specifications/pkg-config-1.1.5.gemspec

    Changelog

    2014-03-13 - HIGUCHI Daisuke (VDR dai) <dai@debian.org> ruby-pkg-config (1.1.5-1) unstable; urgency=low * Team upload. [ HIGUCHI Daisuke (VDR dai) ] * New upstream release. * fix FTBFS: ERROR: Test "ruby1.9.1" failed (Closes: #735862) - debian/rubygem-pkg-config-1.1.3-cflags-result-sort.patch: New file. pick up from upstream issues and modify for debian. * debian/copyright: fix lintian warning old-fsf-address-in-copyright-file * Bump standards version to 3.9.5; no further changes needed

    2011-08-11 - Antonio Terceiro <terceiro@debian.org> ruby-pkg-config (1.1.2-1) unstable; urgency=low * New upstream release. + Fixed to build on non-Intel+Linux platforms #632323 - dropped Debian-specific patch * Run tests with debian/ruby-tests.rb; drop build dependency on rake

    2011-07-02 - Antonio Terceiro <terceiro@softwarelivre.org> ruby-pkg-config (1.1.2~git20110615-2) unstable; urgency=low * Fix debian/watch: use upstream name instead of Debian name * Also look in arch-dependent pkgconfig directories (Closes: #632323) * Make tests not depend on the exact order in which pkg-config outputs.

    2011-06-14 - Antonio Terceiro <terceiro@softwarelivre.org> ruby-pkg-config (1.1.2~git20110615-1) unstable; urgency=low * Initial release (Closes: #630659)

    Advertisement
    Advertisement