ruby-peach_0.5.1-3_all.deb


Advertisement

Description

ruby-peach - parallel execution of each and map in Ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-peach
Package version: 0.5.1
Package release: 3
Package architecture: all
Package type: deb
Installed size: 59 B
Download size: 5.03 KB
Official Mirror: archive.ubuntu.com
This Ruby module provides parallel (multi-threaded) versions of the each and map methods. This makes it each to (almost transparently) parallelize such loops.

Alternatives

    Download

    Source package: ruby-peach

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-peach deb package:
      # sudo apt-get install ruby-peach

    Files

    • /usr/lib/ruby/vendor_ruby/peach.rb
    • /usr/lib/ruby/vendor_ruby/peach/version.rb
    • /usr/share/doc/ruby-peach/README
    • /usr/share/doc/ruby-peach/changelog.Debian.gz
    • /usr/share/doc/ruby-peach/copyright
    • /usr/share/rubygems-integration/all/specifications/peach-0.5.1.gemspec

    Changelog

    2015-05-07 - Lucas Nussbaum <lucas@debian.org> ruby-peach (0.5.1-3) unstable; urgency=medium * Upload to unstable now that jessie is released. * Fix Homepage field. * Increase the length of the description to avoid a lintian warning.

    2015-04-10 - Sebastien Badia <seb@sebian.fr> ruby-peach (0.5.1-3~exp1) experimental; urgency=medium * Team upload. * Target experimental and build with ruby 2.2 * Add ruby-test-unit and ruby-minitest to Build-Depends for ruby2.2 * Update Vcs-Browser to cgit URL and HTTPS

    2014-10-19 - Cédric Boutillier <boutil@debian.org> ruby-peach (0.5.1-2) unstable; urgency=medium * Reupload to update rubygems-integration metadata * Update homepage to github repository * Testsuite set to autopkgtest-pkg-ruby; Standards-Version set to 3.9.6 * Add dont_read_lib_from_tests.patch to let Ruby determine where the files are located instead of hardcoding relative path in tests

    2013-05-07 - Cédric Boutillier <boutil@debian.org> ruby-peach (0.5.1-1) unstable; urgency=low * New upstream release * debian/control: + add myself to Uploaders + bump Standards-Version to 3.9.4 (no changes needed) + use canonical URLs in Vcs-* fields * debian/ruby-tests + do not modify the LOAD_PATH before running the tests + restrict to the test/ directory

    2012-06-29 - Cédric Boutillier <cedric.boutillier@gmail.com> ruby-peach (0.4-2) unstable; urgency=low * Team upload. * Bump build dependency on gem2deb to >= 0.3.0~. * Bump Standards-Versions to 3.9.3 (no changes needed) * Convert debian/copyright to DEP-5 copyright-format/1.0

    2011-07-28 - Lucas Nussbaum <lucas@debian.org> ruby-peach (0.4-1) unstable; urgency=low * Initial release.

    Advertisement
    Advertisement