ruby-pdf-core_0.5.1-1_all.deb


Advertisement

Description

ruby-pdf-core - Ruby library to render PDF documents

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-pdf-core
Package version: 0.5.1
Package release: 1
Package architecture: all
Package type: deb
Installed size: 117 B
Download size: 17.80 KB
Official Mirror: archive.ubuntu.com
PDF::Core is a pure Ruby library to render PDF documents. It supports several PDF features, such as among others: * low-level annotation * istream objects and stream filters * NameTree * object repository * object serialization * indirect objects * page geometries It is used internally by Prawn (provided in the ruby-prawn package), a Ruby PDF generation library.

Alternatives

Replaces

  • ruby-prawn << 1.0.0~s

    Download

    Source package: ruby-pdf-core

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-pdf-core deb package:
      # sudo apt-get install ruby-pdf-core

    Files

    • /usr/lib/ruby/vendor_ruby/pdf/core.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/annotations.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/byte_string.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/destinations.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/document_state.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/filter_list.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/filters.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/graphics_state.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/literal_string.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/name_tree.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/object_store.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/outline_item.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/outline_root.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/page.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/page_geometry.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/pdf_object.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/reference.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/renderer.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/stream.rb
    • /usr/lib/ruby/vendor_ruby/pdf/core/text.rb
    • /usr/share/doc/ruby-pdf-core/changelog.Debian.gz
    • /usr/share/doc/ruby-pdf-core/copyright
    • /usr/share/rubygems-integration/all/specifications/pdf-core-0.5.1.gemspec

    Changelog

    2015-04-29 - Cédric Boutillier <boutil@debian.org> ruby-pdf-core (0.5.1-1) unstable; urgency=medium * Imported Upstream version 0.5.1 * Bump Standards-Version to 3.9.6 (no changes needed)

    2014-09-28 - Cédric Boutillier <boutil@debian.org> ruby-pdf-core (0.4.0-1) unstable; urgency=medium * Imported Upstream version 0.4.0 * Extend no_bundler.patch to load correctly pdf/core in specs, and rename to clean_spec_helper.patch * Add Testsuite: autopkgtest-pkg-ruby to debian/control

    2014-03-28 - Cédric Boutillier <boutil@debian.org> ruby-pdf-core (0.2.5-2) unstable; urgency=medium * Add Breaks: and Replaces: with version of ruby-prawn < 1.0.0, as this library has been split out from ruby-prawn and thus ships files contained in earlier versions of ruby-prawn. (Closes: #742585)

    2014-03-19 - Cédric Boutillier <boutil@debian.org> ruby-pdf-core (0.2.5-1) unstable; urgency=medium * Initial release (Closes: #742270)

    Advertisement
    Advertisement