ruby-open4_1.3.4-1_all.deb


Advertisement

Description

ruby-open4 - library for managing child processes in Ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: ruby-open4
Package version: 1.3.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 79 B
Download size: 13.97 KB
Official Mirror: archive.ubuntu.com
Open4 lets you open child process with handles on pid, stdin, stdout, and stderr: manage child processes and their I/O handles easily.

Alternatives

    Download

    Source package: ruby-open4

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-open4 deb package:
      # sudo apt-get install ruby-open4

    Files

    • /usr/lib/ruby/vendor_ruby/open4.rb
    • /usr/share/doc/ruby-open4/README.gz
    • /usr/share/doc/ruby-open4/changelog.Debian.gz
    • /usr/share/doc/ruby-open4/copyright
    • /usr/share/doc/ruby-open4/examples/bg.rb
    • /usr/share/doc/ruby-open4/examples/block.rb
    • /usr/share/doc/ruby-open4/examples/exception.rb
    • /usr/share/doc/ruby-open4/examples/jesse-caldwell.rb
    • /usr/share/doc/ruby-open4/examples/pfork4.rb
    • /usr/share/doc/ruby-open4/examples/simple.rb
    • /usr/share/doc/ruby-open4/examples/spawn.rb
    • /usr/share/doc/ruby-open4/examples/stdin_timeout.rb
    • /usr/share/doc/ruby-open4/examples/timeout.rb
    • /usr/share/rubygems-integration/all/specifications/open4-1.3.4.gemspec

    Changelog

    2014-06-19 - Cédric Boutillier <boutil@debian.org> ruby-open4 (1.3.4-1) unstable; urgency=medium * Team upload. [ Cédric Boutillier ] * Imported Upstream version 1.3.4 * Drop transitional packages (Closes: #735728) * Bump Standards-Version to 3.9.5 + remove obsolete DM-Upload-Allowed flag in debian/control * use canonical URI in Vcs-* fields * debian/copyright: use copyright-format/1.0 official URL for Format field [ Roberto C. Sanchez ] * Remove myself from uploaders

    2012-06-24 - Paul van Tilburg <paulvt@debian.org> ruby-open4 (1.3.0-1) unstable; urgency=low * New upstream release. * debian/control: - Bumped the standards-version to 3.9.3. - Bumped the build-depend on gem2deb to 0.3.0. - Set the priority for the transtional packages lib*-ruby to "extra". * debian/source/lintian-overrides: added to override description warnings for the transitional packages.

    2011-09-25 - Paul van Tilburg <paulvt@debian.org> ruby-open4 (1.1.0-1) unstable; urgency=low * New upstream release. * Source packages adapted according to the new Ruby policy: - Build for both ruby1.8 and ruby1.9.1. - Migrated to pkg-ruby-extras git repos. Changed the Vcs-* fields in debian/control accordingly. - Changed the depends and recommends to follow the new Ruby library naming scheme. * debian/control: - Added a default DM-Upload-Allowed field set to yes. - Standards-Version bumped to 3.9.2; no changes required. - Set XS-Ruby-Versions to all. - Changed the build-depends for using gem2deb instead of ruby-pkg-tools. - Switched the maintainer with the uploaders field as per new convention the team is the default maintainer. * debian/copyright: small updates.

    2010-02-20 - Lucas Nussbaum <lucas@lucas-nussbaum.net> libopen4-ruby (0.9.6-5) unstable; urgency=low * std-ver 3.8.4. No changes needed. * Switch to ruby 1.9.1. Closes: #569885.

    2009-08-27 - Roberto C. Sanchez <roberto@connexer.com> libopen4-ruby (0.9.6-4) unstable; urgency=low * Update package section to ruby to comply with new archive layout. * Bump standards version to 3.8.3 (no changes) * Make lintian happy: + Have Build-Depends satisfy requirements for 'debian/rules clean' + Add missing ${misc:Depends} dependency for each binary package

    2008-06-17 - Roberto C. Sanchez <roberto@connexer.com> libopen4-ruby (0.9.6-3) unstable; urgency=high * Build-Depends on ruby-pkg-tools >= 0.14 and install 1.9 module files into /usr/lib/ruby/1.9.0/ (Closes: #484616) * Bump Standards-Version to 3.8.0 (no changes).

    2008-05-08 - Roberto C. Sanchez <roberto@connexer.com> libopen4-ruby (0.9.6-2) unstable; urgency=high * Replace libcommandline-ruby1.8 (<< 0.7.10-10~) (Closes: #479502)

    2008-04-15 - Roberto C. Sanchez <roberto@connexer.com> libopen4-ruby (0.9.6-1) unstable; urgency=low * Initial release (Closes: #462032)

    Advertisement
    Advertisement