qmmp_1.0.5-1_i386.deb


Advertisement

Description

qmmp - feature-rich audio player with support of many formats

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name qmmp
Package version 1.0.5
Package release 1
Package architecture i386
Package type deb
Installed size 9.37 KB
Download size 1.98 MB
Official Mirror archive.ubuntu.com
Qmmp is feature-rich audio player with support of many formats.
It is written in Qt.
Audio formats supported:
- MPEG1 layer 2/3
- Ogg Vorbis
- Ogg Opus
- Native FLAC, Ogg FLAC
- Musepack
- WavePack
- tracker modules (mod, s3m, it, xm, etc)
- ADTS AAC
- CD Audio
- WMA, Monkey's Audio (and other formats provided by FFmpeg library)
- PCM WAVE (and other formats provided by libsndfile library)
- midi
- SID
- chiptune formats (AY, GBS, GYM, HES, KSS, NSF, NSFE, SAP, SPC, VGM, VGZ,
VTX)
Audio output through:
- ALSA
- OSS
- PulseAudio
- JACK
DSP effects:
- BS2B effect
- sample rate converter
- LADSPA effects
- extra stereo
- crossfade
Other features:
- XMMS and Winamp 2.x skins support
- 10-band equalizer
- MP3, Vorbis, AAC, AAC+ streams support
- mms support
- MPRIS (1.0 and 2.0)
- removable device detection (via HAL or UDisks)
- video playback via Mplayer
- lyrics (using lyrics.wikia.com)
- cover art support
- CUE sheet support
- embedded CUE support (for FLAC and WavPack)
- multiple playlists
- automatic charset detection for cue files and ShoutCast metadata
- playlist formats: m3u, pls, xspf
- ReplayGain support
- Last.fm/Libre.fm scrobbler
- CDDB support
- audio converter
- stream browser
- audio formats converter
- external programs execution on track change
- ReplayGain scanner
- visualization (spectre analyzer, projectm)
- global hotkeys

Alternatives

Package Version Architecture Repository
qmmp_1.0.5-1_amd64.deb 1.0.5 amd64 Ubuntu Universe
qmmp - - -

Requires

Name Value
libasound2 >= 1.0.27
libavcodec-ffmpeg-extra56 >= 7:2.4
libavcodec-ffmpeg56 >= 7:2.4
libavformat-ffmpeg56 >= 7:2.4
libavutil-ffmpeg54 >= 7:2.4
libbs2b0 -
libc6 >= 2.4
libcddb2 -
libcdio-cdda1 >= 0.83
libcdio13 >= 0.83
libcurl3-gnutls >= 7.16.2
libenca0 >= 1.9
libfaad2 >= 2.7
libflac8 >= 1.3.0
libgcc1 >= 1:4.2
libgme0 >= 0.5.5
libjack-0.116 -
libjack-jackd2-0 >= 1.9.5~dfsg-14
libmad0 >= 0.15.1b-3
libmms0 >= 0.4
libmodplug1 >= 1:0.8.8.5
libmpcdec6 >= 1:0.1~r435
libopusfile0 >= 0.5
libpulse0 >= 0.99.1
libqt5core5a >= 5.5.0
libqt5dbus5 >= 5.0.2
libqt5gui5 >= 5.0.2
libqt5gui5-gles >= 5.0.2
libqt5network5 >= 5.0.2
libqt5widgets5 >= 5.4.0
libqt5x11extras5 >= 5.1.0
libsamplerate0 >= 0.1.7
libsidplayfp4 -
libsndfile1 >= 1.0.20
libstdc++6 >= 4.6
libtag1v5 >= 1.9.1-2.4ubuntu1
libvorbisfile3 >= 1.1.2
libwavpack1 >= 4.40.0
libwildmidi1 >= 0.2.3
libx11-6 -

Replaces

Name Value
libqmmp-misc << 0.8
libqmmp0 << 0.8
libqmmpui0 << 0.8

Download

Type URL
Binary Package qmmp_1.0.5-1_i386.deb
Source Package qmmp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install qmmp deb package:
    # sudo apt-get install qmmp

Files

Path
/usr/bin/qmmp
/usr/include/qmmp/abstractengine.h
/usr/include/qmmp/audioparameters.h
/usr/include/qmmp/buffer.h
/usr/include/qmmp/channelmap.h
/usr/include/qmmp/decoder.h
/usr/include/qmmp/decoderfactory.h
/usr/include/qmmp/effect.h
/usr/include/qmmp/effectfactory.h
/usr/include/qmmp/enginefactory.h
/usr/include/qmmp/eqsettings.h
/usr/include/qmmp/fileinfo.h
/usr/include/qmmp/inputsource.h
/usr/include/qmmp/inputsourcefactory.h
/usr/include/qmmp/metadatamanager.h
/usr/include/qmmp/metadatamodel.h
/usr/include/qmmp/output.h
/usr/include/qmmp/outputfactory.h
/usr/include/qmmp/qmmp.h
/usr/include/qmmp/qmmpsettings.h
/usr/include/qmmp/soundcore.h
/usr/include/qmmp/statehandler.h
/usr/include/qmmp/tagmodel.h
/usr/include/qmmp/visual.h
/usr/include/qmmp/visualfactory.h
/usr/include/qmmp/volume.h
/usr/include/qmmpui/commandlinemanager.h
/usr/include/qmmpui/commandlineoption.h
/usr/include/qmmpui/configdialog.h
/usr/include/qmmpui/detailsdialog.h
/usr/include/qmmpui/filedialog.h
/usr/include/qmmpui/filedialogfactory.h
/usr/include/qmmpui/general.h
/usr/include/qmmpui/generalfactory.h
/usr/include/qmmpui/mediaplayer.h
/usr/include/qmmpui/metadataformatter.h
/usr/include/qmmpui/playlistdownloader.h
/usr/include/qmmpui/playlistformat.h
/usr/include/qmmpui/playlistgroup.h
/usr/include/qmmpui/playlistheadermodel.h
/usr/include/qmmpui/playlistitem.h
/usr/include/qmmpui/playlistmanager.h
/usr/include/qmmpui/playlistmodel.h
/usr/include/qmmpui/playlistparser.h
/usr/include/qmmpui/playlisttrack.h
/usr/include/qmmpui/qmmpuisettings.h
/usr/include/qmmpui/templateeditor.h
/usr/include/qmmpui/uifactory.h
/usr/include/qmmpui/uihelper.h
/usr/include/qmmpui/uiloader.h
/usr/lib/qmmp/libqmmp.so
/usr/lib/qmmp/libqmmp.so.1
/usr/lib/qmmp/libqmmp.so.1.0.5
/usr/lib/qmmp/libqmmpui.so
/usr/lib/qmmp/libqmmpui.so.1
/usr/lib/qmmp/libqmmpui.so.1.0.5
/usr/lib/qmmp/pkgconfig/qmmp.pc
/usr/lib/qmmp/pkgconfig/qmmpui.pc
/usr/lib/qmmp/qmmp/CommandLineOptions/libincdecvolumeoption.so
/usr/lib/qmmp/qmmp/CommandLineOptions/libplaylistoption.so
/usr/lib/qmmp/qmmp/CommandLineOptions/libseekoption.so
/usr/lib/qmmp/qmmp/CommandLineOptions/libstatusoption.so
/usr/lib/qmmp/qmmp/Effect/libbs2b.so
/usr/lib/qmmp/qmmp/Effect/libcrossfade.so
/usr/lib/qmmp/qmmp/Effect/libladspa.so
/usr/lib/qmmp/qmmp/Effect/libsrconverter.so
/usr/lib/qmmp/qmmp/Effect/libstereo.so
/usr/lib/qmmp/qmmp/Engines/libmplayer.so
/usr/lib/qmmp/qmmp/FileDialogs/libqmmpfiledialog.so
/usr/lib/qmmp/qmmp/General/libconverter.so
/usr/lib/qmmp/qmmp/General/libcopypaste.so
/usr/lib/qmmp/qmmp/General/libcovermanager.so
/usr/lib/qmmp/qmmp/General/libfileops.so
/usr/lib/qmmp/qmmp/General/libgnomehotkey.so
/usr/lib/qmmp/qmmp/General/libhotkey.so
/usr/lib/qmmp/qmmp/General/libkdenotify.so
/usr/lib/qmmp/qmmp/General/liblyrics.so
/usr/lib/qmmp/qmmp/General/libmpris.so
/usr/lib/qmmp/qmmp/General/libnotifier.so
/usr/lib/qmmp/qmmp/General/librgscan.so
/usr/lib/qmmp/qmmp/General/libscrobbler.so
/usr/lib/qmmp/qmmp/General/libstatusicon.so
/usr/lib/qmmp/qmmp/General/libstreambrowser.so
/usr/lib/qmmp/qmmp/General/libtrackchange.so
/usr/lib/qmmp/qmmp/General/libudisks2.so
/usr/lib/qmmp/qmmp/Input/libaac.so
/usr/lib/qmmp/qmmp/Input/libcdaudio.so
/usr/lib/qmmp/qmmp/Input/libcue.so
/usr/lib/qmmp/qmmp/Input/libffmpeg.so
/usr/lib/qmmp/qmmp/Input/libflac.so
/usr/lib/qmmp/qmmp/Input/libgme.so
/usr/lib/qmmp/qmmp/Input/libmad.so
/usr/lib/qmmp/qmmp/Input/libmodplug.so
/usr/lib/qmmp/qmmp/Input/libmpc.so
/usr/lib/qmmp/qmmp/Input/libopus.so
/usr/lib/qmmp/qmmp/Input/libsid.so
/usr/lib/qmmp/qmmp/Input/libsndfile.so
/usr/lib/qmmp/qmmp/Input/libvorbis.so
/usr/lib/qmmp/qmmp/Input/libwavpack.so
/usr/lib/qmmp/qmmp/Input/libwildmidi.so
/usr/lib/qmmp/qmmp/Output/libalsa.so
/usr/lib/qmmp/qmmp/Output/libjack.so
/usr/lib/qmmp/qmmp/Output/libnull.so
/usr/lib/qmmp/qmmp/Output/liboss4.so
/usr/lib/qmmp/qmmp/Output/libpulseaudio.so
/usr/lib/qmmp/qmmp/PlayListFormats/libm3uplaylistformat.so
/usr/lib/qmmp/qmmp/PlayListFormats/libplsplaylistformat.so
/usr/lib/qmmp/qmmp/PlayListFormats/libxspfplaylistformat.so
/usr/lib/qmmp/qmmp/Transports/libhttp.so
/usr/lib/qmmp/qmmp/Transports/libmms.so
/usr/lib/qmmp/qmmp/Ui/libqsui.so
/usr/lib/qmmp/qmmp/Ui/libskinned.so
/usr/lib/qmmp/qmmp/Visual/libanalyzer.so
/usr/share/applications/qmmp.desktop
/usr/share/applications/qmmp_dir.desktop
/usr/share/applications/qmmp_enqueue.desktop
/usr/share/doc/qmmp/README.RUS.gz
/usr/share/doc/qmmp/README.gz
/usr/share/doc/qmmp/changelog.Debian.gz
/usr/share/doc/qmmp/copyright
/usr/share/icons/hicolor/16x16/apps/qmmp.png
/usr/share/icons/hicolor/32x32/apps/qmmp.png
/usr/share/icons/hicolor/48x48/apps/qmmp.png
/usr/share/icons/hicolor/scalable/apps/qmmp-simple.svgz
/usr/share/icons/hicolor/scalable/apps/qmmp.svgz
/usr/share/lintian/overrides/qmmp
/usr/share/man/man1/qmmp.1.gz
/usr/share/qmmp/images/app_icon.png
/usr/share/qmmp/images/empty_cover.png

Changelog

2016-01-23 - Matteo Cypriani <mcy@lm7.fr>
qmmp (1.0.5-1) unstable; urgency=medium
* New upstream release.
* Update debian/copyright.
* Update Build-Depends (switched to Qt5).
* Remove debian/menu, according to #741573.
2015-09-30 - Matteo Cypriani <mcy@lm7.fr>
qmmp (0.9.1-1) unstable; urgency=medium
* New upstream release.
+ Fixed segfault with TTA-encoded files. (Closes: #792301)
* Update debian/copyright.
* Update debian/upstream/metadata: Qmmp has moved from Google Code to
SourceForge.
2014-10-20 - Matteo Cypriani <mcy@lm7.fr>
qmmp (0.8.2-1) unstable; urgency=low
* New upstream release.
+ Removed patches (everything applied upstream).
2014-10-06 - Matteo Cypriani <mcy@lm7.fr>
qmmp (0.8.1-1) unstable; urgency=medium
* New upstream release.
* Adoption. (Closes: #750924)
* Un-split the package: libqmmp* are now into the main qmmp package,
installed as private libraries (/usr/lib/qmmp/libqmmp*).
* Switch to debhelper 9 and format 3.0 (quilt).
* Bump Standards-Version to 3.9.6.
* debian/copyright:
+ Switch to format 1.0.
+ Full copyright review (thanks to Thomas Preud'homme): update dates, add
missing authors, add missing exceptions.
+ Relicense debian/* under GPL-2+, with authorisation of the former
maintainer, Eugene V. Lyubimkin (cf. #750924).
* debian/control:
+ Simplify Build-Depends (remove most version numbers).
+ Add missing Build-Depends: qtchooser, libcdio-dev, libopus-dev,
libopusfile-dev, libsidplayfp-dev, libenca-dev.
+ qmmp now Suggests mplayer2.
+ Add Vcs-Git and Vcs-Browser fields.
+ Update Homepage.
+ Update qmmp's Description.
* debian/rules:
+ Simplify.
+ Don't call cmake directly, use dh_auto_configure instead.
+ Add verbose build variables (commented-out).
+ Add CPPFLAGS to CFLAGS and CXXFLAGS (fixes hardening).
+ Add -Wl,--as-needed to LDFLAGS to avoid unneeded dependencies for
plugins.
* debian/patches:
+ Actually remove 010-libav10-support.patch.
+ Add allows_one_to_typo.patch.
+ Add desktop_files.patch.
* debian/watch: add "debian uupdate".
* Add debian/upstream/metadata (DEP-12).
* Add lintian override (spellcheck false positive on libqmmpui).
* Remove useless debian/README.source.
* Remove useless debian/README.Debian (Opus is supported now).
2014-06-08 - Eugene V. Lyubimkin <jackyf@debian.org>
qmmp (0.7.6-2) unstable; urgency=medium
* debian/control:
- Typo fix: s/conveter/converter/. (Closes: #746181)
- Suggest udisks2 instead of udisks on linux. Already supported upstream
since 0.7.0. (Closes: #750513)
- libqmmpui-dev now depends on libqmmp-dev. Suggested by upstream.
2014-04-23 - Eugene V. Lyubimkin <jackyf@debian.org>
qmmp (0.7.6-1) experimental; urgency=medium
* New upstream release.
- Uploading to experimental until libav10 transition is completed.
* debian/patches:
- 010-libav10-support.patch: removed, implemented in a different way
upstream.
2014-02-22 - Eugene V. Lyubimkin <jackyf@debian.org>
qmmp (0.7.5-1) unstable; urgency=low
* New upstream release.
* debian/control:
- Added quilt to Build-Depends.
- Bumped Standards-Version to 3.9.5, no changes needed.
* debian/rules:
- Use quilt sequence.
* debian/patches:
- New patch '010-libav10-support.patch' by Sebastian Ramacher.
(Closes: #739378)
2013-12-26 - Eugene V. Lyubimkin <jackyf@debian.org>
qmmp (0.7.4-1) unstable; urgency=low
* New upstream release.
* debian/copyright:
- Updated list of translators.
2013-10-05 - Eugene V. Lyubimkin <jackyf@debian.org>
qmmp (0.7.3-1) unstable; urgency=low
* New upstream relese.
2013-06-24 - Eugene V. Lyubimkin <jackyf@debian.org>
qmmp (0.7.1-1) unstable; urgency=low
* New upstream release.
* debian/control:
- Bumped Standards-Version to 3.9.4, no changes needed.
* debian/rules:
- Use dpkg-provided buildflags if possible.
- Enable verbose building.

See Also

Package Description
qmpdclient_1.2.2-2_i386.deb Qt4 client for the Music Player Daemon (MPD)
qmtest_2.4.1-3_all.deb Testing Framework (part of the Quality Management Toolset (QM))
qnapi_0.1.9-1_i386.deb application that downloads Polish subtitles from www.napiprojekt.pl
qnifti2dicom_0.4.11-1ubuntu3_i386.deb convert 3D medical images to DICOM 2D series (gui)
qonk_0.3.1-3.1build1_i386.deb Small build-and-conquer strategy game with very simple rules
qpdfview-djvu-plugin_0.4.14-1_i386.deb tabbed document viewer - DjVu plugin
qpdfview-ps-plugin_0.4.14-1_i386.deb tabbed document viewer - PostScript plugin
qpdfview-translations_0.4.14-1_all.deb tabbed document viewer - translations
qpdfview_0.4.14-1_i386.deb tabbed document viewer
qpid-client_0.16-9ubuntu2_i386.deb enterprise messaging system - AMQP client
qpid-doc_0.16-9ubuntu2_all.deb enterprise messaging system - documentation and examples
qpid-proton-dump_0.10-2_i386.deb Qpid Proton messaging tools
qpidd_0.16-9ubuntu2_i386.deb enterprise messaging system - AMQP broker
qprint-doc_1.1.dfsg.2-2_all.deb qprint quoted-printable encoder/decoder (documentation)
qprint_1.1.dfsg.2-2_i386.deb encoder and decoder for quoted-printable encoding
Advertisement
Advertisement