python-pyxb-bundles-saml20_1.2.4+dfsg-1_all.deb


Advertisement

Description

python-pyxb-bundles-saml20 - Python XML Schema Bindings (SAML bindings for Python2)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: python-pyxb-bundles-saml20
Package version: 1.2.4+dfsg
Package release: 1
Package architecture: all
Package type: deb
Installed size: 1.35 KB
Download size: 155.18 KB
Official Mirror: archive.ubuntu.com
PyXB is a pure Python package that generates Python code for classes that correspond to data structures defined by XMLSchema. In concept it is similar to JAXB for Java and CodeSynthesis XSD for C++. The major goals of PyXB are: * Provide a generated Python interface that is “Pythonic”, meaning similar to one that would have been hand-written: + Attributes and elements are Python properties, with name conflicts resolved in favor of elements + Elements with maxOccurs larger than 1 are stored as Python lists + Bindings for type extensions inherit from the binding for the base type + Enumeration constraints are exposed as class (constant) variables * Support bi-directional conversion (document to Python and back) * Allow easy customization of the generated bindings to provide functionality along with content * Support all XMLSchema features that are in common use, including: + complex content models (nested all/choice/sequence) + cross-namespace dependencies + include and import directives + constraints on simple types * Validate the documents against their schema This package contains the prebuilt Security Assertion Markup Language bindings for Python2.

Alternatives

    Download

    Source package: pyxb

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pyxb-bundles-saml20 deb package:
      # sudo apt-get install python-pyxb-bundles-saml20

    Files

    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/__init__.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/assertion.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/dce.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/ecp.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/metadata.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/protocol.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/x500.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/xacml.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/__init__.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/assertion.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/assertion.wxs
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/dce.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/dce.wxs
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/ecp.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/ecp.wxs
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/metadata.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/metadata.wxs
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/protocol.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/protocol.wxs
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/x500.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/x500.wxs
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/xacml.py
    • /usr/lib/python2.7/dist-packages/pyxb/bundles/saml20/raw/xacml.wxs
    • /usr/share/doc/python-pyxb-bundles-saml20/changelog.Debian.gz
    • /usr/share/doc/python-pyxb-bundles-saml20/copyright

    Changelog

    2014-10-24 - Michael Fladischer <FladischerMichael@fladi.at> pyxb (1.2.4+dfsg-1) unstable; urgency=low * New upstream release (Closes: #764338). * Add dh-python to Build-Depends. * Switch buildsystem to pybuild. * Add Python3 variants of all binary packages. * Rename patch to include numeric index (01-remove_remote_logo.patch). * Add 02-setup_open_unicode.patch to make tests work with Python3. * Bump Standards-Version to 3.9.6. * Rename BSD to BSD-2-clause in d/copyright. * Update years in d/copyright.

    2014-04-25 - Michael Fladischer <FladischerMichael@fladi.at> pyxb (1.2.3+dfsg-2) unstable; urgency=low * Remove override_dh_install target from debian/rules as it contained left-over debugging code. * Wrap Dependencies in debian/control. * Remove emtpy line at the end of debian/control. * Sort patterns for installed files in debian/python-pyxb.install.

    2014-04-22 - Michael Fladischer <FladischerMichael@fladi.at> pyxb (1.2.3+dfsg-1) unstable; urgency=low * Initial release (Closes: #651170).

    Advertisement
    Advertisement