python-hypothesis_3.0.1-1_all.deb


Advertisement

Description

python-hypothesis - advanced Quickcheck style testing library for Python 2

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package name python-hypothesis
Package version 3.0.1
Package release 1
Package architecture all
Package type deb
Installed size 329 B
Download size 56.93 KB
Official Mirror archive.ubuntu.com
Hypothesis is a library for testing your Python code against a much
larger range of examples than you would ever want to write by
hand. It's based on the Haskell library, Quickcheck, and is designed
to integrate seamlessly into your existing Python unit testing work
flow.
Hypothesis is both extremely practical and also advances the state of
the art of unit testing by some way. It's easy to use, stable, and
extremely powerful. If you're not using Hypothesis to test your
project then you're missing out.
This package contains the Python 2 module.

Alternatives

Package Version Architecture Repository
python-hypothesis_3.6.0-1~nd16.04+1_all.deb 3.6.0 all NeuroDebian Main
python-hypothesis_3.6.0-1~nd16.04+1_all.deb 3.6.0 all NeuroDebian Main
python-hypothesis_3.0.1-1_all.deb 3.0.1 all Ubuntu Universe
python-hypothesis - - -

Requires

Name Value
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-hypothesis_3.0.1-1_all.deb
Source Package python-hypothesis

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-hypothesis deb package:
    # sudo apt-get install python-hypothesis

Files

Path
/usr/lib/python2.7/dist-packages/hypothesis/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/_settings.py
/usr/lib/python2.7/dist-packages/hypothesis/configuration.py
/usr/lib/python2.7/dist-packages/hypothesis/control.py
/usr/lib/python2.7/dist-packages/hypothesis/core.py
/usr/lib/python2.7/dist-packages/hypothesis/database.py
/usr/lib/python2.7/dist-packages/hypothesis/errors.py
/usr/lib/python2.7/dist-packages/hypothesis/executors.py
/usr/lib/python2.7/dist-packages/hypothesis/reporting.py
/usr/lib/python2.7/dist-packages/hypothesis/stateful.py
/usr/lib/python2.7/dist-packages/hypothesis/strategies.py
/usr/lib/python2.7/dist-packages/hypothesis/strategytests.py
/usr/lib/python2.7/dist-packages/hypothesis/types.py
/usr/lib/python2.7/dist-packages/hypothesis/version.py
/usr/lib/python2.7/dist-packages/hypothesis-3.0.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/hypothesis-3.0.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/hypothesis-3.0.1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/hypothesis-3.0.1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/hypothesis-3.0.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/hypothesis-3.0.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/hypothesis/extra/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/datetime.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/fakefactory.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/numpy.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/pytestplugin.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/django/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/extra/django/models.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/charmap.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/classmap.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/compat.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/debug.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/floats.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/intervalsets.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/reflection.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/data.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/engine.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/minimizer.py
/usr/lib/python2.7/dist-packages/hypothesis/internal/conjecture/utils.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/collections.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/deferred.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/fixed.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/flatmapped.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/misc.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/numbers.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/recursive.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/reprwrapper.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/shared.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/strategies.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/streams.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/strings.py
/usr/lib/python2.7/dist-packages/hypothesis/searchstrategy/wrappers.py
/usr/lib/python2.7/dist-packages/hypothesis/tools/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/tools/mergedbs.py
/usr/lib/python2.7/dist-packages/hypothesis/utils/__init__.py
/usr/lib/python2.7/dist-packages/hypothesis/utils/conventions.py
/usr/lib/python2.7/dist-packages/hypothesis/utils/dynamicvariables.py
/usr/lib/python2.7/dist-packages/hypothesis/utils/size.py
/usr/share/doc/python-hypothesis/changelog.Debian.gz
/usr/share/doc/python-hypothesis/copyright

Changelog

2016-02-18 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.0.1-1) unstable; urgency=medium
* New upstream release.
2016-02-17 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (3.0.0-1) unstable; urgency=medium
* Fix watch file to handle alpha version.
* New upstream release.
- Add Build-Depends: python-enum34.
* Switch to https in Vcs-Git.
2016-01-23 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (2.0.0-1) unstable; urgency=medium
* New upstream version.
2015-12-21 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (1.18.0-1) unstable; urgency=medium
* New upstream release.
- Switch to GitHub tarball to pick up the tests.
* Run the tests at build time (closes: #808039).
2015-12-16 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (1.17.0-1) unstable; urgency=medium
* New upstream release.
- Change in Python 3 compatibility code (closes: #807988).
* Add myself to Uploaders.
2015-12-11 - Tristan Seligmann <mithrandi@debian.org>
python-hypothesis (1.16.0-1) unstable; urgency=medium
* Team upload.
[ Vincent Bernat ]
* Ship README.rst.
[ Stefano Rivera ]
* Update VCS fields for Git migration.
[ Tristan Seligmann ]
* New upstream release.
* Remove stray egg-info directory.
2015-09-15 - Vincent Bernat <bernat@debian.org>
python-hypothesis (1.11.0-1) unstable; urgency=medium
* Initial release. Closes: #799044.

See Also

Package Description
python-iapws_1.1.1-2_all.deb Python implementation of the international APWS-IF97 steam tables
python-ibm-db-sa_2.0.5-0ubuntu2_all.deb SQLAlchemy support for IBM Data Servers - Python 2.x
python-icalendar-doc_3.8-1_all.deb parser/generator of iCalendar files for use with Python -- docs
python-icalendar_3.8-1_all.deb parser/generator of iCalendar files for use with Python2
python-id3_1.2-6.3_all.deb Python module for id3-tags manipulation
python-ieee1284_0.2.11-12_i386.deb Python bindings to libieee1284
python-igraph_0.7.1post6-0ubuntu2_i386.deb High performance graph data structures and algorithms
python-ijson_2.3-1_all.deb event-driven JSON parser (Python 2 version)
python-image-geometry_1.11.11+ds-1_all.deb image_geometry Robot OS package - Python bindings
python-imaging-doc-html_1.1.2-1.1ubuntu1_all.deb Documentation for the Python Imaging Library
python-imaging-doc-pdf_1.1.2-1.1ubuntu1_all.deb Documentation for the Python Imaging Library
python-imaging_3.1.2-0ubuntu1_all.deb Python Imaging Library compatibility layer
python-imaplib2_2.53-1_all.deb Threaded Python IMAP4 client
python-imdbpy_5.0-1_i386.deb Python package to access the IMDb's movie database
python-imobiledevice_1.2.0+dfsg-2.1build1_i386.deb Library for communicating with iPhone and iPod Touch devices
Advertisement
Advertisement