libmuffin-dev_2.8.4-1_i386.deb


Advertisement

Description

libmuffin-dev - lightweight window and compositing manager (development files)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe i386
Package filename libmuffin-dev_2.8.4-1_i386.deb
Package name libmuffin-dev
Package version 2.8.4
Package release 1
Package architecture i386
Package type deb
Category universe/libdevel
Homepage http://cinnamon.linuxmint.com/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 51.23 KB
Installed size 516.00 KB
Muffin is a small window manager performing compositing as well based on
GTK+ and Clutter and used in desktop environment such as Cinnamon.
It is fairly extensible by the mean of plugins, providing new or customized
visual effects as well as a flexibility in the behavior of the window
manager.
This package contains the development files.

Alternatives

Package Version Architecture Repository
libmuffin-dev_2.8.4-1_amd64.deb 2.8.4 amd64 Ubuntu Universe
libmuffin-dev - - -

Requires

Name Value
gir1.2-meta-muffin-0.0 = 2.8.4-1
libclutter-1.0-dev >= 1.0.0
libgtk-3-dev >= 3.0.0
libmuffin0 = 2.8.4-1

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libmuffin-dev_2.8.4-1_i386.deb
Source Package muffin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmuffin-dev deb package:
    # sudo apt-get install libmuffin-dev

Files

Path
/usr/include/muffin/meta/atomnames.h
/usr/include/muffin/meta/boxes.h
/usr/include/muffin/meta/common.h
/usr/include/muffin/meta/compositor-muffin.h
/usr/include/muffin/meta/compositor.h
/usr/include/muffin/meta/display.h
/usr/include/muffin/meta/errors.h
/usr/include/muffin/meta/gradient.h
/usr/include/muffin/meta/group.h
/usr/include/muffin/meta/keybindings.h
/usr/include/muffin/meta/main.h
/usr/include/muffin/meta/meta-background-actor.h
/usr/include/muffin/meta/meta-plugin.h
/usr/include/muffin/meta/meta-shadow-factory.h
/usr/include/muffin/meta/meta-shaped-texture.h
/usr/include/muffin/meta/meta-window-actor.h
/usr/include/muffin/meta/prefs.h
/usr/include/muffin/meta/preview-widget.h
/usr/include/muffin/meta/screen.h
/usr/include/muffin/meta/theme.h
/usr/include/muffin/meta/types.h
/usr/include/muffin/meta/util.h
/usr/include/muffin/meta/window.h
/usr/include/muffin/meta/workspace.h
/usr/lib/i386-linux-gnu/libmuffin.so
/usr/lib/i386-linux-gnu/pkgconfig/libmuffin.pc
/usr/lib/i386-linux-gnu/pkgconfig/muffin-plugins.pc
/usr/share/doc/libmuffin-dev/changelog.Debian.gz
/usr/share/doc/libmuffin-dev/copyright
/usr/share/gir-1.0/Meta-Muffin.0.gir

Changelog

2016-01-08 - Maximiliano Curia <maxy@debian.org>
muffin (2.8.4-1) unstable; urgency=medium
* New upstream release.
* Remove patch: support-muffin-typelib
* Remove patch: revert.patch
* Update symbols files.
2015-06-18 - Maximiliano Curia <maxy@debian.org>
muffin (2.6.1-3) unstable; urgency=medium
[ Fabio Fantoni ]
* Added muffin-doc package.
2015-06-09 - Margarita Manterola <marga@debian.org>
muffin (2.6.1-2) unstable; urgency=critical
[ Maximiliano Curia ]
* Add rm_conffile rule for /etc/sgml/muffin-common.cat. (Closes:
#787695)
[ Margarita Manterola ]
* Add Breaks for cinnamon, as this package is not backwards compatible.
(Closes: #788203)
2015-06-03 - Maximiliano Curia <maxy@debian.org>
muffin (2.6.1-1) unstable; urgency=medium
* New upstream release.
2015-04-21 - Maximiliano Curia <maxy@debian.org>
muffin (2.4.5-1) experimental; urgency=medium
[ Fabio Fantoni ]
* New upstream release.
[ Maximiliano Curia ]
2015-03-02 - Maximiliano Curia <maxy@debian.org>
muffin (2.4.4-1) experimental; urgency=medium
[ Fabio Fantoni ]
* New upstream release. (Closes: #762368)
* debian/patches: removed one patch applied upstream.
[ Maximiliano Curia ]
* Bump Standards-Version to 3.9.6, no changes needed.
* Update copyright information.
* Update symbols files.
2014-10-02 - Maximiliano Curia <maxy@debian.org>
muffin (2.2.6-4) unstable; urgency=medium
* New patch: upstream_add_GTK_STATE_FLAG_CHECKED_case (Closes: #763249)
2014-08-24 - Margarita Manterola <marga@debian.org>
muffin (2.2.6-3) unstable; urgency=medium
* Remove doc symlinks, since this causes the package to be not binNMU safe.
2014-07-16 - Maximiliano Curia <maxy@debian.org>
muffin (2.2.6-2) unstable; urgency=medium
[ Margarita Manterola ]
* Incorporate changes from Ubuntu to make muffin build on ppc64el.
2014-07-12 - Margarita Manterola <marga@debian.org>
muffin (2.2.6-1) experimental; urgency=medium
[ Fabio Fantoni ]
* New upstream release.
* debian/control:
- removed libgnome2-common
- gsettings-desktop-schemas-dev -> libcinnamon-desktop-dev
- gnome-session -> cinnamon-session
- gnome-control-center -> cinnamon-control-center

See Also

Package Description
libmuffin0_2.8.4-1_i386.deb lightweight window and compositing manager (shared library)
libmulticobex1-dev_0.24-4build2_i386.deb multi-protocol cable OBEX library - development files
libmulticobex1_0.24-4build2_i386.deb multi-protocol cable OBEX library
libmultidimensional-perl_0.010-1build3_i386.deb Perl pragma to disable multidimensional array emulation
libmultiverse-core-java-doc_0.7.0-4_all.deb Documentation for libmultiverse-core-java
libmultiverse-core-java_0.7.0-4_all.deb Java library implementing Software Transactional Memory (STM)
libmumps-4.10.0_4.10.0.dfsg-4_i386.deb Direct linear systems solver - parallel shared libraries
libmumps-dev_4.10.0.dfsg-4_i386.deb Direct linear systems solver - parallel development files
libmumps-ptscotch-4.10.0_4.10.0.dfsg-4_i386.deb Direct linear systems solver - PTScotch-version shared libraries
libmumps-ptscotch-dev_4.10.0.dfsg-4_i386.deb Direct linear systems solver - PTScotch-version development files
libmumps-scotch-4.10.0_4.10.0.dfsg-4_i386.deb Direct linear systems solver - Scotch-version shared libraries
libmumps-scotch-dev_4.10.0.dfsg-4_i386.deb Direct linear systems solver - Scotch-version development files
libmumps-seq-4.10.0_4.10.0.dfsg-4_i386.deb Direct linear systems solver - non-parallel shared libraries
libmumps-seq-dev_4.10.0.dfsg-4_i386.deb Direct linear systems solver - non-parallel development files
libmunge-dev_0.5.11-3_i386.deb authentication service for credential -- development package
Advertisement
Advertisement