dogtag-pki - Dogtag Public Key Infrastructure (PKI) Suite

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe i386
Package name: dogtag-pki
Package version: 10.2.6+git20160317
Package release: 1
Package architecture: all
Package type: deb
Installed size: 45 B
Download size: 11.71 KB
Official Mirror:
The Dogtag Public Key Infrastructure (PKI) Suite is comprised of the following five subsystems and a client (for use by a Token Management System): * Certificate Authority (CA) * Data Recovery Manager (DRM) * Online Certificate Status Protocol (OCSP) Manager * Token Key Service (TKS) * Token Processing System (TPS) * Enterprise Security Client (ESC) Additionally, it provides a console GUI application used for server and user/group administration of CA, DRM, OCSP, and TKS, javadocs on portions of the Dogtag API, as well as various command-line tools used to assist with a PKI deployment.



    Source package: dogtag-pki

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install dogtag-pki deb package:
      # sudo apt-get install dogtag-pki


    • /usr/share/doc/dogtag-pki/README.Debian
    • /usr/share/doc/dogtag-pki/changelog.Debian.gz
    • /usr/share/doc/dogtag-pki/copyright


    2016-04-05 - Timo Aaltonen <> dogtag-pki (10.2.6+git20160317-1) unstable; urgency=medium * update to current 10_2_6_BRANCH. - refresh patches - add pki-user-membership.1 to pki-tools - tomcat7-build-fix.diff: Dropped, upstream. * rules: Mark systemd units disabled by default. * use-usr-bin.diff: Updated. * use-root-homedir.diff: Force home_dir to be /root, so that ipa works right. * control: Add conflicts on strongswan-pki. * pki-server: Remove default.cfg, logs on purge. (Closes: #814636) * pki-base: Remove pki.conf on purge. (Closes: #804312)

    2016-01-08 - Timo Aaltonen <> dogtag-pki (10.2.6-3) unstable; urgency=medium * pki-base.postrm: Remove upgrade logs on purge. (Closes: #801139) * use-usr-bin.diff: Fix paths to binaries to use /usr/bin instead of /bin.

    2015-10-01 - Timo Aaltonen <> dogtag-pki (10.2.6-2) unstable; urgency=medium * pki-server.dirs: Add * base.postrm: No need to remove /etc/pki here. * debian-support.diff: Drop /etc/default/tomcat8, was a leftover from t8 testing. (Closes: #800558) * debian-support.diff: Import /lib/lsb/init-functions in scripts/operations. (Closes: #800559)

    2015-09-23 - Timo Aaltonen <> dogtag-pki (10.2.6-1) unstable; urgency=medium * New upstream release based on DOGTAG_10_2_6_FEDORA_22_23_20150718 tag. * Refresh patches, drop upstreamed ones. * control: Drop libcrypt-ssleay-perl and libxml-perl from depends. * pki-tools.install: Add pki-ca-profile manpage. * control: Add python-sphinx to build-depends. * fix-jackson-paths.diff: Dropped, obsolete. Refresh other patches to drop unused jackson includes. * pki-server.install: Add sbin/pki-server. * control: strongswan-starter didn't rename it's 'pki' as planned, so add an unversioned Conflicts to pki-tools. (Closes: #767561) * control: Update vcs-git location (-> dogtag-pki.git). * Update patches. * control, pki-server.install: Clean up perl stuff, drop pki-setup- proxy which is gone. * control: Add libnuxwdog-java to build-depends, and pki-server depends. * install: Added new manpages, nuxwdog support, html docs to pki-base. * debian-support.diff: Fix nuxwdog paths. * debian-support.diff: Don't try to manage rc3.d/* symlinks. * rules: Symlink jars under subsystem WEB-INF. * pki-server.postinst,{inst,rm}: Add pki-upgrade/pki- server-upgrade snippets. * rules, patches: Explicitly build using tomcat7, and add a dummy method. (Closes: #789138) * use-dot-instead-of-source.diff: Fix bashisms. * debian-support.diff: Fix JNI_JAR_DIR.

    2014-11-07 - Timo Aaltonen <> dogtag-pki (10.2.0-4) unstable; urgency=medium * control: Add python-selinux to pki-server depends.

    2014-11-05 - Timo Aaltonen <> dogtag-pki (10.2.0-3) unstable; urgency=medium * control: Add Breaks/Replaces on strongswan-starter to pki-tools. (Closes: #767561)

    2014-10-24 - Timo Aaltonen <> dogtag-pki (10.2.0-2) unstable; urgency=medium * patches: Fix servlet jar name, and paths to jss4.jar and symkey.jar.

    2014-10-10 - Timo Aaltonen <> dogtag-pki (10.2.0-1) unstable; urgency=low * Initial release (Closes: #653606)