ruby-safe-yaml_1.0.4-1_all.deb


Advertisement

Description

ruby-safe-yaml - safer YAML loader for Ruby

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: ruby-safe-yaml
Package version: 1.0.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 71 B
Download size: 17.05 KB
Official Mirror: archive.ubuntu.com
SafeYAML provides an alternative implementation of YAML.load suitable for accepting user input in Ruby applications. Unlike Ruby's built-in implementation of YAML.load, SafeYAML's version does not expose applications to arbitrary code execution exploits.

Alternatives

    Download

    Source package: ruby-safe-yaml

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install ruby-safe-yaml deb package:
      # sudo apt-get install ruby-safe-yaml

    Files

    • /usr/lib/ruby/vendor_ruby/safe_yaml.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/deep.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/libyaml_checker.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/load.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/psych_handler.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/psych_resolver.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/resolver.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/safe_to_ruby_visitor.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/syck_hack.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/syck_node_monkeypatch.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/syck_resolver.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/version.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/parse/date.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/parse/hexadecimal.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/parse/sexagesimal.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform/to_boolean.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform/to_date.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform/to_float.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform/to_integer.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform/to_nil.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform/to_symbol.rb
    • /usr/lib/ruby/vendor_ruby/safe_yaml/transform/transformation_map.rb
    • /usr/share/doc/ruby-safe-yaml/README.md.gz
    • /usr/share/doc/ruby-safe-yaml/changelog.Debian.gz
    • /usr/share/doc/ruby-safe-yaml/copyright
    • /usr/share/doc/ruby-safe-yaml/examples/safe_yaml
    • /usr/share/rubygems-integration/all/specifications/safe_yaml-1.0.4.gemspec

    Changelog

    2015-06-25 - Antonio Terceiro <terceiro@debian.org> ruby-safe-yaml (1.0.4-1) unstable; urgency=medium * Team upload * New upstream release - test suite ported to RSpec 3 * Update packaging with a new dh-make-ruby run

    2014-05-16 - Cédric Boutillier <boutil@debian.org> ruby-safe-yaml (1.0.3-1) unstable; urgency=medium * Imported Upstream version 1.0.3 * Install bin/safe_yaml as an example + fix load_path with fix_bin_safe_yaml.patch * Refresh use_ruby-indentation.patch

    2014-01-10 - Cédric Boutillier <boutil@debian.org> ruby-safe-yaml (1.0.1-1) unstable; urgency=medium * Imported Upstream version 1.0.1 * debian/control: + update Homepage field + bump Standards-Version to 3.9.5 (no changes needed) * Refresh use_ruby-indentation.patch

    2013-09-25 - Cédric Boutillier <boutil@debian.org> ruby-safe-yaml (0.9.7-1) unstable; urgency=low * Imported Upstream version 0.9.7

    2013-09-11 - Cédric Boutillier <boutil@debian.org> ruby-safe-yaml (0.9.5-1) unstable; urgency=low * Imported Upstream version 0.9.5 * Take into account Ruby2.0 and its yamler in ruby-tests.rb (Closes: #720243).

    2013-06-26 - Cédric Boutillier <boutil@debian.org> ruby-safe-yaml (0.9.3-1) unstable; urgency=low * New upstream version * Install upstream changelog

    2013-03-28 - Cédric Boutillier <boutil@debian.org> ruby-safe-yaml (0.9.0-1) unstable; urgency=low * Initial release (Closes: #703861)

    Advertisement
    Advertisement