python-smbc_1.0.15.5-1_amd64.deb


Advertisement

Description

python-smbc - Python 2 bindings for the Samba client library

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-smbc
Package version: 1.0.15.5
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 68 B
Download size: 16.86 KB
Official Mirror: archive.ubuntu.com
This package contains an extension that allows one to write Python 2 programs that can talk to SMB/CIFS servers.

Alternatives

Provides

  • python2.7-smbc

    Download

    Source package: pysmbc

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-smbc deb package:
      # sudo apt-get install python-smbc

    Files

    • /usr/lib/python2.7/dist-packages/_smbc.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/pysmbc-1.0.15.5.egg-info
    • /usr/lib/python2.7/dist-packages/smbc/__init__.py
    • /usr/lib/python2.7/dist-packages/smbc/xattr.py
    • /usr/share/doc/python-smbc/changelog.Debian.gz
    • /usr/share/doc/python-smbc/copyright

    Changelog

    2016-02-14 - Dmitry Shachnev <mitya57@debian.org> pysmbc (1.0.15.5-1) unstable; urgency=medium * Team upload. * New upstream bugfix release. * Use https (the recommended protocol) for Vcs-Git field.

    2015-09-18 - Dmitry Shachnev <mitya57@debian.org> pysmbc (1.0.15.4-1) unstable; urgency=medium * Team upload. * Acknowledge NMUs, thanks Hideki Yamane! [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Dmitry Shachnev ] * Switch to pybuild buildsystem. * Build python3-smbc package. * Drop obsolete debian/pyversions file, use X-Python-Version instead. * Bump debhelper compatibility level to 9. * Rewrite debian/copyright using 1.0 format. * Update Homepage field. * Add Tsukasa Hamano's public key to debian/upstream/signing-key.asc and tell uscan to check the tarball signatures. * Install upstream NEWS file as a changelog.

    2015-05-26 - Hideki Yamane <henrich@debian.org> pysmbc (1.0.15.4-0.1) unstable; urgency=medium * Non-maintainer upload. * New upstream release * debian/watch - fix lintian "debian-watch-file-unsupported-pypi-url" error

    2015-04-12 - Hideki Yamane <henrich@debian.org> pysmbc (1.0.15.3-0.2) unstable; urgency=medium * Non-maintainer upload. * fix debian/watch * debian/control - set Standards-Version: 3.9.6

    2014-08-12 - Hideki Yamane <henrich@debian.org> pysmbc (1.0.15.3-0.1) unstable; urgency=medium * Non-maintainer upload. * New upstream release

    2014-07-31 - Hideki Yamane <henrich@debian.org> pysmbc (1.0.15.1-0.1) unstable; urgency=medium * Non-maintainer upload. * New upstream release * debian/patches - drop adjust-with-samba4.0.patch since now upstream uses pkg-config to detect necessary headers * debian/rules - drop "--buildsystem=python_distutils" and specify --with python2 * debian/control - add newer build-dependency: pkg-config - drop obsolete python-support - fix description grammer error

    2014-04-22 - Hideki Yamane <henrich@debian.org> pysmbc (1.0.13-0.1) unstable; urgency=medium * Non-maintainer upload. * New upstream release (Closes: #741066) - fix "python-smbc: Context.open takes 3 arguments, official docs say 1" (Closes: #635294) * debian/watch - new upstream location, it's in PyPI now.

    2014-01-23 - Hideki Yamane <henrich@debian.org> pysmbc (1.0.6-1.1) unstable; urgency=medium * Non-maintainer upload. * debian/patches - add adjust-with-samba4.0.patch: Fix "FTBFS: smbcmodule.h:23:26: fatal error: libsmbclient.h: No such file or directory" (Closes: #728624)

    2010-02-15 - Josselin Mouette <joss@debian.org> pysmbc (1.0.6-1) unstable; urgency=low [ Jérôme Guelfucci ] * Initial release. [ Josselin Mouette ] * Upload to unstable. Closes: #569992. * Require python-all-dev 2.5. * Bump debhelper requirement. * Remove debian/pycompat. * Add missing ${shlibs:Depends}. * Force debhelper to use the python_distutils system. * Add NEWS to the upstream files. * Add Vcs-* fields.

    Advertisement
    Advertisement