python-simpy3_3.0.7+dfsg-1_all.deb


Advertisement

Description

python-simpy3 - python-based simulation package

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-simpy3
Package version: 3.0.7+dfsg
Package release: 1
Package architecture: all
Package type: deb
Installed size: 193 B
Download size: 32.93 KB
Official Mirror: archive.ubuntu.com
SimPy is a process-based discrete-event simulation language based on standard Python. Its event dispatcher is based on Python’s generators and can also be used for asynchronous networking or to implement multi-agent systems (with both, simulated and real communication). Processes in SimPy are defined by Python generator functions and can, for example, be used to model active components like customers, vehicles or agents. SimPy also provides various types of shared resources to model limited capacity congestion points (like servers, checkout counters and tunnels). This package contains SimPy 3, which has conceptual and API changes from the previous version SimPy 2.

Alternatives

    Download

    Source package: python-simpy3

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-simpy3 deb package:
      # sudo apt-get install python-simpy3

    Files

    • /usr/lib/python2.7/dist-packages/simpy/__init__.py
    • /usr/lib/python2.7/dist-packages/simpy/_compat.py
    • /usr/lib/python2.7/dist-packages/simpy/core.py
    • /usr/lib/python2.7/dist-packages/simpy/events.py
    • /usr/lib/python2.7/dist-packages/simpy/rt.py
    • /usr/lib/python2.7/dist-packages/simpy/util.py
    • /usr/lib/python2.7/dist-packages/simpy-3.0.7.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/simpy-3.0.7.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/simpy-3.0.7.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/simpy/resources/__init__.py
    • /usr/lib/python2.7/dist-packages/simpy/resources/base.py
    • /usr/lib/python2.7/dist-packages/simpy/resources/container.py
    • /usr/lib/python2.7/dist-packages/simpy/resources/resource.py
    • /usr/lib/python2.7/dist-packages/simpy/resources/store.py
    • /usr/lib/python2.7/dist-packages/simpy/test/__init__.py
    • /usr/lib/python2.7/dist-packages/simpy/test/conftest.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_condition.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_environment.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_event.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_exceptions.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_interrupts.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_process.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_resources.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_rt.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_timeout.py
    • /usr/lib/python2.7/dist-packages/simpy/test/test_util.py
    • /usr/share/doc/python-simpy3/README.txt
    • /usr/share/doc/python-simpy3/changelog.Debian.gz
    • /usr/share/doc/python-simpy3/copyright

    Changelog

    2015-04-30 - Larissa Reis <larissa@colivre.coop.br> python-simpy3 (3.0.7+dfsg-1) unstable; urgency=low * SimPy 3.0.7 release (Closes: #729866) - Simpy 3 API is not compatible with Simpy 2. For information on changes from Simpy 2, see http://simpy.rtfd.org/en/latest/topical_guides/porting_from_simpy2.html * Update to Standards-Version 3.9.6 (no changes) * Update License * Rewrite debian/rules to use pybuild * Patch sphinx docs to use local inventory instead of downloading from python.org

    2012-04-17 - Nicolas Dandrimont <nicolas.dandrimont@crans.org> python-simpy (2.3.1-1) unstable; urgency=low * New upstream release - Add a patch to fix the sphinx documentation build - Add a patch to fix README.txt's encoding for the python3 build * Add a python3-simpy binary package (SimPy now supports Python3!) * Update to Standards-Version 3.9.3 (no changes) * Update the copyright file - Add the new contributors - Update format to 1.0 * Run the tests at build-time (adding a Build-Depend on python-pytest)

    2011-10-12 - Nicolas Dandrimont <nicolas.dandrimont@crans.org> python-simpy (2.2-1) unstable; urgency=low * New upstream release (Closes: #644671)

    2011-08-20 - Nicolas Dandrimont <nicolas.dandrimont@crans.org> python-simpy (2.1.0-1) unstable; urgency=low * New upstream release (Closes: #463044) * Take over the package under the Python Modules Team. - Thanks Antal A. Buss for your work on this package. * Add debian/watch file * Update Standards-Version to 3.9.2 (no changes) * Bump dehelper compat level to 8 * Switch to dh_python2 * Switch to the 3.0 (quilt) source format * Build the documentation from source * Drop old Conflicts/Replaces * Update the copyright file, switch to DEP5

    2007-12-09 - Antal A. Buss <abuss@puj.edu.co> python-simpy (1.8-1) unstable; urgency=low * New upstream release (Closes: #409997) * add Homepage fields and remove Homepage from package description. * Removed pycompat file and X{B|S}-Python related fields

    2006-08-16 - Antal A. Buss <abuss@puj.edu.co> python-simpy (1.7.1-1) unstable; urgency=low * New upstream release (Closes: #359028, #340295, #376083) * Acknowledge NMU (Closes: #373354) * Rewrite rules to follow new Python policy using python-support * Removed python2.3-simpy and python2.3-simpy-gui.

    2006-07-02 - Pierre Habouzit <madcoder@debian.org> python-simpy (1.6-1.1) unstable; urgency=low * Non-maintainer upload. * Update package to the last python policy (Closes: #373354).

    2005-06-13 - Antal A. Buss <abuss@puj.edu.co> python-simpy (1.6-1) unstable; urgency=low * New upstream release (closes: #313350)

    2005-03-27 - Antal A. Buss <abuss@puj.edu.co> python-simpy (1.5.1-3) unstable; urgency=low * Fix section conflict in doc package

    2005-03-20 - Antal A. Buss <abuss@puj.edu.co> python-simpy (1.5.1-2) unstable; urgency=low * Fix build depends (Closes: #300741)

    Advertisement
    Advertisement