python-sfml_2.2~git20150611.196c88+dfsg-2build1_amd64.deb


Advertisement

Description

python-sfml - Simple and Fast Multimedia Library - Python 2 Bindings

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-sfml
Package version: 2.2~git20150611.196c88+dfsg
Package release: 2build1
Package architecture: amd64
Package type: deb
Installed size: 1.21 KB
Download size: 275.44 KB
Official Mirror: archive.ubuntu.com
SFML is an modern multimedia library offering a wide range of subsystems useful to produce an multimedia application. It offers OpenGL integration for hardware accelerated Graphics, Windowing and input support, audio and network facilities and supports besides GNU/Linux MS Windows and Mac OS X, too. This package contains the Python 2 bindings for SFML.

Alternatives

Provides

  • python2.7-sfml

    Download

    Source package: python-sfml

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-sfml deb package:
      # sudo apt-get install python-sfml

    Files

    • /usr/lib/python2.7/dist-packages/pySFML-2.2.0.egg-info
    • /usr/lib/python2.7/dist-packages/sfml/__init__.py
    • /usr/lib/python2.7/dist-packages/sfml/audio.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/sfml/graphics.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/sfml/network.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/sfml/sf.py
    • /usr/lib/python2.7/dist-packages/sfml/system.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/sfml/window.x86_64-linux-gnu.so
    • /usr/share/doc/python-sfml/README.Debian
    • /usr/share/doc/python-sfml/changelog.Debian.gz
    • /usr/share/doc/python-sfml/copyright

    Changelog

    2016-01-19 - Matthias Klose <doko@ubuntu.com> python-sfml (2.2~git20150611.196c88+dfsg-2build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2015-09-24 - James Cowgill <james410@cowgill.org.uk> python-sfml (2.2~git20150611.196c88+dfsg-2) unstable; urgency=medium * Add patch to fix FTBFS with Cython 0.23 (Closes: #799893).

    2015-06-30 - James Cowgill <james410@cowgill.org.uk> python-sfml (2.2~git20150611.196c88+dfsg-1) unstable; urgency=medium * New upstream development version. - No released version of python-sfml builds properly with SFML 2.3 at the moment. * Use Files-Excluded instead of the get-orig-source target to exclude non-dfsg files. Re-add example resources which are dfsg but were excluded. * debian/clean: - Only clean _api.h files (not the new hacks.h file). * debian/control: - Bump required SFML version to 2.2. * debian/rules: - Don't try to run unittests - upstream removed them. * debian/watch: - Revert watch changes which were needed to handle the 1.5.1... version.

    2015-06-07 - James Cowgill <james410@cowgill.org.uk> python-sfml (1.5.1.is.1.3+dfsg-3) unstable; urgency=medium * Add 05_Fix-documentation-errors-causing-build-failures-with.patch to fix FTBFS with Sphinx 1.3 (Closes: #787855).

    2015-05-18 - James Cowgill <james410@cowgill.org.uk> python-sfml (1.5.1.is.1.3+dfsg-2) unstable; urgency=medium * debian/README.Debian - Add with information about removed non-dfsg files (see #732139). * debian/control: - Bump standards version - no changes. - Use cgit Vcs-Browser URL. * debian/copyright: - Update debian/copyright and readd Christoph Egger's copyright. * debian/patches: - Add numbers to patch names. - Add patch to fix sf.Rectangle.intersects (LP: #1400906). * debian/rules: - Fix arch-independent build failure. * debian/watch: - Fix watch file to work with 1.5.1 version number.

    2013-12-09 - James Cowgill <james410@cowgill.org.uk> python-sfml (1.5.1.is.1.3+dfsg-1) unstable; urgency=low * New upstream version 1.3 (from python-sfml.org) - This is a complete rewrite of the Python bindings for SFML2, and the new maintainer is using a different version numbering scheme. * Added myself to the list of uploaders * Change package priority from extra to optional * Bumped standards version (to 3.9.5) and debhelper compat (to 9) * Added Python 3 and documentation packages * Improve package description for debug packages

    2010-05-09 - Christoph Egger <christoph@debian.org> python-sfml (1.5-2) unstable; urgency=low * Update for SFML 1.6 * Change my email address * Switch to source format 3.0 (quilt) * Bump debhelper compat from 6 to 7 * Bump standards version from .3 to .4 (no changes)

    2010-05-09 - Christoph Egger <christoph@debian.org> python-sfml (1.5-1) unstable; urgency=low * New upstream version * Bump standards version to 3.8.3 * Replace (C) by © in debian/copyright * Take patch from Ubuntu to build with Python 2.6 - Needs a minimum Python version for python.mk

    2009-01-25 - Christoph Egger <debian@christoph-egger.org> python-sfml (1.4-1) unstable; urgency=low * New upstream version * Change my email address

    2008-07-08 - Christoph Egger <Christoph.Egger@gmx.de> python-sfml (1.3-1) unstable; urgency=low [ Christoph Egger ] * Initial release (Closes: #481667) * Adding README.source as there is now some work needed [ Gonéri Le Bouder ] * Avoid an useless linking on libpthread.so.0 by using LDFLAGS=-Wl,--as-needed

    Advertisement
    Advertisement