python-scikits-learn_0.17.0-4_all.deb


Advertisement

Description

python-scikits-learn - transitional compatibility package for scikits.learn -> sklearn migration

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-scikits-learn
Package version: 0.17.0
Package release: 4
Package architecture: all
Package type: deb
Installed size: 65 B
Download size: 3.04 KB
Official Mirror: archive.ubuntu.com
Provides old namespace (scikits.learn) and could be removed if dependent code migrated to use sklearn for clarity of the namespace.

Requires

    Download

    Source package: scikit-learn

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-scikits-learn deb package:
      # sudo apt-get install python-scikits-learn

    Files

    • /usr/share/doc/python-scikits-learn/AUTHORS.rst
    • /usr/share/doc/python-scikits-learn/README.rst.gz
    • /usr/share/doc/python-scikits-learn/changelog.Debian.gz
    • /usr/share/doc/python-scikits-learn/copyright

    Changelog

    2015-12-22 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.17.0-4) unstable; urgency=medium * debian/tests/deb_tests_lower_precision - lowering further to 4 decimals

    2015-12-21 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.17.0-3) unstable; urgency=medium * debian/control - recommend python3- versions of packages for python3-sklearn. Thanks Christopher Baines * debian/rules - boost minimal Cython version for recythonization to 0.23.1. Should enable back bakckports on older Debian/Ubuntus * debian/tests/deb_tests_lower_precision - to lower precision of test_feature_importances to avoid FTBFS on some (BE) platforms

    2015-11-13 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.17.0-2) unstable; urgency=medium * debian/copyright - extended list of copyrights/licenses (Thanks Thorsten Alteholz for review)

    2015-11-05 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.17.0-1) unstable; urgency=medium * Fresh upstream release - should address FTBFS on 32bit and other platforms due to failing tests * debian/patches/deb_no_tinyclues_external_image - to not link to external images inthe documentation (privacy concern)

    2015-10-27 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.17.0~b1+git14-g4e6829c-1) unstable; urgency=medium * Fresh beta release + post-release fixes -- test build - requires joblib >= 0.9.2 (Closes: #792483) - if succeeds, means that failing test fixed (Closes: #797507) * debian/patches - deb_disable_google_anals to disable google tracking - deb_nopaypal to refer to upstream website and not incorporate paypal form in the doc - deb_no_online_jquery to avoid referring to online jquery * debian/{control,rules} - heavy refactoring to support python3-sklearn (Closes: #730532) - point to the debian branch for git repo (Closes: #792476) - use system-wide libjs-underscore * debian/compat raise to level 7 from elderly 5

    2015-07-10 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.16.1-2) unstable; urgency=medium * Upload to unstable (Closes: #792074) * debian/control - boosted policy to 3.9.6 - properly dropped python-support, debian/rules was already using dh_ helpers (Closes: #786185) * debian/patches - Picked up from usptream 2 fixes: - changeset_190fe7347cfd6fab67f37c7535c4fa9b8f0870de.diff FIX Include PyFuncDistance attributes while pickling. - changeset_5e502596460014ed3adebe61e8189a60e72d3623.diff Fix signature not compatible with previous declaration (Closes: #791615) - deb_skip_some_tests_on_arm fixed it up (missing nose imports). Thanks Logan Rosen! (Closes: #773862)

    2015-04-14 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.16.1-1) experimental; urgency=medium * Fresh upstream bugfix release

    2015-03-30 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.16.0-1) experimental; urgency=medium * Fresh upstream release * debian/patches - deb_git_revision_cmd - use debian/github-revision.txt with github treeish for this release (TODO: automate) - deb_no_plot_gallery - do not build gallery of example plots (some require network and otherwise memory/cpu intensive etc) - deb_optional_linkcode - would not use linkcode extension if not available

    2014-10-07 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.15.2-3) unstable; urgency=medium * debian/patches - deb_skip_some_tests_on_arm -- skip two tests on armv to avoid FTBFS - up_workaround_buggy_pil -- workaround a bug in PIL

    2014-09-08 - Yaroslav Halchenko <debian@onerussian.com> scikit-learn (0.15.2-2) unstable; urgency=medium * debian/rules - fixed version for comparison against sphinx. Now documentation should get built on recent releases (Closes: #760730). Thanks Federico Ceratto for the report

    Advertisement
    Advertisement