python-rpy_1.0.3-30_amd64.deb


Advertisement

Description

python-rpy - Python interface to the GNU R language and environment

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-rpy
Package version: 1.0.3
Package release: 30
Package architecture: amd64
Package type: deb
Installed size: 119 B
Download size: 24.96 KB
Official Mirror: archive.ubuntu.com
This Debian package provides RPy, a very simple yet robust Python interface to the GNU R Programming Language. It can manage different types of R objects, and can execute arbitrary R functions, including graphic functions. URL: http://rpy.sourceforge.net/

Alternatives

Provides

  • python2.7-rpy

Conflicts

  • python2.2-rpy << 0.99.2-4
  • python2.3-rpy << 0.99.2-4
  • python2.4-rpy << 0.99.2-4

Replaces

  • python2.2-rpy << 0.99.2-4
  • python2.3-rpy << 0.99.2-4
  • python2.4-rpy << 0.99.2-4

    Download

    Source package: rpy

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-rpy deb package:
      # sudo apt-get install python-rpy

    Files

    • /usr/lib/python2.7/dist-packages/_rpy3011.so
    • /usr/lib/python2.7/dist-packages/rpy-1.0.3.egg-info
    • /usr/lib/python2.7/dist-packages/rpy.py
    • /usr/lib/python2.7/dist-packages/rpy_io.py
    • /usr/lib/python2.7/dist-packages/rpy_options.py
    • /usr/lib/python2.7/dist-packages/rpy_tools.py
    • /usr/lib/python2.7/dist-packages/rpy_version.py
    • /usr/lib/python2.7/dist-packages/rpy_wintools.py
    • /usr/share/doc/python-rpy/changelog.Debian.gz
    • /usr/share/doc/python-rpy/copyright
    • /usr/share/lintian/overrides/python-rpy

    Changelog

    2014-07-24 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-30) unstable; urgency=low * Rebuilt under R 3.1.1

    2014-04-10 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-29) unstable; urgency=low * Rebuilt under R 3.1.0 * debian/control: Added texlive-fonts-recommended and texlive-fonts-extra to Build-Depends, removed texi2html * debian/control: Set (Build-)Depends: to current R version * debian/control: Set Standards-Version: to current version

    2013-09-29 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-27) unstable; urgency=low * Rebuilt under R 3.0.2 * debian/control: Set (Build-)Depends: to current R version

    2013-06-04 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-26) unstable; urgency=low * Rebuilt under R 3.0.1 * debian/control: Set (Build-)Depends: to current R version * debian/control: Add 'texlive-latex-recommended' to Build-Depends

    2013-04-22 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-25) unstable; urgency=low * src/RPy.h: Comment-out (Rf_)PrintWarnings() which is no longer available under R 3.0.0; change committed to upstream SVN too * src/rpymodule.c: Idem (Closes: #705847)

    2013-04-04 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-24) unstable; urgency=low * Rebuilt under R 3.0.0 * debian/control: Updated for current version (Closes: #704658)

    2012-11-03 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-23) unstable; urgency=low * (A week late) rebuilding under R 2.15.2 * debian/control: Set (Build-)Depends: to current R version

    2012-07-17 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-22) unstable; urgency=low * (Belated) rebuilding under R 2.15.1 * debian/control: Set (Build-)Depends: to current R version * debian/rules: Also call dh_numpy (with thanks to lintian)

    2012-03-31 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-21) unstable; urgency=low * Rebuilt under R 2.15.0 * debian/control: Set (Build-)Depends: to current R version * debian/control: Set Standards-Version: to current version * debian/control: Set Breaks: to next R version (expected March 2013)

    2011-12-24 - Dirk Eddelbuettel <edd@debian.org> rpy (1.0.3-20) unstable; urgency=low * Rebuilt under R 2.14.1 * debian/control: Set (Build-)Depends: to current R version * debian/control: Set Standards-Version: to current version

    Advertisement
    Advertisement