python-repoze.who_2.2-3_all.deb


Advertisement

Description

python-repoze.who - ident and auth framework for Python WSGI applications - Python 2.x

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-repoze.who
Package version: 2.2
Package release: 3
Package architecture: all
Package type: deb
Installed size: 351 B
Download size: 47.19 KB
Official Mirror: archive.ubuntu.com
repoze.who is an identification and authentication framework for arbitrary Python WSGI applications; it acts as WSGI middleware. repoze.who is inspired by Zope 2's Pluggable Authentication Service (PAS), but is not dependent on Zope in any way; it is useful for any WSGI application. It provides no facility for authorization (ensuring whether a user can or cannot perform the operation implied by the request). This is considered to be the domain of the WSGI application. This package contains the Python 2.x module.

Alternatives

    Download

    Source package: python-repoze.who

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-repoze.who deb package:
      # sudo apt-get install python-repoze.who

    Files

    • /usr/lib/python2.7/dist-packages/repoze.who-2.2.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/repoze.who-2.2.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/repoze.who-2.2.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/repoze.who-2.2.egg-info/namespace_packages.txt
    • /usr/lib/python2.7/dist-packages/repoze.who-2.2.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/repoze.who-2.2.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/repoze.who-2.2.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/repoze/who/_auth_tkt.py
    • /usr/lib/python2.7/dist-packages/repoze/who/_compat.py
    • /usr/lib/python2.7/dist-packages/repoze/who/api.py
    • /usr/lib/python2.7/dist-packages/repoze/who/classifiers.py
    • /usr/lib/python2.7/dist-packages/repoze/who/config.py
    • /usr/lib/python2.7/dist-packages/repoze/who/interfaces.py
    • /usr/lib/python2.7/dist-packages/repoze/who/middleware.py
    • /usr/lib/python2.7/dist-packages/repoze/who/restrict.py
    • /usr/lib/python2.7/dist-packages/repoze/who/utils.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/auth_tkt.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/basicauth.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/htpasswd.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/redirector.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/sql.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/__init__.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/test_authtkt.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/test_basicauth.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/test_htpasswd.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/test_redirector.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/test_sql.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/fixtures/__init__.py
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/fixtures/test.htpasswd
    • /usr/lib/python2.7/dist-packages/repoze/who/plugins/tests/fixtures/testapp.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/__init__.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/test__auth_tkt.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/test__compat.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/test_api.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/test_classifiers.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/test_config.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/test_middleware.py
    • /usr/lib/python2.7/dist-packages/repoze/who/tests/test_restrict.py
    • /usr/share/doc/python-repoze.who/README.rst
    • /usr/share/doc/python-repoze.who/TODO.txt
    • /usr/share/doc/python-repoze.who/changelog.Debian.gz
    • /usr/share/doc/python-repoze.who/copyright
    • /usr/share/python/ns/python-repoze.who

    Changelog

    2015-11-13 - Thomas Goirand <zigo@debian.org> python-repoze.who (2.2-3) unstable; urgency=medium * Added reproducibility patch from Chris Lamb (Closes: #790697). * Fixed watch file.

    2015-10-31 - Thomas Goirand <zigo@debian.org> python-repoze.who (2.2-2) unstable; urgency=medium * Uploading to unstable. * Adopting the package, as per the email of Florian that the package is currently unmaintained. * Switch the package to PKG OpenStack as I have no write access to the DPMT. * Bump to debhelper/compat 9.

    2015-04-24 - Thomas Goirand <zigo@debian.org> python-repoze.who (2.2-1) experimental; urgency=low [ Thomas Goirand ] * Team upload. * Switched to format 3.0 (quilt). * Ran wrap-and-sort. * Added dh-python as build-depends. * Added Python3 support. * Added debian/source/options to ignore change to the egg-info. * debian/copyright is now using parseable format 1.0. [ Bernhard Reiter ] * New upstream release * debian/control - Add python-repoze.sphinx.autointerface to Build-Depends - Bump Standards-Version to 3.9.1 (no changes needed) - Add myself to Uploaders - Replace python-dev build dependency with python (package is pure Python) * debian/source/format: Create (with 1.0 inside) * debian/doc-base: s/pytyon-repoze-who/python-repoze.who/ * debian/watch: uversionmangle alpha part of version number [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Florian Zavatzki ] * New upstream release * debian/control: - Add myself to Uploaders - Add python-webob to Depends * debian/rules: Change rules format [ Piotr Ożarowski ] * Do not install useless .pth files

    2012-05-03 - Stefano Zacchiroli <zack@debian.org> python-repoze.who (1.0.18-2) unstable; urgency=low * Orphan package

    2009-11-05 - Piotr Ożarowski <piotr@debian.org> python-repoze.who (1.0.18-1) unstable; urgency=low * New upstream release

    2009-11-05 - Piotr Ożarowski <piotr@debian.org> python-repoze.who (1.0.16-1) unstable; urgency=low * New upstream release * Remove .pth file (module is installed into standard location) * Remove requires.txt file (dpkg does a better job of handling dependencies) * Suggest python-psycopg2 (repoze.who.plugins.sql) * Suggest libjs-jquery package and use its jquery.js * s/python-zopeinterface/python-zope.interface in {Build-,}Depends

    2009-09-13 - Stefano Zacchiroli <zack@debian.org> python-repoze.who (1.0.15-2) unstable; urgency=low * bump Standards-Version to 3.8.3 (no changes needed) * s/-setuptools/-pkg-resources/ in runtime deps, the full setuptools is not needed at runtime (Closes: #546428)

    2009-08-02 - Stefano Zacchiroli <zack@debian.org> python-repoze.who (1.0.15-1) unstable; urgency=low * new upstream release * first upload to unstable * debian/control - bump Standards-Version to 3.8.2 (no changes needed) - add Piotr as an Uploader

    2009-06-03 - Stefano Zacchiroli <zack@debian.org> python-repoze.who (1.0.13-2) experimental; urgency=low * debian/control: add build-deps on python-{zopeinterface,paste} (needed at build time), to inhibit easy_install to download it

    2009-05-29 - Stefano Zacchiroli <zack@debian.org> python-repoze.who (1.0.13-1) experimental; urgency=low * First release (Closes: #531083)

    Advertisement
    Advertisement