python-repoze.tm2_2.0-1_all.deb


Advertisement

Description

python-repoze.tm2 - Zope-like transaction manager WSGI middleware (Python 2)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-repoze.tm2
Package version: 2.0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 85 B
Download size: 9.39 KB
Official Mirror: archive.ubuntu.com
repoze.tm2 is Python WSGI middleware which uses the ZODB (Zope Object DataBase) package's transaction manager to wrap a call to its pipeline children inside a transaction. This is the Python 2 version of the package.

Alternatives

    Download

    Source package: python-repoze.tm2

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-repoze.tm2 deb package:
      # sudo apt-get install python-repoze.tm2

    Files

    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0-nspkg.pth
    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0.egg-info/namespace_packages.txt
    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/repoze.tm2-2.0.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/repoze/tm/__init__.py
    • /usr/lib/python2.7/dist-packages/repoze/tm/tests.py
    • /usr/share/doc/python-repoze.tm2/changelog.Debian.gz
    • /usr/share/doc/python-repoze.tm2/copyright
    • /usr/share/python/ns/python-repoze.tm2

    Changelog

    2014-10-05 - Jan Dittberner <jandd@debian.org> python-repoze.tm2 (2.0-1) unstable; urgency=low [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Jan Dittberner ] * New upstream version * update debian/docs to match new upstream files * switch to pybuild (Closes: #671329) * add Python3 support * split into separate Python 2, Python 3 and documentation packages * bump debian/compat to 9 * bump Standards-Version to 3.9.6 (no changes) * add extend-diff-ignore for egg-info data in debian/source/options * install CHANGES.rst as upstream changelog * change debian/copyright to machine readable format * add uversionmangle option to debian/watch to sort upstream alpha and beta versions correctly

    2012-02-04 - Jan Dittberner <jandd@debian.org> python-repoze.tm2 (1.0b2-1) unstable; urgency=low * New upstream version (Closes: #630704) * Adopting package. * debian/control: - drop cdbs and python-support from Build-Depends - bump required debhelper version to (>= 7.0.50~) - use python (>= 2.6.5~) instead of python-dev in Build-Depends - add version (>= 1.0.7+dfsg) to python-sphinx in Build-Depends - bump Standards-Version to 3.9.2 (no changes needed) - add ${sphinxdoc:Depends} to Depends * debian/rules: - use simplified dh rules using --with python2,sphinxdoc * switch to source format 3.0 (quilt)

    2012-02-01 - Stefano Zacchiroli <zack@debian.org> python-repoze.tm2 (1.0a4-3) unstable; urgency=low * Orphan package.

    2009-08-02 - Stefano Zacchiroli <zack@debian.org> python-repoze.tm2 (1.0a4-2) unstable; urgency=low * first upload to unstable * debian/control: - add build-dep on python-transaction (needed at build time), to inhibit easy_install to download it - bump Standards-Version to 3.8.2 (no changes needed)

    2009-05-29 - Stefano Zacchiroli <zack@debian.org> python-repoze.tm2 (1.0a4-1) experimental; urgency=low * First release (Closes: #531046)

    Advertisement
    Advertisement