python-renpy_6.99.8+dfsg-2_amd64.deb


Advertisement

Description

python-renpy - framework for developing visual-novel type games - Python module

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-renpy
Package version: 6.99.8+dfsg
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 3.64 KB
Download size: 698.60 KB
Official Mirror: archive.ubuntu.com
Ren'Py is a programming language and runtime, intended to ease the creation of visual-novel type games. It contains features that make it easy to display thoughts, dialogue, and menus; to display images to the user; to write game logic; and to support the saving and loading of games. This package includes the native Python module.

Alternatives

    Download

    Source package: renpy

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-renpy deb package:
      # sudo apt-get install python-renpy

    Files

    • /usr/lib/python2.7/dist-packages/Ren_Py-6.99.8.959.egg-info
    • /usr/lib/python2.7/dist-packages/_renpy.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/_renpybidi.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/pysdlsound/__init__.py
    • /usr/lib/python2.7/dist-packages/pysdlsound/sound.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/style.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/display/accelerator.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/display/render.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/gl.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/gl1.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/gldraw.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/glenviron_fixed.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/glenviron_limited.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/glenviron_shader.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/glrtt_copy.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/glrtt_fbo.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/gl/gltexture.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_activate_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_hover_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_idle_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_insensitive_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_selected_activate_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_selected_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_selected_hover_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_selected_idle_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/style_selected_insensitive_functions.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/styleclass.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/styledata/stylesets.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/text/ftfont.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/text/textsupport.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/renpy/text/texwrap.x86_64-linux-gnu.so
    • /usr/share/doc/python-renpy/changelog.Debian.gz
    • /usr/share/doc/python-renpy/copyright

    Changelog

    2016-01-26 - Markus Koschany <apo@debian.org> renpy (6.99.8+dfsg-2) unstable; urgency=medium * Team upload. * Add IMG_savepng.c.patch and fix FTBFS on Big-endian architectures.

    2016-01-26 - Markus Koschany <apo@debian.org> renpy (6.99.8+dfsg-1) unstable; urgency=medium * Team upload. * New upstream release. (Closes: #810852) * debian/control: - Switch to SDL2. - Remove libspeex-dev, libavutil-dev, libmodplug-dev, libpng-dev. - Add libjpeg-dev and python-pygame-sdl2. - Replace fonts-roboto with fonts-roboto-hinted. - renpy: Remove versioned python-renpy (<< ${source:Version}.1~) dependency. * Rebase patches 01-04. * debian/rules: Use DEB_HOST_MULTIARCH for renpy's install path. * Merge ffmpeg related patches into ffmpeg-2.9.patch. * Ensure that renpy can be built twice in a row. * debian/rules: Find all html files and fix the privacy issue. * renpy-demo: Replace NanumGothic.ttf with system font * renpy: Replace DroidSansFallback.ttf with system font. * renpy: Replace DejaVuSans-Bold.ttf with system font. * Update debian/copyright for new release and switch to copyright format 1.0. * Add get-orig-source target and remove prebuilt *.pyo files and unwanted fonts which are already packaged for Debian.

    2016-01-21 - Markus Koschany <apo@debian.org> renpy (6.17.6-4) unstable; urgency=medium * Team upload. * Fix file permissions in dh_auto_build override and only in dh_install-indep. Thus we can completely remove the second dh_install override which also ensures that the privacy issues are properly fixed.

    2016-01-12 - Markus Koschany <apo@debian.org> renpy (6.17.6-3) unstable; urgency=medium * Team upload. * Add an arch-indep override for dh_install so that building the package will not fail on buildd.

    2016-01-12 - Markus Koschany <apo@debian.org> renpy (6.17.6-2) unstable; urgency=medium * Team upload. * Fix FTBFS with FFmpeg 2.9. Thanks to Andreas Cadhalpun for the report and patch. (Closes: #803858) * Replace macros removed from FFmpeg. Thanks to Andreas Cadhalpun for the report and patch. (Closes: #758365) * wrap-and-sort -sa. * Declare compliance with Debian Policy 3.9.6. * Move the package to Git. * Remove debian/pycompat because it is obsolete. * Remove README.source because source format 3.0 uses quilt by default. * d/control: - Remove quilt from Build-Depends. - Remove dpkg-dev from Build-Depends. - Use unversioned libglew-dev build-dependency. - Remove versioned dependency on python-pygame. - Switch to fonts-dejavu-core. - Replace fonts-roboto with fonts-roboto-hinted and adjust the paths in links files accordingly. - Build-depend on libpng-dev instead of libpng12-dev. (Closes: #662492) * renpy-doc: Depend on libjs-jquery and libjs-underscore and fix Lintian warning about embedded javascript libraries. * Simplify debian/rules by using dh sequencer. Remove dirs and docs file and use install files instead. Replace dh_install, dh_links and dh_installmanpages commands with install, links and manpages files. * Ensure renpy can be built twice in a row. * source/options: Do not use bzip compression and use xz compression instead. * Update debian/watch and detect the latest releases. Thanks to Bart Martens. * desktop files: Add keywords and a comment in German. Change category key to Game;AdventureGame;

    2014-08-10 - Tobias Frost <tobi@debian.org> renpy (6.17.6-1.1) unstable; urgency=medium * Non-maintainer upload. * Tighten dependency of penpy on same version of python-renpy" (Closes: #753756)

    Advertisement
    Advertisement