python-quixote1_1.2-6_amd64.deb


Advertisement

Description

python-quixote1 - highly Pythonic Web application framework

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-quixote1
Package version: 1.2
Package release: 6
Package architecture: amd64
Package type: deb
Installed size: 409 B
Download size: 88.07 KB
Official Mirror: archive.ubuntu.com
Quixote is yet another framework for developing Web applications in Python. The design goals were: 1) To allow easy development of Web applications where the emphasis is more on complicated programming logic than complicated templating. 2) To make the templating language as similar to Python as possible, in both syntax and semantics. The aim is to make as many of the skills and structural techniques used in writing regular Python code applicable to Web applications built using Quixote. 3) No magic. When it's not obvious what to do in a certain case, Quixote refuses to guess. If you view a web site as a program, and web pages as subroutines, Quixote just might be the tool for you. If you view a web site as a graphic design showcase, and each web page as an individual work of art, Quixote is probably not what you're looking for.

Alternatives

Provides

  • python2.7-quixote1

Conflicts

  • python-quixote
  • quixote
  • quixote1

Replaces

  • python-quixote
  • quixote
  • quixote1

    Download

    Source package: quixote1

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-quixote1 deb package:
      # sudo apt-get install python-quixote1

    Files

    • /usr/lib/python2.7/dist-packages/Quixote-1.2.egg-info
    • /usr/lib/python2.7/dist-packages/quixote/__init__.py
    • /usr/lib/python2.7/dist-packages/quixote/_c_htmltext.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/quixote/_py_htmltext.py
    • /usr/lib/python2.7/dist-packages/quixote/cimport.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/quixote/config.py
    • /usr/lib/python2.7/dist-packages/quixote/errors.py
    • /usr/lib/python2.7/dist-packages/quixote/fcgi.py
    • /usr/lib/python2.7/dist-packages/quixote/html.py
    • /usr/lib/python2.7/dist-packages/quixote/http_request.py
    • /usr/lib/python2.7/dist-packages/quixote/http_response.py
    • /usr/lib/python2.7/dist-packages/quixote/mod_python_handler.py
    • /usr/lib/python2.7/dist-packages/quixote/ptl_compile.py
    • /usr/lib/python2.7/dist-packages/quixote/ptl_import.py
    • /usr/lib/python2.7/dist-packages/quixote/ptlc_dump.py
    • /usr/lib/python2.7/dist-packages/quixote/publish.py
    • /usr/lib/python2.7/dist-packages/quixote/qx_distutils.py
    • /usr/lib/python2.7/dist-packages/quixote/sendmail.py
    • /usr/lib/python2.7/dist-packages/quixote/session.py
    • /usr/lib/python2.7/dist-packages/quixote/upload.py
    • /usr/lib/python2.7/dist-packages/quixote/util.py
    • /usr/lib/python2.7/dist-packages/quixote/demo/__init__.py
    • /usr/lib/python2.7/dist-packages/quixote/demo/demo_scgi.py
    • /usr/lib/python2.7/dist-packages/quixote/demo/forms.ptl
    • /usr/lib/python2.7/dist-packages/quixote/demo/integer_ui.py
    • /usr/lib/python2.7/dist-packages/quixote/demo/pages.ptl
    • /usr/lib/python2.7/dist-packages/quixote/demo/run_cgi.py
    • /usr/lib/python2.7/dist-packages/quixote/demo/session.ptl
    • /usr/lib/python2.7/dist-packages/quixote/demo/widgets.ptl
    • /usr/lib/python2.7/dist-packages/quixote/form/__init__.py
    • /usr/lib/python2.7/dist-packages/quixote/form/form.py
    • /usr/lib/python2.7/dist-packages/quixote/form/widget.py
    • /usr/lib/python2.7/dist-packages/quixote/form2/__init__.py
    • /usr/lib/python2.7/dist-packages/quixote/form2/compatibility.py
    • /usr/lib/python2.7/dist-packages/quixote/form2/css.py
    • /usr/lib/python2.7/dist-packages/quixote/form2/form.py
    • /usr/lib/python2.7/dist-packages/quixote/form2/widget.py
    • /usr/lib/python2.7/dist-packages/quixote/server/__init__.py
    • /usr/lib/python2.7/dist-packages/quixote/server/medusa_http.py
    • /usr/lib/python2.7/dist-packages/quixote/server/twisted_http.py
    • /usr/share/doc/python-quixote1/README.Debian
    • /usr/share/doc/python-quixote1/changelog.Debian.gz
    • /usr/share/doc/python-quixote1/copyright

    Changelog

    2015-08-29 - Andrey Rahmatullin <wrar@debian.org> quixote1 (1.2-6) unstable; urgency=medium * Team upload. * Port from python-support to dh-python (Closes: #786136)

    2013-07-14 - Luca Falavigna <dktrkranz@debian.org> quixote1 (1.2-5) unstable; urgency=low * Team upload. [ Piotr Ożarowski ] * Added Vcs-Svn and Vcs-Browser fields [ Sandro Tosi ] * debian/control - uniforming Vcs-Browser field - switch Vcs-Browser field to viewsvn - set quixote1-doc as arch:all; thanks to Aurelien Jarno for the report; Closes: #517602 [ Carlos Galisteo ] * debian/control: - Added Homepage field. [ Julien Lavergne ] * From Ubuntu, prepare for the future python transition: - debian/rules: + Add --install-layout=deb to setup.py install - debian/control: + Bump build-depends to python and python-all-dev (>= 2.5.4-1~) [ Jakub Wilk ] * Add watch file. * Don't run dh_python, which is obsolete (Closes: #715306). * Remove obsolete lintian overrides. * Don't start description synopsis with an article. * Put python-quixote1 in section python, quixote1-doc in section doc. * Add ${misc:Depends} and ${shlibs:Depeds}. * Bump debhelper compat level to 7. + Use debian/compat rather than setting DH_COMPAT in debian/rules. + Bump minimum required debhelper version. + Use dh_prep instead of dh_clean -k. * Bump standards version to 3.9.2 (no changes needed). * Add build-arch and build-indep targets. * Implement binary-indep target. * Don't install duplicate changelog file. * Run dh_fixperms after dh_pysupport. * Use canonical URIs for Vcs-* fields. * Drop obsolete Conflicts/Replaces with python2.3-quixote1 and python2.4-quixote1. [ Luca Falavigna ] * Remove obsolete XB-Python-Version field. * Remove obsolete pycompat file.

    2008-11-28 - Ben Hutchings <ben@decadent.org.uk> quixote1 (1.2-4.1) unstable; urgency=low * Non-maintainer upload * Update ptl_compile for compatibility with Python 2.5 (Closes: #484360)

    2006-08-10 - Santiago Ruano Rincón <santiago@debian.org> quixote1 (1.2-4) unstable; urgency=low * Updated to the new python policy (Closes: #380926)

    2006-04-25 - Santiago Ruano Rincón <santiago@debian.org> quixote1 (1.2-3) unstable; urgency=low * Added build-dependecy on python

    2006-04-24 - Santiago Ruano Rincón <santiago@debian.org> quixote1 (1.2-2) unstable; urgency=low * New maintainer address * Added to python modules packaging team * Building python2.3-quixote1 and python2.4-quixote1 packages * Fixed a conflict with quixote 2.X package (Closes: #363240)

    2005-09-08 - Santiago Ruano Rincon <santiago@unicauca.edu.co> quixote1 (1.2-1) unstable; urgency=low * Initial debian release. (Closes: #327265: ITP: quixote1 -- A highly Pythonic Web application framework)

    Advertisement
    Advertisement