python-pyspatialite_3.0.1-10_amd64.deb


Advertisement

Description

python-pyspatialite - Python interface to Spatialite

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pyspatialite
Package version 3.0.1
Package release 10
Package architecture amd64
Package type deb
Installed size 106 B
Download size 29.43 KB
Official Mirror archive.ubuntu.com
pyspatialite is an interface to the SQLite 3.x embedded relational database
engine with spatialite extensions.
It is almost fully compliant with the Python database API version 2.0 and also
exposes the unique features of SQLite and spatialite.

Alternatives

Package Version Architecture Repository
python-pyspatialite_3.0.1-10_i386.deb 3.0.1 i386 Ubuntu Universe
python-pyspatialite - - -

Requires

Name Value
libc6 >= 2.14
libspatialite7 >= 4.1.0
python << 2.8
python >= 2.7~
python:any >= 2.7.5-5~

Provides

Name Value
python2.7-pyspatialite -

Download

Type URL
Binary Package python-pyspatialite_3.0.1-10_amd64.deb
Source Package pyspatialite

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pyspatialite deb package:
    # sudo apt-get install python-pyspatialite

Files

Path
/usr/lib/python2.7/dist-packages/pyspatialite-3.0.1.egg-info
/usr/lib/python2.7/dist-packages/pyspatialite/__init__.py
/usr/lib/python2.7/dist-packages/pyspatialite/_spatialite.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/pyspatialite/dbapi2.py
/usr/lib/python2.7/dist-packages/pyspatialite/dump.py
/usr/share/doc/python-pyspatialite/changelog.Debian.gz
/usr/share/doc/python-pyspatialite/copyright
/usr/share/lintian/overrides/python-pyspatialite

Changelog

2015-08-29 - Bas Couwenberg <sebastic@debian.org>
pyspatialite (3.0.1-10) unstable; urgency=medium
* Update Vcs-Browser URL to use HTTPS.
* Drop © character from copyright statements.
* Improve upstream release matching in watch file.
* Use debian/* instead of absolute path in rules file.
* Rebuild for geos transition.
2015-07-30 - Bas Couwenberg <sebastic@debian.org>
pyspatialite (3.0.1-9) unstable; urgency=medium
* Apply patch from Ubuntu to fix misbuild on 64-bit archs.
Thanks to Steve Langasek for forwarding the patch.
(closes: #794047)
* Use multi-line uscan options in watch file.
2015-07-14 - Bas Couwenberg <sebastic@debian.org>
pyspatialite (3.0.1-8) unstable; urgency=medium
* Add dh-python to build dependencies.
* Bump minimum libspatialite-dev version to 4.3.0.
2015-05-29 - Bas Couwenberg <sebastic@debian.org>
pyspatialite (3.0.1-7) unstable; urgency=medium
* Update my email to @debian.org address.
* Update Vcs-Browser URL to use cgit instead of gitweb.
* Bump Standards-Version to 3.9.6, no changes.
* Add patch to support spatialite_init_ex() as alternative for the
deprecated spatialite_init() method.
2014-03-22 - Bas Couwenberg <sebastic@xs4all.nl>
pyspatialite (3.0.1-6) unstable; urgency=low
* Mangle upstream version in watch file to handle with -alpha release.
* Update watch file and Homepage for upstream move to GitHub.
* Refresh patches.
* Enable parallel builds.
* Drop lintian override for no-upstream-changelog,
shouldn't override pedantic tags.
2014-03-18 - Bas Couwenberg <sebastic@xs4all.nl>
pyspatialite (3.0.1-5) unstable; urgency=low
* Add gbp.conf to use pristine-tar by default.
* Move from experimental to unstable.
2013-12-14 - Bas Couwenberg <sebastic@xs4all.nl>
pyspatialite (3.0.1-4) experimental; urgency=low
* Bump Standards-Version to 3.9.5, no changes required.
* Require at least libspatialite version 4.1.1.
2013-11-26 - Bas Couwenberg <sebastic@xs4all.nl>
pyspatialite (3.0.1-3) experimental; urgency=low
[ David Paleino ]
* Updated debian/watch.
[ Bas Couwenberg ]
* Use canonical URLs in Vcs-* fields.
* Update copyright file.
* Bump dephelper compatibility to 9.
* Bump Standards-Version to 3.9.4, no changes.
* Add lintian override for no-fortify-functions false positive.
* Add lintian override for no-upstream-changelog.
* Change priority to optional.
2012-04-17 - David Paleino <dapal@debian.org>
pyspatialite (3.0.1-2) unstable; urgency=low
* Add Gerhard Häring to copyright holders.
2012-04-15 - David Paleino <dapal@debian.org>
pyspatialite (3.0.1-1) unstable; urgency=low
* Initial release (Closes: #623805)

See Also

Package Description
python-pysph_0~20160122.git1fe4786-1_amd64.deb open source framework for Smoothed Particle Hydrodynamics
python-pysqlite2-doc_2.7.0-1_all.deb Documentation for python-pysqlite2
python-pysqlite2_2.7.0-1_amd64.deb Python interface to SQLite 3
python-pysrt_1.0.1-1_all.deb library to edit or create SubRip files (Python 2)
python-pyst_0.6.50-1_all.deb Python module for interacting with the Asterisk PBX
python-pystache_0.5.4-5_all.deb Python implementation of Mustache
python-pytango-doc_8.1.8-1_all.deb API for the TANGO control system
python-pytango_8.1.8-1_amd64.deb API for the TANGO control system (Python 2)
python-pytc_0.8-2_amd64.deb Python bindings for the Tokyo Cabinet database
python-pyte-doc_0.4.8-1_all.deb simple VTXXX-compatible terminal emulator (documentation)
python-pyte_0.4.8-1_all.deb simple VTXXX-compatible terminal emulator
python-pytest-catchlog_1.2.1-1_all.deb py.test plugin to capture test log messages
python-pytest-cov_2.2.1-1_all.deb py.test plugin to produce coverage reports
python-pytest-django_2.9.1-2_all.deb Django plugin for py.test
python-pytest-doc_2.8.7-4_all.deb Simple, powerful testing in Python - Documentation
Advertisement
Advertisement