python-pyruntest_0.1+13.10.20130702-0ubuntu3_all.deb


Advertisement

Description

python-pyruntest - Simple python test-runner

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pyruntest
Package version: 0.1+13.10.20130702
Package release: 0ubuntu3
Package architecture: all
Package type: deb
Installed size: 55 B
Download size: 5.90 KB
Official Mirror: archive.ubuntu.com
This simple test-runner is * Simple to use (zero configuration). * Can output a text report of test passes/failures. * Can output a junitxml report of test passes/failures. * Compatible with testtools and test scenarios * Can run tests with coverage, and save coverage to: - Cobertura-compatible XML. - Human-viewable HTML. - Human viewable Text.

Alternatives

    Download

    Source package: pyruntest

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pyruntest deb package:
      # sudo apt-get install python-pyruntest

    Files

    • /usr/bin/pyruntest
    • /usr/lib/python2.7/dist-packages/pyruntest-0.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/pyruntest-0.1.egg-info/SOURCES.txt
    • /usr/lib/python2.7/dist-packages/pyruntest-0.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/pyruntest-0.1.egg-info/top_level.txt
    • /usr/share/doc/python-pyruntest/changelog.Debian.gz
    • /usr/share/doc/python-pyruntest/copyright

    Changelog

    2014-03-15 - Dimitri John Ledkov <xnox@ubuntu.com> pyruntest (0.1+13.10.20130702-0ubuntu3) trusty; urgency=medium * Fix FTBFS (LP: #1270812): + Pass "cover_pylib=True" to coverage, as it now defaults to not cover modules installed in standard library. + Add jquery build-dependencies for coverage to be able to produce html coverage reports.

    2014-02-23 - Matthias Klose <doko@ubuntu.com> pyruntest (0.1+13.10.20130702-0ubuntu2) trusty; urgency=medium * Rebuild to drop files installed into /usr/share/pyshared.

    2013-07-02 - Ubuntu daily release <ps-jenkins@lists.canonical.com> pyruntest (0.1+13.10.20130702-0ubuntu1) saucy; urgency=low [ Timo Jyrinki ] * Depend on python-testtools (LP: #1155232). (LP: #1155232) [ Ubuntu daily release ] * Automatic snapshot from revision 17

    2013-06-12 - Ubuntu daily release <ps-jenkins@lists.canonical.com> pyruntest (0.1daily13.06.12-0ubuntu1) saucy; urgency=low [ Michael Terry ] * Run tests during build. (LP: #1188690) [ Ubuntu daily release ] * Automatic snapshot from revision 15

    2013-06-05 - Ubuntu daily release <ps-jenkins@lists.canonical.com> pyruntest (0.1daily13.06.05-0ubuntu1) saucy; urgency=low * Automatic snapshot from revision 13

    2013-05-03 - Ubuntu daily release <ps-jenkins@lists.canonical.com> pyruntest (0.1daily13.05.03ubuntu.unity.next-0ubuntu1) raring; urgency=low * Automatic snapshot from revision 12 (ubuntu-unity/next)

    2013-03-13 - Ubuntu daily release <ps-jenkins@lists.canonical.com> pyruntest (0.1daily13.03.13.2-0ubuntu1) raring; urgency=low [ Martin Mrazik ] * pyruntest combines stdout with xml (LP: #1154032) [ Ubuntu daily release ] * Automatic snapshot from revision 11

    2012-11-29 - Automatic PS uploader <ps-jenkins@lists.canonical.com> pyruntest (0.1daily12.11.29.2-0ubuntu1) raring; urgency=low [ Martin Mrasik ] * Initial release [ Mathieu Trudel-Lapierre ] * Automatic snapshot from revision 1 (bootstrap). * debian/control: - Update long/short descriptions for python-pyruntest. - Wrap and update (Build-)Depends lists to use trailing commas. - Add Vcs-Bzr, Vcs-Browser and add a notice to uploaders. - Bump debhelper Build-Depends to (>= 9). - Drop build-depends on python-support. * debian/compat: bump to compat level 9. * debian/source/format: migrate back to source format 1.0. * debian/rules: - Override dh_install to fail the build if files are missing. [ Automatic PS uploader ] * Automatic snapshot from revision 9

    Advertisement
    Advertisement