python-pyroute2_0.3.5-1_all.deb


Advertisement

Description

python-pyroute2 - Python Netlink library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pyroute2
Package version 0.3.5
Package release 1
Package architecture all
Package type deb
Installed size 413 B
Download size 72.17 KB
Official Mirror archive.ubuntu.com
Pyroute2 is a pure Python netlink and Linux network configuration
library. It requires only Python stdlib, no 3rd party libraries.
Later it can change, but the deps tree will remain as simple, as
it is possible.
This is the Python 2 compatible package.

Alternatives

Package Version Architecture Repository
python-pyroute2_0.3.5-1_all.deb 0.3.5 all Ubuntu Universe
python-pyroute2 - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-pyroute2_0.3.5-1_all.deb
Source Package pyroute2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pyroute2 deb package:
    # sudo apt-get install python-pyroute2

Files

Path
/usr/lib/python2.7/dist-packages/pyroute2-0.3.5.egg-info
/usr/lib/python2.7/dist-packages/pyroute2/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/arp.py
/usr/lib/python2.7/dist-packages/pyroute2/common.py
/usr/lib/python2.7/dist-packages/pyroute2/config.py
/usr/lib/python2.7/dist-packages/pyroute2/iproute.py
/usr/lib/python2.7/dist-packages/pyroute2/iwutil.py
/usr/lib/python2.7/dist-packages/pyroute2/netns.py
/usr/lib/python2.7/dist-packages/pyroute2/protocols.py
/usr/lib/python2.7/dist-packages/pyroute2/proxy.py
/usr/lib/python2.7/dist-packages/pyroute2/ipdb/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/ipdb/common.py
/usr/lib/python2.7/dist-packages/pyroute2/ipdb/interface.py
/usr/lib/python2.7/dist-packages/pyroute2/ipdb/linkedset.py
/usr/lib/python2.7/dist-packages/pyroute2/ipdb/route.py
/usr/lib/python2.7/dist-packages/pyroute2/ipdb/transactional.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/nlsocket.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/generic/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/ipq/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/nfnetlink/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/nfnetlink/nfqueue.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/nl80211/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/__init__.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/dhcpmsg.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/errmsg.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/ifaddrmsg.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/ifinfmsg.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/iw_event.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/ndmsg.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/req.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/rtmsg.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/rtnl/tcmsg.py
/usr/lib/python2.7/dist-packages/pyroute2/netlink/taskstats/__init__.py
/usr/share/doc/python-pyroute2/changelog.Debian.gz
/usr/share/doc/python-pyroute2/copyright

Changelog

2015-03-26 - Florian Pelgrim <florian.pelgrim@craneworks.de>
pyroute2 (0.3.5-1) unstable; urgency=medium
* Update package to 0.3.5 
2015-01-02 - Florian Pelgrim <florian.pelgrim@craneworks.de>
pyroute2 (0.3.3-1) unstable; urgency=low
* Initial packaging Closes: #772572

See Also

Package Description
python-pyrrd_0.1.0-2_all.deb object-oriented Python interface for RRD
python-pyrss2gen_1.1-1_all.deb interface for generating RSS 2.0 feeds
python-pyruntest_0.1+13.10.20130702-0ubuntu3_all.deb Simple python test-runner
python-pysam-tests_0.7.7-1ubuntu1_all.deb interface for the SAM/BAM sequence alignment and mapping format (test data)
python-pysam_0.7.7-1ubuntu1_amd64.deb interface for the SAM/BAM sequence alignment and mapping format
python-pyscard_1.9.2-2_amd64.deb Python wrapper above PC/SC API
python-pyscript-doc_0.6.1-4_all.deb Python module for producing postscript graphics - documentation
python-pyscript_0.6.1-4_all.deb Python module for producing postscript graphics
python-pyshp_1.2.3+ds-1_all.deb read/write support for ESRI Shapefile format
python-pyside.phonon_1.2.2-2build2_amd64.deb Qt 4 Phonon module - Python bindings
python-pyside.qtcore_1.2.2-2build2_amd64.deb Qt 4 core module - Python bindings
python-pyside.qtdeclarative_1.2.2-2build2_amd64.deb Qt 4 Declarative module - Python bindings
python-pyside.qtgui_1.2.2-2build2_amd64.deb Qt 4 GUI module - Python bindings
python-pyside.qthelp_1.2.2-2build2_amd64.deb Qt 4 help module - Python bindings
python-pyside.qtnetwork_1.2.2-2build2_amd64.deb Qt 4 network module - Python bindings
Advertisement
Advertisement