python-pyoperators_0.13.6-1_amd64.deb


Advertisement

Description

python-pyoperators - Operators and solvers for high-performance computing (Python 2)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pyoperators
Package version: 0.13.6
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 586 B
Download size: 108.04 KB
Official Mirror: archive.ubuntu.com
The PyOperators package defines operators and solvers for high-performance computing. These operators are multi-dimensional functions with optimised and controlled memory management. If linear, they behave like matrices with a sparse storage footprint. This package provides the Python 2 version of the library.

Alternatives

    Download

    Source package: pyoperators

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pyoperators deb package:
      # sudo apt-get install python-pyoperators

    Files

    • /usr/lib/python2.7/dist-packages/pyoperators-0.13.egg-info
    • /usr/lib/python2.7/dist-packages/pyoperators/__init__.py
    • /usr/lib/python2.7/dist-packages/pyoperators/config.py
    • /usr/lib/python2.7/dist-packages/pyoperators/core.py
    • /usr/lib/python2.7/dist-packages/pyoperators/fft.py
    • /usr/lib/python2.7/dist-packages/pyoperators/flags.py
    • /usr/lib/python2.7/dist-packages/pyoperators/linear.py
    • /usr/lib/python2.7/dist-packages/pyoperators/memory.py
    • /usr/lib/python2.7/dist-packages/pyoperators/nonlinear.py
    • /usr/lib/python2.7/dist-packages/pyoperators/operators_mpi.py
    • /usr/lib/python2.7/dist-packages/pyoperators/operators_pywt.py
    • /usr/lib/python2.7/dist-packages/pyoperators/proxy.py
    • /usr/lib/python2.7/dist-packages/pyoperators/rules.py
    • /usr/lib/python2.7/dist-packages/pyoperators/warnings.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/__init__.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/algorithms.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/cg.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/core.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/criterions.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/dli.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/lanczos.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/linesearch.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/optimize.py
    • /usr/lib/python2.7/dist-packages/pyoperators/iterative/stopconditions.py
    • /usr/lib/python2.7/dist-packages/pyoperators/utils/__init__.py
    • /usr/lib/python2.7/dist-packages/pyoperators/utils/cythonutils.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/pyoperators/utils/fake_MPI.py
    • /usr/lib/python2.7/dist-packages/pyoperators/utils/misc.py
    • /usr/lib/python2.7/dist-packages/pyoperators/utils/mpi.py
    • /usr/lib/python2.7/dist-packages/pyoperators/utils/testing.py
    • /usr/lib/python2.7/dist-packages/pyoperators/utils/ufuncs.x86_64-linux-gnu.so
    • /usr/share/doc/python-pyoperators/changelog.Debian.gz
    • /usr/share/doc/python-pyoperators/copyright

    Changelog

    2015-07-03 - Ghislain Antony Vaillant <ghisvail@gmail.com> pyoperators (0.13.6-1) unstable; urgency=medium * New upstream release.

    2015-02-19 - Ghislain Antony Vaillant <ghisvail@gmail.com> pyoperators (0.13.5-2) unstable; urgency=medium * d/control: - remove numpy and scipy from recommends - move pyfftw to suggests * d/p/001-fix-requirements.diff: - force numpexpr as dependency - remove pyfftw from requirements * d/watch: use pypi.debian.net

    2015-02-12 - Ghislain Antony Vaillant <ghisvail@gmail.com> pyoperators (0.13.5-1) unstable; urgency=medium * New upstream release * d/copyright: cme fixed * d/control: cme fixed

    2014-09-23 - Ghislain Antony Vaillant <ghisvail@gmail.com> pyoperators (0.13-1) unstable; urgency=low * Initial release (Closes: #762752)

    Advertisement
    Advertisement