python-pyode_1.2.0-4+cvs20090320.1build1_amd64.deb


Advertisement

Description

python-pyode - Python bindings for The Open Dynamics Engine

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pyode
Package version: 1.2.0
Package release: 4+cvs20090320.1build1
Package architecture: amd64
Package type: deb
Installed size: 487 B
Download size: 92.43 KB
Official Mirror: archive.ubuntu.com
PyODE is a set of open-source Python bindings for The Open Dynamics Engine, an open-source physics engine. PyODE also includes an XODE parser. This package provides PyODE for supported versions of Python.

Alternatives

Provides

  • python2.7-pyode

Conflicts

  • python2.3-pyode
  • python2.4-pyode

Replaces

  • python2.3-pyode
  • python2.4-pyode

    Download

    Source package: pyode

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pyode deb package:
      # sudo apt-get install python-pyode

    Files

    • /usr/lib/python2.7/dist-packages/PyODE-1.2.0.egg-info
    • /usr/lib/python2.7/dist-packages/ode.so
    • /usr/lib/python2.7/dist-packages/xode/__init__.py
    • /usr/lib/python2.7/dist-packages/xode/body.py
    • /usr/lib/python2.7/dist-packages/xode/errors.py
    • /usr/lib/python2.7/dist-packages/xode/geom.py
    • /usr/lib/python2.7/dist-packages/xode/joint.py
    • /usr/lib/python2.7/dist-packages/xode/node.py
    • /usr/lib/python2.7/dist-packages/xode/parser.py
    • /usr/lib/python2.7/dist-packages/xode/transform.py
    • /usr/share/doc/python-pyode/AUTHORS
    • /usr/share/doc/python-pyode/README
    • /usr/share/doc/python-pyode/TODO.Debian
    • /usr/share/doc/python-pyode/changelog.Debian.gz
    • /usr/share/doc/python-pyode/copyright

    Changelog

    2015-11-12 - Iain Lane <iain@orangesquash.org.uk> pyode (1.2.0-4+cvs20090320.1build1) xenial; urgency=medium * No-change rebuild against new ode

    2013-06-28 - Andrea Colangelo <warp10@ubuntu.com> pyode (1.2.0-4+cvs20090320.1) unstable; urgency=low * Non-maintainer upload. * Convert to dh_python2. (Closes: #616976)

    2009-03-20 - Yaroslav Halchenko <debian@onerussian.com> pyode (1.2.0-4+cvs20090320) unstable; urgency=low * Build-depends on libode-dev instead of libode0-dev (closes: #520457). Thanks Adeodato Simo. * Added Vcs fields. * Added installation of upstream's changelog. * python-pyrex Build-Depend. * Incorporated upstream changes since 1.2.0: - Apply linear/angular damping patch from Tristam MacDonald. - Rename __new__ to __cinit__ for new Pyrex version. - Compiling against new ODE -- requires dInitODE(). - Document last change. - Include whatever necessary flags/libs are needed for ODE. - Rename type to space_type for pyrex. - Changelog entry describing previous commit. - * tutorial3.py: change glScale to glScalef to be compatible with python-opengl version 3.0 and up. Thanks to Nathanial Troutman for finding the bug and suggesting a fix. - Reapply weakref patch after finding bug in tutorial3.py. - * heightfielddata.pyx: Save a reference to the data tuple, because otherwise it gets garbage collected and causes problems. Thanks to Dan Miller for finding the bug and figuring it out. - Revert weakref patch; it breaks the tutorials. - Bug fix from Dan Miller. - Applied the heightfield patch - Applied a couiple of patches posted by Ethan Glasser-Camp (GeomRay doc strings, angle methods on UniversalJoint, GeomObject.__delattr__, weak refs, triangle count)

    2008-07-12 - Yaroslav Halchenko <debian@onerussian.com> pyode (1.2.0-3) unstable; urgency=low * Rebuild with up-to-date pycentral (closes: #490522) * Standards version boost to 3.8.0: - Homepage is in header field now - Section python instead of science - Library depends without debian revision

    2007-07-22 - Yaroslav Halchenko <debian@onerussian.com> pyode (1.2.0-2) unstable; urgency=low * Since ode>=0.8.dfsg-1 builds with-trimesh=gimpact, patch patches/01_ode_notrimesh.dpatch is disabled * Rebuilt against most recent (lib)ode (Closes: #431941)

    2007-02-22 - Yaroslav Halchenko <debian@onerussian.com> pyode (1.2.0-1) experimental; urgency=low * New upstream release (Closes: #410945) (Thanks Ethan Glasser-Camp for a buzz) * debian/patches/01_{debian_ode_config.dpatch,ode_pyrex_0.9.4.dpatch} no longer applied * Explicit depends on libode0c2 (>=0.7-1) via debian/shlibs.local * Since libode 0.7 shipped within Debian is without trimesh support, trimesh support disabled for building pyode (patches/01_ode_notrimesh.dpatch)

    2006-06-13 - Yaroslav Halchenko <debian@onerussian.com> pyode (1.1.0-1) unstable; urgency=low * Initial release Closes: #329013

    Advertisement
    Advertisement