python-pynzb_0.1.0-2_all.deb


Advertisement

Description

python-pynzb - unified API for parsing NZB files from NNTP (Usenet) servers

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pynzb
Package version: 0.1.0
Package release: 2
Package architecture: all
Package type: deb
Installed size: 59 B
Download size: 6.90 KB
Official Mirror: archive.ubuntu.com
pynzb is a unified API for parsing NZB files, with several concrete implementations included. NZB is an XML-based file format for retrieving posts from NNTP (Usenet) servers. Since NZB is XML-based, it's relatively easy to build one-off parsers to parse NZB files. This project is an attempt to consolidate those many one-off NZB parsers into one simple interface. This package includes three implementations (listed in order of compatibility): one based on expat, another based on ElementTree, and a final implementation based on lxml. The expat version should work on all versions of Python > 2.0. The ElementTree implementation will work on Python > 2.5. The lxml version will work as long as lxml is installed. Simply import nzb_parser from the pynzb package. It's an instantiated version of the fastest available parser that your system can support.

Alternatives

    Download

    Source package: python-pynzb

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pynzb deb package:
      # sudo apt-get install python-pynzb

    Files

    • /usr/lib/python2.7/dist-packages/pynzb/__init__.py
    • /usr/lib/python2.7/dist-packages/pynzb/base.py
    • /usr/lib/python2.7/dist-packages/pynzb/etree_nzb.py
    • /usr/lib/python2.7/dist-packages/pynzb/expat_nzb.py
    • /usr/lib/python2.7/dist-packages/pynzb/lxml_nzb.py
    • /usr/lib/python2.7/dist-packages/pynzb/tests.py
    • /usr/lib/python2.7/dist-packages/pynzb-0.1.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/pynzb-0.1.0.egg-info/SOURCES.txt
    • /usr/lib/python2.7/dist-packages/pynzb-0.1.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/pynzb-0.1.0.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/pynzb-0.1.0.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/pynzb-0.1.0.egg-info/top_level.txt
    • /usr/share/doc/python-pynzb/changelog.Debian.gz
    • /usr/share/doc/python-pynzb/copyright

    Changelog

    2014-10-23 - Hans-Christoph Steiner <hans@eds.org> python-pynzb (0.1.0-2) unstable; urgency=low * use https:// URL for pypi in debian/watch * clarify description (Closes: #749218)

    2013-09-16 - Hans-Christoph Steiner <hans@eds.org> python-pynzb (0.1.0-1) unstable; urgency=low * source package automatically created by stdeb 0.6.0+git * Initial release (Closes: #723170)

    Advertisement
    Advertisement