python-pykaraoke_0.7.5-1.1_amd64.deb


Advertisement

Description

python-pykaraoke - free CDG/MIDI/MPEG karaoke player

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pykaraoke
Package version 0.7.5
Package release 1.1
Package architecture amd64
Package type deb
Installed size 499 B
Download size 91.20 KB
Official Mirror archive.ubuntu.com
PyKaraoke is a free karaoke player. You can use this program to play your
collection of CDG, MIDI and MPEG karaoke songs.
This package includes the Python modules needed to play CDG files, MIDI/KAR
files and MPEG files.
This package also includes the arch-dependent modules that gives a major
performance boost to the CDG player.
Features:
* CDG (MP3+G, OGG+G) playback - Play standard CDG karaoke files
* MIDI (.MID/.KAR) playback - Play MIDI format karaoke files
* MPEG playback - Play karaoke songs and movies in MPEG format
MIDI/KAR support on Linux, requires the following:
* Timidity++
* Sounds/patches for Timidity++ (e.g. freepats or eawpatches)

Alternatives

Package Version Architecture Repository
python-pykaraoke_0.7.5-1.1_i386.deb 0.7.5 i386 Ubuntu Universe
python-pykaraoke - - -

Requires

Name Value
libc6 >= 2.14
libsdl1.2debian >= 1.2.11
python >= 2.7
python << 2.8
python-pygame -
ttf-dejavu -

Provides

Name Value
python2.7-pykaraoke -

Download

Type URL
Binary Package python-pykaraoke_0.7.5-1.1_amd64.deb
Source Package pykaraoke

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pykaraoke deb package:
    # sudo apt-get install python-pykaraoke

Files

Path
/usr/lib/python2.7/dist-packages/_pycdgAux.so
/usr/lib/python2.7/dist-packages/performer_prompt.py
/usr/lib/python2.7/dist-packages/pycdg.py
/usr/lib/python2.7/dist-packages/pycdgAux.py
/usr/lib/python2.7/dist-packages/pykar.py
/usr/lib/python2.7/dist-packages/pykaraoke-0.7.5.egg-info
/usr/lib/python2.7/dist-packages/pykaraoke.py
/usr/lib/python2.7/dist-packages/pykaraoke_mini.py
/usr/lib/python2.7/dist-packages/pykconstants.py
/usr/lib/python2.7/dist-packages/pykdb.py
/usr/lib/python2.7/dist-packages/pykenv.py
/usr/lib/python2.7/dist-packages/pykmanager.py
/usr/lib/python2.7/dist-packages/pykplayer.py
/usr/lib/python2.7/dist-packages/pykversion.py
/usr/lib/python2.7/dist-packages/pympg.py
/usr/share/doc/python-pykaraoke/changelog.Debian.gz
/usr/share/doc/python-pykaraoke/copyright

Changelog

2014-10-07 - Olly Betts <olly@survex.com>
pykaraoke (0.7.5-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Update to use wxPython 3.0 (Closes: #758948):
+ New patch: wxpython3.0.patch
* Drop dependency on python-wxgtk2.6 (Closes: #645568)
2011-11-24 - Miriam Ruiz <little_miry@yahoo.es>
pykaraoke (0.7.5-1) unstable; urgency=low
[ Miriam Ruiz ]
* New Upstream Release.
* Upgraded Standards-Version from 3.8.4 to 3.9.2
* Transitioned to dh_python2
See: http://wiki.debian.org/Python/TransitionToDHPython2
* Changed dependency from python-wxgtk2.6 
to python-wxgtk2.8 | python-wxgtk2.6
2010-05-15 - Miriam Ruiz <little_miry@yahoo.es>
pykaraoke (0.7.3-1) unstable; urgency=low
[ Miriam Ruiz ]
* New Upstream Release:
- Fixes for international / unicode characters in filenames.
- Supports unusual CDG file draw commands found in the wild.
- Makes About window work with Wx2.6 again.
- Options for double-buffered and hardware.
- Cleans up keyboard operations.
- ā€˜Pā€™ pauses, Backspace rewinds.
- Remote control access to pykaraoke_mini.
- Supports left/right margins
- Improvements to printing support.
- Fixes occasional crash in CDG player.
- Improvements for GP2X, Windows and OSX.
* Upgraded Standards-Version from 3.8.3 to 3.8.4
2010-02-04 - Python Applications Packaging Team <python-apps-team@lists.alioth.debian.org>
pykaraoke (0.7.1-3) unstable; urgency=low
[ Jakub Wilk ]
* In order to fix FTBFS, replace build-dependency on python-wxversion with
python-wxgtk2.6 (closes: #562390).
* Add Depends: ${misc:Depends}.
* Include patch from Jonathan Wiltshire to fix bashism in cdg2mpg
(closes: #547761).
2009-11-16 - Python Applications Packaging Team <python-apps-team@lists.alioth.debian.org>
pykaraoke (0.7.1-2) unstable; urgency=medium
* Include patch from Karl Ferdinand Ebert:
Fix "should use python-numpy instead of python-num{eric,array}"
by changing only suggest field in debian/control as code base
contains already import case (Closes: #478453).
2009-08-28 - Miriam Ruiz <little_miry@yahoo.es>
pykaraoke (0.7.1-1) unstable; urgency=low
[ Miriam Ruiz ]
* New Upstream Release.
- Fixes a bug with choosing files from the Folder View.
- It now uses python-mutagen instead of MP3Info.py
* Added python-mutagen to Recommends in python-pykaraoke binary package.
2009-08-21 - Miriam Ruiz <little_miry@yahoo.es>
pykaraoke (0.7.0-1) unstable; urgency=low
[ Miriam Ruiz ]
* New Upstream Release.
* Added Vcs-Svn and Vcs-Browser to debian/control
* Bumped Standards-Version to 3.8.3 in debian/control
* Added python-wxversion to build dependencies
* Removed dh_desktop from debian/rules (deprecated)
* Install cdg2mpg in pykaraoke-bin
2009-07-05 - Ryan Kavanagh <ryanakca@kubuntu.org>
pykaraoke (0.6.1-1) UNRELEASED; urgency=low
[ Ryan Kavanagh ]
* Add depends on ttf-dejavu-extra so we can find "DejaVuSansCondensed.ttf"
(Closes: #436135)
[ Marco Rodrigues ]
* New upstream version.
* debian/control:
+ Replace 'python' by 'Python' to fix
lintian warning.
[ Julien Lavergne ]
* From Ubuntu, prepare for the future python transition:
- debian/rules: Add --install-layout=deb to setup.py install
- debian/control: Bump build-depends to python-all-dev (>= 2.5.4-1~)

See Also

Package Description
python-pykdtree_0.2-1_amd64.deb Fast kd-tree implementation with OpenMP-enabled queries
python-pykickstart_1.83-2_all.deb Python library for manipulating kickstart files
python-pykka_1.2.1-2_all.deb Actor model library for Python (Python 2)
python-pykmip_0.4.0-2_all.deb implementation of the Key Management Interoperability Protocol - Python 2.x
python-pyknon_1.0-1_all.deb Simple Python music library
python-pylast_1.0.0-1_all.deb Python interface to Last.fm and other compatible services
python-pyld_0.6.8-1_all.deb implementation of the JSON-LD API
python-pylibmc-doc_1.5.0-4build1_all.deb libmemcached wrapper (Documentation)
python-pylibmc_1.5.0-4build1_amd64.deb libmemcached wrapper
python-pylint-celery_0.3-1_all.deb Pylint plugin for code using the Celery library
python-pylint-common_0.2.2-1_all.deb Pylint plugin for the standard Python library
python-pylint-django_0.7.1-1_all.deb Pylint plugin for analysing code using Django (Python 2)
python-pylint-flask_0.1-1_all.deb Pylint plugin for analyzing Flask applications (Python 2)
python-pylint-plugin-utils_0.2.3-2_all.deb Utilities and helpers for writing Pylint plugins (Python 2)
python-pylirc_0.0.5-3build1_amd64.deb Python bindings for Linux Infra-red Remote Control (LIRC) support
Advertisement
Advertisement