python-pygit2_0.24.0-0ubuntu2_amd64.deb


Advertisement

Description

python-pygit2 - bindings for libgit2 - Python 2.x

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pygit2
Package version 0.24.0
Package release 0ubuntu2
Package architecture amd64
Package type deb
Installed size 491 B
Download size 92.36 KB
Official Mirror archive.ubuntu.com
The Pygit2 module provides a set of Python bindings to the libgit2 shared
library. libgit2 implements the core of Git. Pygit2 works with Python 2.7,
3.2, 3.3, 3.4 and pypy.
This package contains the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-pygit2_0.24.0-0ubuntu2_i386.deb 0.24.0 i386 Ubuntu Universe
python-pygit2 - - -

Requires

Name Value
libc6 >= 2.14
libgit2-24 >= 0.24.0
python << 2.8
python >= 2.7~
python-cffi >= 0.9.2
python-cffi-backend-api-9729 -
python-six -
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-pygit2_0.24.0-0ubuntu2_amd64.deb
Source Package python-pygit2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pygit2 deb package:
    # sudo apt-get install python-pygit2

Files

Path
/usr/lib/python2.7/dist-packages/_pygit2.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/pygit2/__init__.py
/usr/lib/python2.7/dist-packages/pygit2/_build.py
/usr/lib/python2.7/dist-packages/pygit2/_libgit2.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/pygit2/_run.py
/usr/lib/python2.7/dist-packages/pygit2/blame.py
/usr/lib/python2.7/dist-packages/pygit2/config.py
/usr/lib/python2.7/dist-packages/pygit2/credentials.py
/usr/lib/python2.7/dist-packages/pygit2/decl.h
/usr/lib/python2.7/dist-packages/pygit2/errors.py
/usr/lib/python2.7/dist-packages/pygit2/ffi.py
/usr/lib/python2.7/dist-packages/pygit2/index.py
/usr/lib/python2.7/dist-packages/pygit2/py2.py
/usr/lib/python2.7/dist-packages/pygit2/py3.py
/usr/lib/python2.7/dist-packages/pygit2/refspec.py
/usr/lib/python2.7/dist-packages/pygit2/remote.py
/usr/lib/python2.7/dist-packages/pygit2/repository.py
/usr/lib/python2.7/dist-packages/pygit2/settings.py
/usr/lib/python2.7/dist-packages/pygit2/submodule.py
/usr/lib/python2.7/dist-packages/pygit2/utils.py
/usr/lib/python2.7/dist-packages/pygit2-0.24.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pygit2-0.24.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pygit2-0.24.0.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/pygit2-0.24.0.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/pygit2-0.24.0.egg-info/top_level.txt
/usr/share/doc/python-pygit2/changelog.Debian.gz
/usr/share/doc/python-pygit2/copyright

Changelog

2016-04-17 - Matthias Klose <doko@ubuntu.com>
python-pygit2 (0.24.0-0ubuntu2) xenial; urgency=medium
* Build-depend on six.
2016-04-17 - Matthias Klose <doko@ubuntu.com>
python-pygit2 (0.24.0-0ubuntu1) xenial; urgency=medium
* New upstream release.
2016-02-06 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.23.3-1) unstable; urgency=medium
* New upstream release.
2015-12-28 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.23.0-2) unstable; urgency=medium
* Rebuild to fix permission error in Py3 (Closes: #807435).
2015-09-08 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.23.0-1) unstable; urgency=medium
* New upstream release (Closes: #797185):
- Fixes can't import in Python3 (Closes: #796657).
* Refreshed and rebased patches.
2015-06-10 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.22.0-3) unstable; urgency=medium
* Depends on version >= 0.9.2 of python-cffi (Closes: #788095).
2015-06-08 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.22.0-2) unstable; urgency=medium
* Removed broken unit tests (Closes: #786509).
* Fixed watch file.
2015-05-26 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.22.0-1) unstable; urgency=medium
* New upstream release:
- Adds support for libgit2 >= 0.22 which unfortunately is incompatible
with previous version, so we restrict to that (Closes: #786597).
* Ran wrap-and-sort.
* Removed version in Build-Depends on python{3,}-all-dev.
* Overrides dh_auto_clean to allow easier gbp builds.
* Added PYTHON_PATH=. when running unit tests (Closes: #786509).
2015-05-07 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.21.4-2) unstable; urgency=medium
[ Yaroslav Halchenko ]
* debian/watch
- add trailing slash to fix downloads
* debian/control
- add python{,3}-{cffi,pycparser} to build-depends (Closes: #784298).
* debian/rules
- export http{,s}_proxy to prevent any online activity during build
[ Thomas Goirand ]
* Uploading to unstable.
2014-11-13 - Thomas Goirand <zigo@debian.org>
python-pygit2 (0.21.4-1) unstable; urgency=medium
* Initial release. (Closes: #769427)

See Also

Package Description
python-pyglet_1.1.4.dfsg-3_all.deb cross-platform windowing and multimedia library
python-pygoocanvas_0.14.1-1.1ubuntu1_amd64.deb GooCanvas Python bindings
python-pygooglechart_0.4.0+git20140622-1_all.deb complete wrapper for the Google Chart API
python-pygrace_0.4p2-3_all.deb Python bindings for grace
python-pygraph_1.8.2-6_all.deb library for working with graphs in Python
python-pygraphviz-doc_1.3.1-0ubuntu2_all.deb Python interface to the Graphviz graph layout and visualization package (doc)
python-pygraphviz_1.3.1-0ubuntu2_amd64.deb Python interface to the Graphviz graph layout and visualization package
python-pygresql_4.0-3.1_amd64.deb PostgreSQL module for Python
python-pyhsm_1.0.4l-1_all.deb Python code for talking to a Yubico YubiHSM hardware
python-pyip_0.7-2_all.deb Python modules for raw ip packet assembling/disassembling
python-pyisomd5sum_1.1.0-1build1_amd64.deb ISO9660 checksum Python module
python-pyjavaproperties_0.6-2.1_all.deb Python implementation of java.util.Properties
python-pykaraoke_0.7.5-1.1_amd64.deb free CDG/MIDI/MPEG karaoke player
python-pykdtree_0.2-1_amd64.deb Fast kd-tree implementation with OpenMP-enabled queries
python-pykickstart_1.83-2_all.deb Python library for manipulating kickstart files
Advertisement
Advertisement