python-pyfiglet_0.7.4+dfsg-2_all.deb


Advertisement

Description

python-pyfiglet - Python port of the FIGlet specification

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pyfiglet
Package version 0.7.4+dfsg
Package release 2
Package architecture all
Package type deb
Installed size 82 B
Download size 14.63 KB
Official Mirror archive.ubuntu.com
FIGLet is a program that creates large characters out of ordinary screen
characters. It takes ASCII text and renders it in ASCII art fonts.
This is a Python port of the original C figlet.  It can be used on the
commandline or as an Object Oriented driver library in your own programs.

Alternatives

Package Version Architecture Repository
python-pyfiglet_0.7.4+dfsg-2_all.deb 0.7.4+dfsg all Ubuntu Universe
python-pyfiglet - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-pyfiglet_0.7.4+dfsg-2_all.deb
Source Package pyfiglet

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pyfiglet deb package:
    # sudo apt-get install python-pyfiglet

Files

Path
/usr/lib/python2.7/dist-packages/pyfiglet/__init__.py
/usr/lib/python2.7/dist-packages/pyfiglet/__main__.py
/usr/lib/python2.7/dist-packages/pyfiglet/test.py
/usr/lib/python2.7/dist-packages/pyfiglet/version.py
/usr/lib/python2.7/dist-packages/pyfiglet-0.7.4.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pyfiglet-0.7.4.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pyfiglet-0.7.4.egg-info/top_level.txt
/usr/share/doc/python-pyfiglet/README.gz
/usr/share/doc/python-pyfiglet/changelog.Debian.gz
/usr/share/doc/python-pyfiglet/copyright

Changelog

2015-07-03 - Stefano Rivera <stefanor@debian.org>
pyfiglet (0.7.4+dfsg-2) unstable; urgency=medium
* Patch py3k: Don't attempt to decode command line args in py3k.
* Update depends for smoketests ADT tests. We now require figlet, as it
contains our default font.
2015-07-03 - Stefano Rivera <stefanor@debian.org>
pyfiglet (0.7.4+dfsg-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
* debian/watch:
- Switch to dversionmangle and repacksuffix, now that it exists.
- Switch from the deprecated githubredir.d.n to github's tag view.
* figlet is now free, and in main:
- Drop patch debian-defaults.
- Build-Depend on figlet, for tests.
- Recommend figlet, as well as toilet-fonts.
* Patch bad-toilet-fonts: The test suite upstream has got stricter, but
fails on some toilet fonts. Skip them.
* Drop XS-Testsuite field, now unnecessary.
* Bump copyright years.
2014-10-17 - Stefano Rivera <stefanor@debian.org>
pyfiglet (0.7.2+dfsg-1) unstable; urgency=medium
* New upstream bugfix release.
* Refresh patches.
* Bump Standards-Version to 3.9.6, no changes needed.
2014-07-27 - Stefano Rivera <stefanor@debian.org>
pyfiglet (0.7.1+dfsg-1) unstable; urgency=medium
* New upstream release.
* Refresh patches.
* Bump copyright years.
* Replace source tarball repacking logic with uscan's Files-Excluded
support.
* Port to pybuild.
- Build-Depend on dh-python.
- Remove SOURCES.txt cleanup.
- Build for Python 3. The Python 3 package has taken over the pyfiglet
command line tool.
* Run upstream test suite. Build-Depends on toilet.
* Add upstream test suite as an ADT test.
* Bump Standards-Version to 3.9.5, no changes needed.
* Add DEP-12 upstream metadata.
2013-05-26 - Stefano Rivera <stefanor@debian.org>
pyfiglet (0.6.1+dfsg-1) unstable; urgency=low
[ Stefano Rivera ]
* New upstream release.
- Includes manpage, drop our man page.
* Update Homepage.
* Bump Standards-Version to 3.9.4.
- Bump debhelper Depends to 8.1 for build-{arch,indep} support.
* Bump machine readable copyright format to 1.0.
* Bump copyright years.
* Bump debhelper compat level to 8.
* Moved repack.sh into a get-packaged-orig-source rule in rules.
* Drop SOURCES.txt from the binary package.
* Add smoketest autopkgtest.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2011-08-18 - Stefano Rivera <stefanor@debian.org>
pyfiglet (0.6+dfsg-1) unstable; urgency=low
* New upstream release.
- Update copyright.
- Update man page.
* Upstream moved to github, updated watch file and get-orig-source.
* Dropped patches superseded upstream:
py26deprecation.diff, dir-error-path.diff, tlf-support.diff
* font-location.diff: Look in /usr/share/figlet for fonts, rather than using
pkg_resources.
* Updated debian-defaults.diff.
* Install wrapper with dh_install, as upstream has a setup.py.
* Build-Depend on python-setuptools and clean up egg-info.
* Move DFSG repacking into a script called by uscan.
2011-05-01 - Stefano Rivera <stefanor@debian.org>
pyfiglet (0.4+dfsg-3) unstable; urgency=low
* debian/copyright:
- Update upstream maintainer's email address.
- Update format.
* Update my e-mail address.
* Use X-Python-Version.
- BD on python-all 2.6.5-13.
- Specify supported versions rather than all.
* Drop Breaks: ${python:Breaks}, no longer used by dh_python2.
* Bump Standards-Version to 3.9.2, no changes needed.
* debian/rules: Correct argument order for dh.
* Patches: Update Forwarding status, upstream development has moved to
github.
* Correct DEP3 headers (first line of Description is the subject)

See Also

Package Description
python-pyfits_3.4-1_amd64.deb Python module for reading, writing, and manipulating FITS files
python-pyflakes_1.1.0-2_all.deb passive checker of Python 2 programs
python-pyflot_0.2-1_all.deb interface from Python to libjs-flot
python-pyfribidi_0.11.0+repack-1_amd64.deb FriBidi Python bindings
python-pyftpdlib_1.4.0-1_all.deb Python FTP server library
python-pygal_2.0.12-2_all.deb Python svg graph plotting library
python-pygame-sdl2_6.99.8-3_amd64.deb reimplementation of the Pygame API using SDL2
python-pygame_1.9.1release+dfsg-10_amd64.deb SDL bindings for games development in Python
python-pygccxml_1.0.0-5_all.deb specialized XML reader reads the output from gccxml
python-pygeoif_0.6-1_all.deb basic implementation of the __geo_interface__
python-pygetdata_0.9.0-2.2_amd64.deb library to read/write dirfile data - python bindings
python-pyghmi_0.8.0-1_all.deb General Hardware Management Initiative (IPMI and others)
python-pygit2-doc_0.24.0-0ubuntu2_all.deb bindings for libgit2 - doc
python-pygit2_0.24.0-0ubuntu2_amd64.deb bindings for libgit2 - Python 2.x
python-pyglet_1.1.4.dfsg-3_all.deb cross-platform windowing and multimedia library
Advertisement
Advertisement