python-pyfftw_0.10.1+dfsg1-1_amd64.deb


Advertisement

Description

python-pyfftw - Pythonic wrapper around FFTW - Python 2

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pyfftw
Package version 0.10.1+dfsg1
Package release 1
Package architecture amd64
Package type deb
Installed size 311 B
Download size 75.24 KB
Official Mirror archive.ubuntu.com
Pythonic wrapper around FFTW, the speedy FFT library. The ultimate
aim is to present a unified interface for all the possible transforms
that FFTW can perform.
Both the complex DFT and the real DFT are supported, as well as
arbitrary axes of abitrary shaped and strided arrays, which makes it
almost feature equivalent to standard and real FFT functions of
numpy.fft (indeed, it supports the clongdouble dtype which numpy.fft
does not).
This package provides the Python 2 bindings.

Alternatives

Package Version Architecture Repository
python-pyfftw_0.10.1+dfsg1-1_i386.deb 0.10.1+dfsg1 i386 Ubuntu Universe
python-pyfftw - - -

Requires

Name Value
libc6 >= 2.4
libfftw3-double3 -
libfftw3-long3 -
libfftw3-single3 -
python >= 2.7~
python << 2.8
python-numpy >= 1:1.10.0~b1
python-numpy-abi9 -
python:any >= 2.7.5-5~

Provides

Name Value
python-fftw3 -

Conflicts

Name Value
python-fftw3 -

Replaces

Name Value
python-fftw3 -

Download

Type URL
Binary Package python-pyfftw_0.10.1+dfsg1-1_amd64.deb
Source Package pyfftw

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pyfftw deb package:
    # sudo apt-get install python-pyfftw

Files

Path
/usr/lib/python2.7/dist-packages/pyFFTW-0.10.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/pyFFTW-0.10.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/pyFFTW-0.10.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/pyfftw/__init__.py
/usr/lib/python2.7/dist-packages/pyfftw/pyfftw.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/pyfftw/version.py
/usr/lib/python2.7/dist-packages/pyfftw/builders/__init__.py
/usr/lib/python2.7/dist-packages/pyfftw/builders/_utils.py
/usr/lib/python2.7/dist-packages/pyfftw/builders/builders.py
/usr/lib/python2.7/dist-packages/pyfftw/interfaces/__init__.py
/usr/lib/python2.7/dist-packages/pyfftw/interfaces/_utils.py
/usr/lib/python2.7/dist-packages/pyfftw/interfaces/cache.py
/usr/lib/python2.7/dist-packages/pyfftw/interfaces/numpy_fft.py
/usr/lib/python2.7/dist-packages/pyfftw/interfaces/scipy_fftpack.py
/usr/share/doc/python-pyfftw/changelog.Debian.gz
/usr/share/doc/python-pyfftw/copyright

Changelog

2016-02-02 - Ghislain Antony Vaillant <ghisvail@gmail.com>
pyfftw (0.10.1+dfsg1-1) unstable; urgency=medium
* New upstream release. (Closes: #810522)
* d/watch: add repacksuffix option.
* d/control: use recommended VCS entries.
* Update d/control:
- source: add dh-python and setuptools to Build-Depends.
- python{3}-h5py: remove manual Depends, use pythondeps and shlibdeps
instead.
- python{3}-h5py-dbg: move python{3}-dbg and python{3}-numpy-dbg from
Recommends to Depends.
* Update patch queue:
- Drop patch arm-build.diff.
- Discover fftw libraries using pkgconfig.
- Add build dependency on python{3}-pkgconfig.
Thanks to Aurelien Jarno (Closes: #746998)
* d/rules: enable clean target by pybuild.
* d/copyright: update copyright information.
2015-09-23 - Ghislain Antony Vaillant <ghisvail@gmail.com>
pyfftw (0.9.2+dfsg-4) unstable; urgency=medium
* Remove install dependency on the long-double version of FFTW on
arm{el,hf} architectures. (Closes: 799831)
2015-09-22 - Ghislain Antony Vaillant <ghisvail@gmail.com>
pyfftw (0.9.2+dfsg-3) unstable; urgency=medium
* d/watch: use pypi.debian.net.
* d/p/arm-build.diff: fixes build on arm. (Closes: #779724)
- Thanks to Matthias Klose for forwarding the fix.
* d/control: bump standards version to 3.9.6, no changes required.
* d/copyright:
- update copyright information for pyFFTW and debian,
- remove copyright information for DFSG-stripped files.
2014-06-13 - Ghislain Antony Vaillant <ghisvail@gmail.com>
pyfftw (0.9.2+dfsg-2) unstable; urgency=medium
[ Ghislain Antony Vaillant ]
* Rename python*-fftw3 to python-pyfftw
- to conform with the Debian Python policy
* Update uploader field with correct GPG ID
* Use pybuild as the package build system 
* d/control: remove unused depend on libjs-query
[ Andreas Tille ]
* debhelper 9
2013-10-28 - Ghislain Antony Vaillant <ghisvail@gmail.com>
pyfftw (0.9.2+dfsg-1) unstable; urgency=low
* Initial release (Closes: #728085)

See Also

Package Description
python-pyfiglet_0.7.4+dfsg-2_all.deb Python port of the FIGlet specification
python-pyfits_3.4-1_amd64.deb Python module for reading, writing, and manipulating FITS files
python-pyflakes_1.1.0-2_all.deb passive checker of Python 2 programs
python-pyflot_0.2-1_all.deb interface from Python to libjs-flot
python-pyfribidi_0.11.0+repack-1_amd64.deb FriBidi Python bindings
python-pyftpdlib_1.4.0-1_all.deb Python FTP server library
python-pygal_2.0.12-2_all.deb Python svg graph plotting library
python-pygame-sdl2_6.99.8-3_amd64.deb reimplementation of the Pygame API using SDL2
python-pygame_1.9.1release+dfsg-10_amd64.deb SDL bindings for games development in Python
python-pygccxml_1.0.0-5_all.deb specialized XML reader reads the output from gccxml
python-pygeoif_0.6-1_all.deb basic implementation of the __geo_interface__
python-pygetdata_0.9.0-2.2_amd64.deb library to read/write dirfile data - python bindings
python-pyghmi_0.8.0-1_all.deb General Hardware Management Initiative (IPMI and others)
python-pygit2-doc_0.24.0-0ubuntu2_all.deb bindings for libgit2 - doc
python-pygit2_0.24.0-0ubuntu2_amd64.deb bindings for libgit2 - Python 2.x
Advertisement
Advertisement