python-pyevolve_0.6~rc1+svn398+dfsg-7_all.deb


Advertisement

Description

python-pyevolve - complete genetic algorithm framework

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pyevolve
Package version 0.6~rc1+svn398+dfsg
Package release 7
Package architecture all
Package type deb
Installed size 355 B
Download size 53.45 KB
Official Mirror archive.ubuntu.com
Pyevolve was developed to be a complete genetic algorithm framework written in
pure Python. It provides an easy-to-use API, implementing the most common
features of GA, including various selectors and scaling schemes. It is also
easily extendable, allowing users to create new representations and genetic
operators. Various methods of interactive and non-interactive visualization
are supported.
This package contains the Python modules.

Alternatives

Package Version Architecture Repository
python-pyevolve_0.6~rc1+svn398+dfsg-7_all.deb 0.6~rc1+svn398+dfsg all Ubuntu Universe
python-pyevolve - - -

Requires

Name Value
python -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-pyevolve_0.6~rc1+svn398+dfsg-7_all.deb
Source Package pyevolve

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pyevolve deb package:
    # sudo apt-get install python-pyevolve

Files

Path
/usr/bin/pyevolve-graph
/usr/lib/python2.7/dist-packages/Pyevolve-0.6.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/Pyevolve-0.6.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/Pyevolve-0.6.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/pyevolve/Consts.py
/usr/lib/python2.7/dist-packages/pyevolve/Crossovers.py
/usr/lib/python2.7/dist-packages/pyevolve/DBAdapters.py
/usr/lib/python2.7/dist-packages/pyevolve/FunctionSlot.py
/usr/lib/python2.7/dist-packages/pyevolve/G1DBinaryString.py
/usr/lib/python2.7/dist-packages/pyevolve/G1DList.py
/usr/lib/python2.7/dist-packages/pyevolve/G2DBinaryString.py
/usr/lib/python2.7/dist-packages/pyevolve/G2DList.py
/usr/lib/python2.7/dist-packages/pyevolve/GAllele.py
/usr/lib/python2.7/dist-packages/pyevolve/GPopulation.py
/usr/lib/python2.7/dist-packages/pyevolve/GSimpleGA.py
/usr/lib/python2.7/dist-packages/pyevolve/GTree.py
/usr/lib/python2.7/dist-packages/pyevolve/GenomeBase.py
/usr/lib/python2.7/dist-packages/pyevolve/Initializators.py
/usr/lib/python2.7/dist-packages/pyevolve/Interaction.py
/usr/lib/python2.7/dist-packages/pyevolve/Migration.py
/usr/lib/python2.7/dist-packages/pyevolve/Mutators.py
/usr/lib/python2.7/dist-packages/pyevolve/Network.py
/usr/lib/python2.7/dist-packages/pyevolve/Scaling.py
/usr/lib/python2.7/dist-packages/pyevolve/Selectors.py
/usr/lib/python2.7/dist-packages/pyevolve/Statistics.py
/usr/lib/python2.7/dist-packages/pyevolve/Util.py
/usr/lib/python2.7/dist-packages/pyevolve/__init__.py
/usr/share/doc/python-pyevolve/README.Debian
/usr/share/doc/python-pyevolve/changelog.Debian.gz
/usr/share/doc/python-pyevolve/copyright
/usr/share/lintian/overrides/python-pyevolve
/usr/share/man/man1/pyevolve-graph.1.gz

Changelog

2015-07-07 - Christian Kastner <debian@kvr.at>
pyevolve (0.6~rc1+svn398+dfsg-7) unstable; urgency=medium
[ Juan Picca ]
* debian/rules:
- Make the build reproducible. Closes: #788403
[ Christian Kastner ]
* debian/control:
- Bump Standards-Version to 3.9.6 (no changes needed)
- Drop XS-Testsuite. dpkg now recognizes the Testsuite header, and
dpkg-source automatically adds one when an autopkgtest suite is found.
- Lower-case package synopsis
- Remove trailing whitespace in package description
* debian/copyright:
- Avoid spaces in short license name
- Bump copyright years
2014-08-17 - Christian Kastner <debian@kvr.at>
pyevolve (0.6~rc1+svn398+dfsg-6) unstable; urgency=medium
* Migrate the git repo to the Debian Science section at git.debian.org
* debian/control:
- Update Vcs-* URLs to point to new location
* debian/tests:
- Fix syntax error in autopkgtest control file, preventing tests from being
run properly.
2014-08-10 - Christian Kastner <debian@kvr.at>
pyevolve (0.6~rc1+svn398+dfsg-5) unstable; urgency=low
* debian/tests:
- Add missing dependency on python-pydot to "run-most-examples"
2014-08-07 - Christian Kastner <debian@kvr.at>
pyevolve (0.6~rc1+svn398+dfsg-4) unstable; urgency=low
* debian/tests:
- Define an autopkgtest "run-most-examples". Runs all of upstream's
examples except for a very-long-running one, and one designed for visual
output.
* debian/control:
- Add version (>= 1.0.7+dfsg-1~) to Build-Depends of python-sphinx
(as recommended by pybuild wiki)
- Add XS-Testsuite header for autopkgtest
* debian/rules:
- Switch to pybuild
- Run autopkgtest after build against build result
2014-03-04 - Christian Kastner <debian@kvr.at>
pyevolve (0.6~rc1+svn398+dfsg-3) unstable; urgency=low
* debian/control:
- Bump Standards-Version to 3.9.5 (no changes needed)
- Bump debhelper Build-Depends to (>= 9)
- Bump python-all Build-Depends to (>= 2.6.6-3~)
- python-pyevolve-doc: drop Recommends for libjs-jquery and add Depends for
${sphinxdoc:Depends}. sphinxdoc will add the right dependency
- Add X-Python-Version with >= 2.6, thereby implicitly dropping support for
Python 2.5 (it used to be supported in the now removed debian/pyversions).
- Drop Build-Depends for python-support
- Remove obsolete DM-Upload-Allowed field
* debian/compat:
- Bump debhelper compatibility level to 9
* debian/rules:
- Convert Python build helper from deprecated python-support to dh_python2
- Build documentation using dh_sphinxdoc
- Drop unnecessary cleaning, dh_sphinxdoc does it for us
* debian/svn-orig-source.sh
- Fix for relative path breakage
* debian/pyversions:
- Dropped (obsolete)
* debian/copyright:
- Update to machine-readable format v1.0
* debian/source/lintian-overrides:
- Add override for debian-watch-may-check-gpg-signature
* debian/*.lintian-overrides:
- Add overrides for no-upstream-changelog
* debian/gbp.conf
- Created (package is based on dfsg branch, not upstream)
2011-06-01 - Christian Kastner <debian@kvr.at>
pyevolve (0.6~rc1+svn398+dfsg-2) unstable; urgency=low
[ Jakub Wilk ]
* Symlink jquery.js into the correct directory. Closes: #627359
[ Christian Kastner ]
* debian/svn-get-orig.sh:
- Added this script which creates an upstream tarball from an SVN revision
* debian/rules:
- Re-added get-orig-source target (via svn-get-orig.sh above)
[ Yaroslav Halchenko ]
* debian/control:
- Added DM-Upload-Allowed

See Also

Package Description
python-pyexiv2-doc_0.3.2-5ubuntu4build2_all.deb Documentation for Python binding to Exiv2
python-pyexiv2_0.3.2-5ubuntu4build2_amd64.deb Python binding to Exiv2
python-pyface_4.5.2-1_all.deb traits-capable windowing framework
python-pyfai-doc_0.11.0+dfsg-3build1_all.deb Fast Azimuthal Integration scripts - Documentation
python-pyfai_0.11.0+dfsg-3build1_amd64.deb Fast Azimuthal Integration scripts - Python2
python-pyfaidx-examples_0.4.5.2-1_all.deb example data for efficient random access to fasta subsequences for Python
python-pyfaidx_0.4.5.2-1_all.deb efficient random access to fasta subsequences for Python
python-pyfann_1.0.7-4build1_amd64.deb deprecated Python bindings for FANN
python-pyfftw_0.10.1+dfsg1-1_amd64.deb Pythonic wrapper around FFTW - Python 2
python-pyfiglet_0.7.4+dfsg-2_all.deb Python port of the FIGlet specification
python-pyfits_3.4-1_amd64.deb Python module for reading, writing, and manipulating FITS files
python-pyflakes_1.1.0-2_all.deb passive checker of Python 2 programs
python-pyflot_0.2-1_all.deb interface from Python to libjs-flot
python-pyfribidi_0.11.0+repack-1_amd64.deb FriBidi Python bindings
python-pyftpdlib_1.4.0-1_all.deb Python FTP server library
Advertisement
Advertisement