python-pyelftools_0.23-2_all.deb


Advertisement

Description

python-pyelftools - pure-python2 library for parsing ELF and DWARF

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pyelftools
Package version: 0.23
Package release: 2
Package architecture: all
Package type: deb
Installed size: 363 B
Download size: 65.77 KB
Official Mirror: archive.ubuntu.com
pyelftools is a pure-Python library for parsing and analyzing ELF files and DWARF debugging information. It can be used to query information about compiled binaries and libraries from your Python code. This package installs the library for Python 2.

Alternatives

    Download

    Source package: python-pyelftools

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pyelftools deb package:
      # sudo apt-get install python-pyelftools

    Files

    • /usr/lib/python2.7/dist-packages/pyelftools-0.23.egg-info
    • /usr/lib/python2.7/dist-packages/elftools/__init__.py
    • /usr/lib/python2.7/dist-packages/elftools/common/__init__.py
    • /usr/lib/python2.7/dist-packages/elftools/common/construct_utils.py
    • /usr/lib/python2.7/dist-packages/elftools/common/exceptions.py
    • /usr/lib/python2.7/dist-packages/elftools/common/py3compat.py
    • /usr/lib/python2.7/dist-packages/elftools/common/utils.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/__init__.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/adapters.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/core.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/debug.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/macros.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/lib/__init__.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/lib/binary.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/lib/bitstream.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/lib/container.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/lib/hex.py
    • /usr/lib/python2.7/dist-packages/elftools/construct/lib/py3compat.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/__init__.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/abbrevtable.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/callframe.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/compileunit.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/constants.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/descriptions.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/die.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/dwarf_expr.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/dwarfinfo.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/enums.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/lineprogram.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/locationlists.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/ranges.py
    • /usr/lib/python2.7/dist-packages/elftools/dwarf/structs.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/__init__.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/constants.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/descriptions.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/dynamic.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/elffile.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/enums.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/gnuversions.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/relocation.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/sections.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/segments.py
    • /usr/lib/python2.7/dist-packages/elftools/elf/structs.py
    • /usr/share/doc/python-pyelftools/changelog.Debian.gz
    • /usr/share/doc/python-pyelftools/copyright

    Changelog

    2015-12-31 - Tomasz Buchert <tomasz@debian.org> python-pyelftools (0.23-2) unstable; urgency=medium * d/copyright: LPGL-2+ -> LGPL-2 * d/rules: run test suite manually

    2015-04-27 - Tomasz Buchert <tomasz@debian.org> python-pyelftools (0.23-1) unstable; urgency=low * Initial release (Closes: #778933)

    Advertisement
    Advertisement