python-pyclamd_0.3.16-1_all.deb


Advertisement

Description

python-pyclamd - Python interface to the ClamAV daemon

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pyclamd
Package version: 0.3.16
Package release: 1
Package architecture: all
Package type: deb
Installed size: 48 B
Download size: 9.92 KB
Official Mirror: archive.ubuntu.com
This package adds virus detection capabilities to Python software in an efficient and easy way, thanks to the ClamAV antivirus toolkit.

Alternatives

    Download

    Source package: pyclamd

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pyclamd deb package:
      # sudo apt-get install python-pyclamd

    Files

    • /usr/lib/python2.7/dist-packages/pyClamd-0.3.16.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/pyClamd-0.3.16.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/pyClamd-0.3.16.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/pyclamd/__init__.py
    • /usr/lib/python2.7/dist-packages/pyclamd/pyclamd.py
    • /usr/share/doc/python-pyclamd/changelog.Debian.gz
    • /usr/share/doc/python-pyclamd/copyright

    Changelog

    2015-11-02 - Scott Kitterman <scott@kitterman.com> pyclamd (0.3.16-1) unstable; urgency=medium [ Scott Kitterman ] * New upstream release * Remove uupdate from debian/watch, no longer relevant when using git-dpm * Update Homepage: field in debian/control with new upstream url [ SVN-Git Migration ] * Migrate packaging to git with git-dpm

    2015-06-20 - Scott Kitterman <scott@kitterman.com> pyclamd (0.3.15-1) unstable; urgency=medium [ Gianfranco Costamagna ] * New upstream release (Closes: #789390) * Bump standards version to 3.9.6 without further change * Drop patches, upstreamed. * Use PYBUILD_NAME=pyclamd - remove .install files * Remove documentation, not ship anymore in the package. * debian/rules: remove clean target override [ Scott Kitterman ] * Add python-setuptools and python3-setuptools to build-depends * Update debian/watch for new upstream location at pypi using the pypi.debian.net redirector * Run wrap-and-sort

    2015-03-12 - Andrey Rahmatullin <wrar@debian.org> pyclamd (0.3.9-2) unstable; urgency=medium * Team upload. * Fix import on Python 3 (Closes: #780337)

    2014-07-13 - Scott Kitterman <scott@kitterman.com> pyclamd (0.3.9-1) unstable; urgency=medium * New upstream release - Drop debian/patches/build_no_clamd.patch, fixed upstream * Add debian/patches/examples-print-fix.patch to fix python3 compatibility in examples * Added doc-base registration files

    2014-07-06 - Scott Kitterman <scott@kitterman.com> pyclamd (0.3.8-1) unstable; urgency=medium [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Scott Kitterman ] * New upstream release * Add debian/patches/build_no_clamd.patch to fix python3 exception syntax error and make it possible to build without clamd installed * Move clamav-daemon from Depends to Recommends (Closes: #645872) * Update debian/copyright * Drop obsolete get-orig-source rule and add debian/watch * Convert from CDBS/pysupport to dh/dh-python/pybuild * Add new python3-pyclamd binary and appropriate build-depends * Add .install and .docs files so new files are appropriately installed * Bump standards version to 3.9.5 without further change * Bump compat and debhelper version to 9 * Add myself to uploaders

    2010-10-24 - Siegfried-Angel Gevatter Pujals <rainct@ubuntu.com> pyclamd (0.2.2-1) unstable; urgency=low * New upstream release: - Replaced deprecated string exceptions with classes. - Added a timeout option to socket operations to avoid blocking. - Code improvements (PEP-8 compliance, new private helper functions). * debian/rules: - Updated get-orig-source (don't take the changelog since it's outdated, and replace GPL2 with LGPL3, ensure indentation is correct -unexpand-). - Don't try to install CHANGELOG as it has been removed. * debian/control: - Bump Standards-Version to 3.9.1. * debian/copyright: - Update copyright years and change license from GPL2+ to LGPL3+. * Remove debian/patches, the string exceptions change has been accepted upstream.

    2010-06-06 - Siegfried-Angel Gevatter Pujals <rainct@ubuntu.com> pyclamd (0.1.1-2) unstable; urgency=low [ Siegfried-Angel Gevatter Pujals ] * debian/control: - Swap Maintainer/Uploader fields. - Bump Standards-Version from 3.7.3 to 3.8.4. * debian/copyright: - Replace "(C)" with "©". - Change GPL to GPL-2. * debian/source/format: - Change source format to "3.0 (quilt)". * debian/patches/string-exceptions, debian/patches/series: - Change exceptions from strings to classes, for python2.6+ compatibility; thanks to Julien Danjou for reporting (Closes: #576694). [ Sandro Tosi ] * debian/control - Switch Vcs-Browser field to viewsvn.

    2008-02-16 - Siegfried-Angel Gevatter Pujals (RainCT) <rainct@ubuntu.com> pyclamd (0.1.1-1) unstable; urgency=low * Initial release (Closes: 466133).

    Advertisement
    Advertisement