python-pyclamav_0.4.1-8build1_amd64.deb


Advertisement

Description

python-pyclamav - Python bindings to ClamAV

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pyclamav
Package version: 0.4.1
Package release: 8build1
Package architecture: amd64
Package type: deb
Installed size: 32 B
Download size: 7.87 KB
Official Mirror: archive.ubuntu.com
This package adds virus detection capabilities to Python software, thanks to the ClamAV antivirus toolkit without the need for running clamav-daemon. For virus scanning with clamav-daemon, python-pyclamd is an available alternative.

Alternatives

    Download

    Source package: python-clamav

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pyclamav deb package:
      # sudo apt-get install python-pyclamav

    Files

    • /usr/lib/python2.7/dist-packages/pyclamav-0.4.1.egg-info
    • /usr/lib/python2.7/dist-packages/pyclamav.x86_64-linux-gnu.so
    • /usr/share/doc/python-pyclamav/README.txt
    • /usr/share/doc/python-pyclamav/changelog.Debian.gz
    • /usr/share/doc/python-pyclamav/copyright

    Changelog

    2016-02-17 - Matthias Klose <doko@ubuntu.com> python-clamav (0.4.1-8build1) xenial; urgency=medium * No-change rebuild for clamav transition.

    2016-02-05 - Scott Kitterman <scott@kitterman.com> python-clamav (0.4.1-8) unstable; urgency=medium [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Scott Kitterman ] * Bump standards version to 3.9.7 without further change * Use https: vice git: for Git-Vcs in debian/control * Remove obsolete python-clamav transitional package * Clean up ancient Breaks/Replaces/Provides * Delete gpl.txt from debian/docs to eliminate shipping duplicate license file * Update Homepage field in debian/control * Update debian watch to explain upstream situation and override debian-watch-file-missing-version lintian warning * Update debian/rules to use dh 7 format and bump compat/debhelper version to 9 * Add explicit build depends on dh-python * Use pybuild

    2012-06-25 - Scott Kitterman <scott@kitterman.com> python-clamav (0.4.1-7) unstable; urgency=low * Add support for dpkg-buildflags in debian/rules * Bump standards-version to 3.9.3 without further change * Move python-clamav transitional package to section oldlibs * Drop unneeded python:Provides

    2011-12-04 - Scott Kitterman <scott@kitterman.com> python-clamav (0.4.1-6) unstable; urgency=low * Build python-clamav transitional package in binary-indep target (Closes: #650789) * Add build-arch and build-indep targets * Enhance package description * Bump standards version to 3.9.2 without further change

    2011-03-11 - Scott Kitterman <scott@kitterman.com> python-clamav (0.4.1-5) unstable; urgency=low * python-pyclamav Breaks python-clamav (<< 0.4.1-4~) instead of Conflicts * Add debian/watch * Fix misspelling of package in the last changelog entry

    2011-02-19 - Scott Kitterman <scott@kitterman.com> python-clamav (0.4.1-4) unstable; urgency=low * Switch to dh_python2 - Drop build-depends on python-support - Version build-depends on python-all-dev - Add X-Python-Version - Add ${python:Breaks} - Replace dh_pysupport in debian/rules with dh_python2 * Rename binary to python-pyclamav (Closes: #507858) - Add transitional package in debian/control - Adjust target of setup.py install in debian/rules * Add install-layout=deb * Drop alternate depends on clamav-data as it is no longer updated * Drop redundant build-depends on python

    2010-10-03 - Scott Kitterman <scott@kitterman.com> python-clamav (0.4.1-3) unstable; urgency=low * Use correct DPMT address for maintainer * Add vcs-* fields to debian/control

    2010-09-22 - Scott Kitterman <scott@kitterman.com> python-clamav (0.4.1-2) unstable; urgency=low * Agreed maintainer change to Debian Python Modules Team - Add myself to uploaders - Thanks to Cédric Delfosse for his work maintaining python-clamav * Acknowledge NMU (Closes: #524645) - Thanks to Imre Gergely * Convert to source format 3.0 (Quilt) to add patch system - Convert existing inline change to debian/patches/clamav-095-compat.patch * Improve debian/copyright * Add Homepage to debian/control and bump standards version to 3.9.1.0 without further change * Remove obsolete debian/pycompat file

    2009-04-18 - Imre Gergely <gimre@narancs.net> python-clamav (0.4.1-1.1) unstable; urgency=low * Non-maintainer upload. * Build against libclamav6/clamav 0.95 - modified pyclamav.c source to use the new API functions - cleaned up some old code for clamav 0.75 - updated Build-Depends

    2008-05-06 - Cédric Delfosse <cedric@debian.org> python-clamav (0.4.1-1) unstable; urgency=low * New upstream release

    Advertisement
    Advertisement