python-pychart_1.39-7.1_all.deb


Advertisement

Description

python-pychart - Python library for creating high quality charts

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pychart
Package version: 1.39
Package release: 7.1
Package architecture: all
Package type: deb
Installed size: 419 B
Download size: 63.94 KB
Official Mirror: archive.ubuntu.com
PyChart is a Python library for creating high quality Encapsulated Postscript, PDF, PNG, or SVG charts. It currently supports line plots, bar plots, range-fill plots, and pie charts. Because it is based on Python, you can make full use of Python's scripting power. You need to have ghostscript installed for PNG generation and X11 displaying.

Alternatives

Provides

  • python2.7-pychart

Conflicts

  • python2.3-pychart
  • python2.4-pychart

Replaces

  • python2.3-pychart
  • python2.4-pychart

    Download

    Source package: python-pychart

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pychart deb package:
      # sudo apt-get install python-pychart

    Files

    • /usr/lib/python2.7/dist-packages/PyChart-1.39.egg-info
    • /usr/lib/python2.7/dist-packages/pychart/__init__.py
    • /usr/lib/python2.7/dist-packages/pychart/area.py
    • /usr/lib/python2.7/dist-packages/pychart/area_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/arrow.py
    • /usr/lib/python2.7/dist-packages/pychart/arrow_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/axis.py
    • /usr/lib/python2.7/dist-packages/pychart/axis_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/axis_x_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/axis_y_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/bar_plot.py
    • /usr/lib/python2.7/dist-packages/pychart/bar_plot_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/basecanvas.py
    • /usr/lib/python2.7/dist-packages/pychart/canvas.py
    • /usr/lib/python2.7/dist-packages/pychart/category_coord.py
    • /usr/lib/python2.7/dist-packages/pychart/chart_data.py
    • /usr/lib/python2.7/dist-packages/pychart/chart_object.py
    • /usr/lib/python2.7/dist-packages/pychart/color.py
    • /usr/lib/python2.7/dist-packages/pychart/color_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/coord.py
    • /usr/lib/python2.7/dist-packages/pychart/doc_support.py
    • /usr/lib/python2.7/dist-packages/pychart/empty_docs.py
    • /usr/lib/python2.7/dist-packages/pychart/error_bar.py
    • /usr/lib/python2.7/dist-packages/pychart/error_bar_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/fill_style.py
    • /usr/lib/python2.7/dist-packages/pychart/fill_style_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/font.py
    • /usr/lib/python2.7/dist-packages/pychart/generate_docs.py
    • /usr/lib/python2.7/dist-packages/pychart/gs_frontend.py
    • /usr/lib/python2.7/dist-packages/pychart/interval_bar_plot.py
    • /usr/lib/python2.7/dist-packages/pychart/legend.py
    • /usr/lib/python2.7/dist-packages/pychart/legend_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/line_plot.py
    • /usr/lib/python2.7/dist-packages/pychart/line_plot_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/line_style.py
    • /usr/lib/python2.7/dist-packages/pychart/line_style_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/linear_coord.py
    • /usr/lib/python2.7/dist-packages/pychart/log_coord.py
    • /usr/lib/python2.7/dist-packages/pychart/object_set.py
    • /usr/lib/python2.7/dist-packages/pychart/pdfcanvas.py
    • /usr/lib/python2.7/dist-packages/pychart/pie_plot.py
    • /usr/lib/python2.7/dist-packages/pychart/pie_plot_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/pngcanvas.py
    • /usr/lib/python2.7/dist-packages/pychart/pscanvas.py
    • /usr/lib/python2.7/dist-packages/pychart/pychart_types.py
    • /usr/lib/python2.7/dist-packages/pychart/pychart_util.py
    • /usr/lib/python2.7/dist-packages/pychart/range_plot.py
    • /usr/lib/python2.7/dist-packages/pychart/range_plot_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/rose_plot.py
    • /usr/lib/python2.7/dist-packages/pychart/scaling.py
    • /usr/lib/python2.7/dist-packages/pychart/svgcanvas.py
    • /usr/lib/python2.7/dist-packages/pychart/text_box.py
    • /usr/lib/python2.7/dist-packages/pychart/text_box_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/theme.py
    • /usr/lib/python2.7/dist-packages/pychart/tick_mark.py
    • /usr/lib/python2.7/dist-packages/pychart/tick_mark_doc.py
    • /usr/lib/python2.7/dist-packages/pychart/typechecker.py
    • /usr/lib/python2.7/dist-packages/pychart/version.py
    • /usr/lib/python2.7/dist-packages/pychart/x11canvas.py
    • /usr/lib/python2.7/dist-packages/pychart/zap.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/AvantGarde_Book.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/AvantGarde_BookOblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/AvantGarde_Demi.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/AvantGarde_DemiOblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Bookman_Demi.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Bookman_DemiItalic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Bookman_Light.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Bookman_LightItalic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Courier.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Courier_Bold.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Courier_BoldOblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Courier_Oblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_Bold.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_BoldOblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_Light.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_LightOblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_Narrow.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_Narrow_Bold.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_Narrow_BoldOblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_Narrow_Oblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Helvetica_Oblique.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/NewCenturySchlbk_Bold.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/NewCenturySchlbk_BoldItalic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/NewCenturySchlbk_Italic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/NewCenturySchlbk_Roman.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Palatino_Bold.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Palatino_BoldItalic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Palatino_Italic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Palatino_Roman.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Symbol.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Times_Bold.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Times_BoldItalic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Times_Italic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Times_Roman.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Utopia_Bold.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Utopia_BoldItalic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Utopia_Italic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/Utopia_Regular.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/ZapfChancery_MediumItalic.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/ZapfDingbats.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/__init__.py
    • /usr/lib/python2.7/dist-packages/pychart/afm/dir.py
    • /usr/share/doc/python-pychart/README
    • /usr/share/doc/python-pychart/changelog.Debian.gz
    • /usr/share/doc/python-pychart/copyright

    Changelog

    2015-08-22 - Matthias Klose <doko@debian.org> python-pychart (1.39-7.1) unstable; urgency=medium * Non-maintainer upload. * Build using dh-python. Closes: #786237.

    2009-04-10 - Debian Python Modules Team <python-modules-team@lists.alioth.debian.org> python-pychart (1.39-7) unstable; urgency=medium [ Piotr Ożarowski ] * Vcs-Browser and Homepage fields added * XS-Vcs-Svn field renamed to Vcs-Svn [ Sandro Tosi ] * debian/control - uniforming Vcs-Browser field - switch Vcs-Browser field to viewsvn - bump Standards-Version to 3.8.1 + added debian/README.source - added ${misc:Depends} to bin pkgs depends - replaced 'gs' (transitional package) with 'ghostscript' [ Luca Falavigna ] * Remove python-pychart.postinst and python-pychart.prerm, pysupport already invokes update-python-modules itself (Closes: #517067). * Add python-pychart-doc binary package (Closes: #507984). [ Raphael Hertzog ] * Remove myself from Uploaders.

    2007-02-22 - Santiago Ruano Rincón <santiago@debian.org> python-pychart (1.39-6) unstable; urgency=low [Piotr Ozarowski] * Added XS-Vcs-Svn field [Santiago Ruano Rincón] * Updated Build-Depends-Indep, using gs instead of gs-gpl|gs-esp * Recommends: gs. (Closes: #411516) * Updated description

    2006-07-24 - Raphael Hertzog <hertzog@debian.org> python-pychart (1.39-5) unstable; urgency=low * Add missing build-depends-indep. Closes: #379560

    2006-06-23 - Raphael Hertzog <hertzog@debian.org> python-pychart (1.39-4) unstable; urgency=low * Update for the new Python policy. Closes: #373341

    2006-06-01 - Santiago Ruano Rincón <santiago@debian.org> python-pychart (1.39-3) unstable; urgency=low * The "I'm tired of working on my thesis project" release. * Initial python-support transition, using cdbs to build the package. python2.{3,4}-pychart deleted. * Standards-Version updated to 3.7.2 * Added Debian Python Modules Team to Uploaders

    2006-04-20 - Santiago Ruano Rincón <santiago@debian.org> python-pychart (1.39-2) unstable; urgency=low * python2.3-pychart and python2.4-pychart, changed to arch: all (Closes: #357179) * New maintainer mail address

    2006-02-06 - Santiago Ruano Rincon <santiago@unicauca.edu.co> python-pychart (1.39-1) unstable; urgency=low * New upstream release * The documentation isn't builded, because it need latex2html, a non-free package.

    2006-02-02 - Santiago Ruano Rincon <santiago@unicauca.edu.co> python-pychart (1.37-6) unstable; urgency=low * Removed binary package for python2.2 (Closes: #351152)

    2005-11-03 - Santiago Ruano Rincon <santiago@unicauca.edu.co> python-pychart (1.37-5) unstable; urgency=low * Changed the description of python-pychart, from "empty dummy package" to "dependency metapackage".

    Advertisement
    Advertisement