python-pybiggles_1.6.6-3_amd64.deb


Advertisement

Description

python-pybiggles - Scientific plotting package for Python

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pybiggles
Package version 1.6.6
Package release 3
Package architecture amd64
Package type deb
Installed size 212 B
Download size 43.50 KB
Official Mirror archive.ubuntu.com
Biggles is a Python module for creating publication-quality 2D scientific
plots. It supports multiple output formats (postscript, x11, png, svg, gif),
understands simple TeX, and sports a high-level, elegant interface. It's
intended for technical users with sophisticated plotting needs.

Alternatives

Package Version Architecture Repository
python-pybiggles_1.6.6-3_i386.deb 1.6.6 i386 Ubuntu Universe
python-pybiggles - - -

Requires

Name Value
libc6 >= 2.4
libplot2c2 >= 2.6
python >= 2.7~
python << 2.8
python-numpy >= 1:1.8.0
python-numpy-abi9 -
python:any >= 2.7.5-5~

Provides

Name Value
python2.7-pybiggles -

Download

Type URL
Binary Package python-pybiggles_1.6.6-3_amd64.deb
Source Package python-biggles

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pybiggles deb package:
    # sudo apt-get install python-pybiggles

Files

Path
/usr/lib/python2.7/dist-packages/python2_biggles-1.6.6.egg-info
/usr/lib/python2.7/dist-packages/biggles/__init__.py
/usr/lib/python2.7/dist-packages/biggles/_biggles.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/biggles/biggles.py
/usr/lib/python2.7/dist-packages/biggles/config.ini
/usr/lib/python2.7/dist-packages/biggles/config.py
/usr/lib/python2.7/dist-packages/biggles/confit.py
/usr/lib/python2.7/dist-packages/biggles/contour.py
/usr/lib/python2.7/dist-packages/biggles/func.py
/usr/lib/python2.7/dist-packages/biggles/geometry.py
/usr/lib/python2.7/dist-packages/biggles/hammer.py
/usr/lib/python2.7/dist-packages/biggles/matlab.py
/usr/lib/python2.7/dist-packages/biggles/libplot/__init__.py
/usr/lib/python2.7/dist-packages/biggles/libplot/libplot.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/biggles/libplot/renderer.py
/usr/lib/python2.7/dist-packages/biggles/libplot/tex2libplot.py
/usr/share/doc/python-pybiggles/README
/usr/share/doc/python-pybiggles/README.Debian
/usr/share/doc/python-pybiggles/changelog.Debian.gz
/usr/share/doc/python-pybiggles/copyright
/usr/share/doc/python-pybiggles/examples/example-matlab.py
/usr/share/doc/python-pybiggles/examples/example1.py
/usr/share/doc/python-pybiggles/examples/example2.py
/usr/share/doc/python-pybiggles/examples/example3.py
/usr/share/doc/python-pybiggles/examples/example4.py
/usr/share/doc/python-pybiggles/examples/example5.py
/usr/share/doc/python-pybiggles/examples/example6.py
/usr/share/doc/python-pybiggles/examples/example7.py
/usr/share/doc/python-pybiggles/examples/example8.py
/usr/share/doc/python-pybiggles/examples/example9.py

Changelog

2015-08-19 - Piotr O┼╝arowski <piotr@debian.org>
python-biggles (1.6.6-3) unstable; urgency=medium
* Team upload.
* Convert from dh_pysupport to dh_python2 (Closes: #785974)
* let dh_numpy generate correct dependency on python-numpy package
* Bump Standards Version to 3.9.6:
build-arch and build-indep targets added in debian/rules
2013-07-14 - Luca Falavigna <dktrkranz@debian.org>
python-biggles (1.6.6-2) unstable; urgency=low
* Team upload.
[ Luca Falavigna ]
* Remove obsolete XB-Python-Version field.
* Remove obsolete pycompat file.
[ Jakub Wilk ]
* Don't run dh_python, which is obsolete (Closes: #715304).
* Use canonical URIs for Vcs-* fields.
* Remove DM-Upload-Allowed; it's no longer used by the archive
software.
* Drop obsolete Conflicts/Replaces with python2.3-biggles and
python2.4-biggles.
2010-06-02 - Deepak Tripathi <apenguinlinux@gmail.com>
python-biggles (1.6.6-1) unstable; urgency=low
* New maintainer. (Closes: #553074)
* New upstream release.
* debian/control
+ added DMUA field.
+ keeping under python module group.
+ bumped standard version to 3.8.4 (no changes)
* debian/copyright
+ updated copyright information.
+ added Debian's copyright information.
* debian/rules
+ package installation path from biggles to pybiggles.
* Switch to dpkg-source 3.0 (quilt) format.
+ added debian/source/format.
2009-10-28 - Barry deFreese <bdefreese@debian.org>
python-biggles (1.6.4-5) unstable; urgency=low
* QA upload.
+ Set maintainer to Debian QA Group <packages@qa.debian.org>.
* Replace python-numeric dep and b-d with python-numpy. (Closes: #478456).
+ Replace Numeric.* calls with numpy.*.
* Remove suggests on python-numeric-ext.
* Add appropriate copyright holders to debian/copyright.
* Version path to license to GPL-2.
* Include python.mk in rules and add $(py_setup_install_args).
* Bump Standards Version to 3.8.3.
2007-02-04 - Ernesto Nadir Crespo Avila <ecrespo@debianvenezuela.org>
python-biggles (1.6.4-4) unstable; urgency=low
* New maintainer (closes: #379684). 
2006-08-14 - Matej Vela <vela@debian.org>
python-biggles (1.6.4-3) unstable; urgency=low
* QA upload.
* Remove `dummy package' from long description.  Closes: #381829.
* debian/README.Debian: Update for unversioned package names.
* debian/copyright: Remove leftover reference to python-adns.
* debian/watch: Add.
2006-08-09 - Michael Ablassmeier <abi@debian.org>
python-biggles (1.6.4-2) unstable; urgency=low
* QA Upload (Ack NMU's; Closes: #348514,#326234,#331003,#373514)
* Set Maintainer to QA Group; Orphaned:  #379684
* Remove [dummy package] from short description (Closes: #381829)
* Remove unnecessary dh calls in binary-indep.
2006-07-01 - Pierre Habouzit <madcoder@debian.org>
python-biggles (1.6.4-1.2) unstable; urgency=low
* Non-maintainer upload.
* Update package to the last python policy (Closes: #373514).
* Fix old FSF address.
2006-01-28 - Matej Vela <vela@debian.org>
python-biggles (1.6.4-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Drop the Python 2.2 package, and add a Python 2.4 one.  Thanks to
Andreas Jochens for the patch.  Closes: #326234.
* Rebuild for C++ transition.  Closes: #331003, #348514.
2004-07-10 - Peter Hawkins <peterh@debian.org>
python-biggles (1.6.4-1) unstable; urgency=low
* New upstream release.
* Acknowledged NMU.

See Also

Package Description
python-pybloomfiltermmap_0.3.14-0.1_amd64.deb Bloom filter (bloomfilter) for Python built on mmap
python-pycalendar_2.1~svn15020-1_all.deb iCalendar/vCard Library
python-pycallgraph_1.0.1-1_all.deb Python library that creates call graphs for Python programs
python-pycarddav_0.7.0-1_all.deb simple to use CardDAV Python library
python-pycassa_1.11.1-2_all.deb Client library for Apache Cassandra
python-pycha_0.7.0-2_all.deb chart-drawing library using Cairo
python-pychart-doc_1.39-7.1_all.deb Documentation for PyChart
python-pychart_1.39-7.1_all.deb Python library for creating high quality charts
python-pyclamav_0.4.1-8build1_amd64.deb Python bindings to ClamAV
python-pyclamd_0.3.16-1_all.deb Python interface to the ClamAV daemon
python-pycoast_0.5.2-1_all.deb Draw coastlines, borders and rivers on images
python-pycountry_1.8+ds1-0.1_all.deb ISO databases accessible from Python 2
python-pycryptopp_0.6.0.20120313-1build1_amd64.deb Python wrappers for the Crypto++ library
python-pydds_2.5.2+ddd105-1_amd64.deb bridge double dummy solver - Python extension
python-pydhcplib_0.6.2-3_all.deb Python DHCP client/server library
Advertisement
Advertisement