python-pyao_0.82-5build1_amd64.deb


Advertisement

Description

python-pyao - Python interface to the Audio Output library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-pyao
Package version 0.82
Package release 5build1
Package architecture amd64
Package type deb
Installed size 69 B
Download size 9.39 KB
Official Mirror archive.ubuntu.com
This module makes the libao (Audio Output) functions available
in Python. With this module you can write Python applications
that use the cross platform audio output library.

Alternatives

Package Version Architecture Repository
python-pyao_0.82-5build1_i386.deb 0.82 i386 Ubuntu Universe
python-pyao - - -

Requires

Name Value
libao4 >= 1.1.0
libc6 >= 2.2.5
python << 2.8
python >= 2.7
python2.7 -

Provides

Name Value
python2.7-pyao -

Download

Type URL
Binary Package python-pyao_0.82-5build1_amd64.deb
Source Package pyao

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pyao deb package:
    # sudo apt-get install python-pyao

Files

Path
/usr/lib/pyshared/python2.7/aomodule.so
/usr/lib/python2.7/dist-packages/aomodule.so
/usr/share/doc/python-pyao/README
/usr/share/doc/python-pyao/README.Debian
/usr/share/doc/python-pyao/changelog.Debian.gz
/usr/share/doc/python-pyao/copyright
/usr/share/doc/python-pyao/examples/test.py

Changelog

2012-10-08 - Colin Watson <cjwatson@ubuntu.com>
pyao (0.82-5build1) quantal; urgency=low
* Rebuild for new armel compiler default of ARMv5t.
2011-12-11 - Luca Falavigna <dktrkranz@debian.org>
pyao (0.82-5) unstable; urgency=low
* QA upload.
* Switch to format 3.0 (quilt).
* debian/patches/*:
- Convert inline patches to quilt ones.
* debian/compat:
- Bump compatibility level to 8.
* debian/control:
- Bump X-Python-Version to >= 2.5.
- Bump Standards-Version to 3.9.2.
- Drop Breaks: ${python:Breaks} field, no longer needed.
- Add debug package.
* debian/rules:
- Pass --dbg-package to dh to build the debug package.
2011-06-23 - Colin Watson <cjwatson@debian.org>
pyao (0.82-4) unstable; urgency=low
* QA upload.
* Upgrade to debhelper v7 and convert to dh.
* Convert to dh_python2 (closes: #616957).
* Remove article from start of short description (thanks, Lintian).
2010-04-26 - Adam D. Barratt <adam@adam-barratt.org.uk>
pyao (0.82-3) unstable; urgency=low
* QA upload.
* src/aomodule.{c,h}:
+ Add a driver_id property to ao_Object, allowing building with libao4
which has made the ao_device structure opaque.  Thanks, Julien Cristau.
(Closes: #577345)
+ Use "i" in format strings when referring to arguments of type "int".
Thanks, Philipp Jocham.  (Closes: #492917)
+ Fix FTBFS with Python 2.5.  Thanks to Philipp Jocham for the patch.
(Closes: #492772)
* debian/copyright: Use correct path to the common-licenses copy of
version 2 of the GPL.
* debian/control:
+ Add ${misc:Depends}.
+ Bump Standards-Version to 3.8.4; no changes necessary.
2008-07-18 - Matthias Klose <doko@debian.org>
pyao (0.82-2.1) unstable; urgency=low
* NMU. Rebuild to move files to /usr/share/pyshared. Closes: #490516.
2008-03-04 - Thomas Viehmann <tv@beamnet.de>
pyao (0.82-2) unstable; urgency=high
* QA upload.
* Fix python memory handling. Closes: #468985.
* Set Maintainer to QA Group.
* Bump standards to 3.7.3 (No changes).
* Introduce debheler debian/compat
* Enhance debian/copyright.
2006-07-16 - Matthias Klose <doko@debian.org>
pyao (0.82-1.2) unstable; urgency=low
* Add build dependency on python-central.
2006-07-02 - Luis Rodrigo Gallardo Cruz <rodrigo@nul-unu.com>
pyao (0.82-1.1) unstable; urgency=low
* NMU
* Upgraded to new python policy using pycentral (closes: #373549)
2003-12-11 - Christopher L Cheney <ccheney@debian.org>
pyao (0.82-1) unstable; urgency=low
* Maintainer upload.
2003-08-13 - Josselin Mouette <joss@debian.org>
pyao (0.82-0.1) unstable; urgency=low
* NMU.
* New upstream release.
- Fixes pytone breakage (closes: #202671).
- No more multi-line strings (closes: #201001).
* Correct debian/copyright.
* Standards-version it 3.6.0.
* Require debhelper 4.1.62.
* Build with python 2.3.

See Also

Package Description
python-pyassimp_3.2~dfsg-3_all.deb 3D model import library (Python bindings)
python-pyatspi2_2.18.0+dfsg-3_all.deb Transitional package for assistive technology Python bindings
python-pyatspi_2.18.0+dfsg-3_all.deb Assistive Technology Service Provider Interface - Python bindings
python-pyaudio-doc_0.2.8-1build2_all.deb Documentation for Python bindings for PortAudio v19
python-pyaudio_0.2.8-1build2_amd64.deb Python bindings for PortAudio v19
python-pyavm_0.9.2-3_all.deb Python module to handle Astronomy Visualization Metadata Standard
python-pybabel_1.3+dfsg.1-6_all.deb tools for internationalizing Python applications (transitional dummy package)
python-pybiggles_1.6.6-3_amd64.deb Scientific plotting package for Python
python-pybloomfiltermmap_0.3.14-0.1_amd64.deb Bloom filter (bloomfilter) for Python built on mmap
python-pycalendar_2.1~svn15020-1_all.deb iCalendar/vCard Library
python-pycallgraph_1.0.1-1_all.deb Python library that creates call graphs for Python programs
python-pycarddav_0.7.0-1_all.deb simple to use CardDAV Python library
python-pycassa_1.11.1-2_all.deb Client library for Apache Cassandra
python-pycha_0.7.0-2_all.deb chart-drawing library using Cairo
python-pychart-doc_1.39-7.1_all.deb Documentation for PyChart
Advertisement
Advertisement