python-poppler_0.12.1-8.1_amd64.deb


Advertisement

Description

python-poppler - Poppler Python bindings

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-poppler
Package version: 0.12.1
Package release: 8.1
Package architecture: amd64
Package type: deb
Installed size: 144 B
Download size: 26.22 KB
Official Mirror: archive.ubuntu.com
This package includes Python bindings for LibPoppler. It is needed to run programs written in Python and using Poppler set. LibPoppler is a PDF rendering library based on xpdf PDF viewer, and used by kpdf and evince PDF viewers.

Alternatives

Provides

  • python2.7-poppler

    Download

    Source package: python-poppler

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-poppler deb package:
      # sudo apt-get install python-poppler

    Files

    • /usr/lib/pyshared/python2.7/poppler.so
    • /usr/lib/python2.7/dist-packages/poppler.so
    • /usr/share/doc/python-poppler/changelog.Debian.gz
    • /usr/share/doc/python-poppler/copyright
    • /usr/share/doc/python-poppler/examples/demo-poppler.py

    Changelog

    2013-07-14 - gregor herrmann <gregoa@debian.org> python-poppler (0.12.1-8.1) unstable; urgency=low * Non-maintainer upload. * Fix "FTBFS: /usr/bin/make: unrecognized option '--prefix|--exec- prefix|--includes|--libs|--cflags|--ldflags|--extension-suffix|-- help|--configdir'": apply Ubuntu changes done by Matthias Klose: - Fix typo calling python-config --includes. (Closes: #711800)

    2012-04-29 - Andrea Gasparini <gaspa@yattaweb.it> python-poppler (0.12.1-8) unstable; urgency=low * uploading to unstable

    2012-04-06 - Andrea Gasparini <gaspa@yattaweb.it> python-poppler (0.12.1-7) experimental; urgency=low * debian/patches: + series: re-enabled poppler-0.18.diff (Closes: #651388) + added 03-psfilenew.diff (Closes: #662890) + added 04-closefiles.diff (LP: #316722) * debian/control: bump standard version to 3.9.3 * debian/rules: rewrite with dh7,added autoreconf (Closes: #558532)

    2011-12-12 - Andrea Gasparini <gaspa@yattaweb.it> python-poppler (0.12.1-6) unstable; urgency=low * patches/series: reverted applied poppler-0.18.diff (Closes: #651388)

    2011-12-09 - Andrea Gasparini <gaspa@yattaweb.it> python-poppler (0.12.1-5) unstable; urgency=low * Specified version of GPL in debian/copyright * Add poppler-0.18.diff: Drop API which does not exist any more in poppler 0.18. Thanks to Martin Pitt for the patch.(LP: #900707) (Closes: #651388)

    2011-07-04 - Jakub Wilk <jwilk@debian.org> python-poppler (0.12.1-4) unstable; urgency=low * Team upload. * Upload to unstable.

    2011-07-02 - Jakub Wilk <jwilk@debian.org> python-poppler (0.12.1-3) experimental; urgency=low * Team upload. * Convert to source format 3.0 (quilt). * Apply patch to follow Poppler 0.15 API changes (closes: #628047). Thanks to Pino Toscano for the bug report, Tom Callaway from Fedora for the patch, and to Michael Biebl for digging up the patch. + Bump minimum required Poppler version to 0.15. * Add build-arch and build-indep targets.

    2011-05-22 - Jakub Wilk <jwilk@debian.org> python-poppler (0.12.1-2) unstable; urgency=low * Team upload. [ Piotr O┼╝arowski ] * Explicitly set source format to 1.0. [ Jakub Wilk ] * Protect for loops in debian/rules with set -e (closes: #626625). * Bump standards version to 3.9.2 (no changed needed). * Remove unused build-dependency on cdbs.

    2009-10-24 - Andrea Gasparini <gaspa@yattaweb.it> python-poppler (0.12.1-1) unstable; urgency=low * New upstream release * Updated watch file and homepage field. * debian/rules: fixed for python2.6

    2009-03-08 - Josselin Mouette <joss@debian.org> python-poppler (0.10.0-1) unstable; urgency=low [ Sandro Tosi ] * debian/control - switch Vcs-Browser field to viewsvn [ Josselin Mouette ] * New upstream release. Closes: #518611. + Bump build-dependency on poppler. + Add missing build-dependency on atk. * Switch to python-support.

    Advertisement
    Advertisement