python-phply_0.9.1-4_all.deb


Advertisement

Description

python-phply - PHP parser written in Python using PLY

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-phply
Package version: 0.9.1
Package release: 4
Package architecture: all
Package type: deb
Installed size: 351 B
Download size: 38.75 KB
Official Mirror: archive.ubuntu.com
phply is a parser for the PHP programming language written using PLY, a Lex/YACC-style parser generator toolkit for Python. With this parser you can: - Convert PHP code to Python - Run PHP templates in a Python environment - Learn more about parsing "industrial" languages, warts and all This is the Python 2 version of the package.

Alternatives

    Download

    Source package: python-phply

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-phply deb package:
      # sudo apt-get install python-phply

    Files

    • /usr/lib/python2.7/dist-packages/phply-0.9.1-nspkg.pth
    • /usr/lib/python2.7/dist-packages/phply/parsetab.py
    • /usr/lib/python2.7/dist-packages/phply/phpast.py
    • /usr/lib/python2.7/dist-packages/phply/phplex.py
    • /usr/lib/python2.7/dist-packages/phply/phpparse.py
    • /usr/lib/python2.7/dist-packages/phply/pythonast.py
    • /usr/lib/python2.7/dist-packages/phply-0.9.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/phply-0.9.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/phply-0.9.1.egg-info/namespace_packages.txt
    • /usr/lib/python2.7/dist-packages/phply-0.9.1.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/phply-0.9.1.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/phply-0.9.1.egg-info/top_level.txt
    • /usr/share/doc/python-phply/README.md
    • /usr/share/doc/python-phply/changelog.Debian.gz
    • /usr/share/doc/python-phply/copyright
    • /usr/share/python/ns/python-phply

    Changelog

    2015-09-28 - Gianfranco Costamagna <locutusofborg@debian.org> python-phply (0.9.1-4) unstable; urgency=medium * Change Python*:Depends to python:Depends.

    2015-08-26 - Gianfranco Costamagna <locutusofborg@debian.org> python-phply (0.9.1-3) unstable; urgency=medium * tweak fix-tests.patch to fix another python-3 issue. (Closes: #796519) thanks Chris Lamb for the useful bug report! * Update my uid.

    2015-07-18 - Gianfranco Costamagna <costamagnagianfranco@yahoo.it> python-phply (0.9.1-2) unstable; urgency=low * python3-phply.pyremove, exclude tests from install. (Closes: #792766) thanks Andreas Beckmann for the bug report.

    2015-06-15 - Gianfranco Costamagna <costamagnagianfranco@yahoo.it> python-phply (0.9.1-1) unstable; urgency=low [ Gianfranco Costamagna ] * New upstream release (actually this is just a tarball rename). * Move myself as maintainer and collab-maint as VCS. - DPMT rejected my team application. [ Piotr O┼╝arowski ] * Add watch file. * python-phply.pyremove, exclude tests from install. (Closes: #788838) - An equivalent fix will come directly in dh_python.

    2015-02-16 - Gianfranco Costamagna <costamagnagianfranco@yahoo.it> python-phply (0.9.1~alpha-1) unstable; urgency=low * Initial release (Closes: #719811).

    Advertisement
    Advertisement